No 4G LTE only 3G Samsung Galaxy S5
Answered

 I think I may need a new sim card sent to me. Have been only getting 3G service not 4G LTE on my Galaxy S5. Who do I contact about this problem?

0

Comments

6 comments
  • Hey Mike,

    Sorry to hear you're not getting the speeds you should be. Is this a newer problem or one that's been going on for a while now ? 

    When you have the chance, can you try re-activating your phone by dialing ##72786#, the phone should reboot, say it's activating and checking prl/firmware and then reboot once more.

    Once that's done, try testing the phone out for a couple of hours and see if there's any change, if not, just let us know. 

    0
    Comment actions Permalink
  • Tried the ##72786#. The phone reboots I do get the LTE symbol, but when it reboots the second time it goes back to 3G. I tried doing the ##72786# again but got the same results.

    0
    Comment actions Permalink
  • Can you go to your phone settings and look for something similar to More > Mobile Networks > Preferred Network type or Network mode and check to see what option is selected and what choices you have available ? 

    0
    Comment actions Permalink
  • I have the phone set at LTE/CDMA. My other options are Automatic and GSM/UMTS.

    0
    Comment actions Permalink
  • What happens when you select Automatic? Do you get any errors?

    0
    Comment actions Permalink
  • I have had this exact same issue for the last year and a half.  I've read every forum and tried every suggestion from Ting.  If you solve the problem, you are a magician.  My phone is set to network automatic(no errors and I tried every other network), I've reactivated with the symbol appearing and disappearing(like you described), PRL update done, Profile update done, latest version of Andriod done, new sim card done, etc.  Of course the next question is, "Are you in a 4G/4GLTE service area"?  My wife's S4 gets 4GLTE while in the same room. I haven't enjoyed 4G since 2015.  Good luck.  

    0
    Comment actions Permalink

Please sign in to leave a comment.