Switched to Flex Plan, lost Google Voice voicemail

It's possible it hasn't worked for longer, because I changed my Google Voice number and nobody calls my actual Ting number.  Almost all calls are forwarded from Google Voice.

I can't find any current, up-to-date instructions for forwarding on busy/no-answer to Google Voice voicemail on the new X3 SIM with a Flex plan.



  • Hey Chad, 

    I had this exact same issue when I moved over to my X3 SIM. The proper dialer code to fix it is:

    * * 0 0 4 * [Your Google Voice Number] #

    Once you've called this, you'll receive a confirmation via a USSD message. You can then continue to use Google Voice as normal.

    If you want to continue to receive calls on the phone when people dial the number, make SURE you have forwarding turned on in Google Voice settings. If it seems to not be working, remove it and re-add it.

  • With the 1 prefix on the GV number or just the bare 10 figures l digits?

  • I'm not sure it matters inside the NANP but I did put the 1 in front of my GV number and it's worked great since.

  • Awesome, this works. Where did you find this code?

  • This just worked for me as well after my switch to the Flex plan and the X3 SIM.  Thanks!

  • This doesn't work for me and I've contacted Ting multiple times about this issue and they keep ping ponging me around with different SIM Cards, I had to switch to the X3 SIM which then put me on the T-Mobile network in my area but they tried sending me a V1 SIM but that simply doesn't work in my area.

    Can anyone help me? I've used Google Voice for years and was a bedrock to managing things.

    I have a Samsung S8 that was formerly Verizon now on the flex plan with a X3 SIM that works with calls/data/text but simply will not forward to my GV #, I've tried so many codes, all error out and was allegedly escalated to T-Mobile but no word back for weeks...


Please sign in to leave a comment.