USB OTG disabled on Samsung Galaxy S II Epic 4G Touch
Answered

One of the features I found appealing about the Samsung Galaxy S II line was the fact that - with an OTG adapter cable - it could connect to USB thumb drives. Unfortunately, I didn't pursue this before purchase and I've discovered that - intentionally or inadvertently - the Sprint edition has this feature disabled. I'm still very happy with the phone generally and I can work around this - but I would like to ask Ting to do whatever they can to address this. (If I have to wait for Ice Cream Sandwich, so be it.)

One thing I did notice is that in Settings > Storage, much of the internal storage of the phone shows up as "USB Storage" instead of "Device memory" and I suspect this may have something to do with it - if the phone already "thinks" it has a USB storage device attached, another one may not be possible.

4

Comments

4 comments
  • George, I'm assuming you've already received the E4gT from Ting? Would you do me a huge favor and check under Menu->Settings->About Phone->Kernel Version and tell me what these phones are shipping with. I'm still waiting on mine to come in the mail and I'm trying to get a headstart on specific research for rooting and hacking these phones. I'm interested to see if it is running the same build as the sprint versions.

    0
    Comment actions Permalink
  • My phone may have been updated OTA since it came out of the box - but the version currently on my phone is 2.6.35.7-SPH-D710.EL29-CL852097

    Hope that helps.

    0
    Comment actions Permalink
  • Thanks a bunch. EL29 is a stock Sprint image... so that's a good thing.

    0
    Comment actions Permalink
  • Did this issue ever gett resolved because I use the same phone and would like to add a a flash drive if possible.  Thanks.

    0
    Comment actions Permalink

Please sign in to leave a comment.