Cannot connect to the web when Huawei Express is in 4G mode
Answered

When my Huawei Express is in 4G mode and when I try to access any web page, I'm redirected to:

    https://deviceselfservice.sprint.com/dsa/4gportal/welcome_input.action;jsessionmid=....

that shows the message:

    "Oops - we can't complete this activation over the phone. Please take it to the nearest Sprint store to get it activated."

When I set it back to "3G only", I can access any website without a problem.

Isn't 4G access included in the plan?  Is Sprint blocking my access erroneously?

Thanks you.

0

Comments

5 comments
  • Hi Komei,

    You should now be able to access 4G services on your device. There was an initial problem enabling 4G for your device, which I've correct. Sorry about that!

    Can you give it a test and let me know?

    • Mike Whitman
    0
    Comment actions Permalink
  • I greatly appreciate your quick response, Mike!  Now the device is working fine with 4G.  I just tested it with Speedtest.net and I got 6024 kbps down and 1443 kbps up.  (I'm in our office building in downtown SF.)  I'm quite happy.

    0
    Comment actions Permalink
  • I'm having a similar issue with my newly activated Huawei Express.  When "4G Preferred" is selected as the WAN connection mode, it does not switch to 3G even with no 4G signal, and there is no internet  connection via 4G.  It connects fine to the internet when I set it to "3G Only."  Thanks!

    0
    Comment actions Permalink
  • Hello! I am having the same issue with my new Huawei device. I am unable to connect to the internet on the 4G setting from zip code 94109, even though the coverage map says 4G is readily available.  I connect fine with 3G, but really got the device to utilize 4G. Can someone help? Thanks!

    0
    Comment actions Permalink
  • Hi Stephanie,

    I just sent you an email about this, and hopefully that will get this working for you. If not, please get back in touch with us and we'll try something else.

    Take care

    0
    Comment actions Permalink

Please sign in to leave a comment.