LG Optimus error 67 "update profile" button not working - Now what?
Answered

After system update on lg optimus (sprint version) to 2.3.3, I'm getting error 67 profile update message but doesn't seem to work -just keeps coming back and sometimes if I push update button, tapping screen icons as well as pushing home row buttons stop working.  Dismiss seems to allow the phone to work fine - I have text only plan and texts go out still.  I have mobile data set to on and I am always connected to a wifi router that works with browser / play store etc.  The problem is more of an annoyance than anything right now as it will pop up right in the middle of doing other things.

 

-complete message on screen:

Error code 67

Unable to establish wireless data connection. Please select update Profile to correct this problem. If the problem persists, please contact your mobile phone company. -Update profile- or -Dismiss- are the buttons 

13

Comments

64 comments
  • Hi Megan, I've sent you a new e-mail. Can you please check your spam folder as well, to make sure that the message isn't ending up in there.

    0
    Comment actions Permalink
  • I don't have data roaming on either. This is on my second phone, my first phone had this message and cleared up.

    0
    Comment actions Permalink
  • Hi Sandra, I'll be sending you an e-mail shortly so we can work on this together.

    0
    Comment actions Permalink
  • I just received this phone and I keep getting that error, can someone help me?

    0
    Comment actions Permalink
  • Hey Joshua,

    Looks like you have data access disabled on your account which would be the reason why you are unable to update the profile.

    You can enable data by logging into your account -> Device Settings tab -> select your phone number -> enable "Can access the internet".

    Make sure you have data enabled in your device as well (Settings -> Wireless & Networks -> Mobile Networks-> enable data). Try updating from there!

    0
    Comment actions Permalink
  • I wanted to turn data off on this phone and only use wi-fi, but it seems like if I turn data off in my account settings, the phone starts to get the error again.  So basically, I have to pay at least the $3 data fee every month.  Or is there something I am missing?  I was hoping if I updated the profile I could then turn off data.  $3 isn't that big of a deal, but this phone is for my sister who isn't that phone savy and may mistakely go over the 100 MB limit and I'll get charged another $10.

    0
    Comment actions Permalink
  • @Linda - you need to make sure data is turned off on the phone as well. Settings > Wireless and Networks > Mobile Networks > Mobile data un-checked

    0
    Comment actions Permalink
  • I need help!

    So i just recently got an LG marquee phone from ting and i tried to activate it, when i went to activate it i got an 67 error thing, ive tried to restart the phone but nothing seems to work!

    Please help!

    0
    Comment actions Permalink
  • Hi Felipe, I've sent you an e-mail so we can troubleshoot your device. Keep an eye on your inbox.

    0
    Comment actions Permalink
  • I have a android and no matter what I do  I get this error code 67 and I fel lik just throwing against the wall or something, excpcialy when im talking to the utility company or something because then I haft to go back threw all thos boring recordings, so if u know how 2 get rid of it please lt me know would b 4-ever grateful.

    0
    Comment actions Permalink
  • Hi Penny,

    I totally understand your frustration. The Error code 67 occurs when your phone is unsuccessful connecting to the Sprint data network. I will be sending you a help request shortly where we can work on getting that removed.

    0
    Comment actions Permalink
  • Error 67 means that your devices are having trouble connecting to our network and may not have been fully activated yet. To remedy this, you will need to reset and update the network settings on your device. This is equivalent to the activation steps that are found here.

    0
    Comment actions Permalink
  • I am getting error 67 repeatedly every few seconds when I use my phone.  I am not in roaming, that i can tell, and I went through the steps of setting up my phone again, but nothing works.  Any help would be appreciated.

    0
    Comment actions Permalink
  • Hey Tanya,

    It could be the roaming network your phone is connected to - can you ensure that the roaming network in your phone settings is set to "Automatic" instead of Sprint only?

    0
    Comment actions Permalink
  • help me I have the same issue with my phone it is so annoying I hate my phone needs to be fixed otherwise sprint will always get bad review from me. I hate phones to start with but this is rediculous, I have tried everything and it won't stop stupid error code 67!

    0
    Comment actions Permalink
  • Hey Mika, We would love to give you a hand, but I cannot track down your account. Send us an email from your Ting account details and someone will be in touch to get you up and running. 

    0
    Comment actions Permalink
  • I'm also having the problem of error 67 popping up every couple seconds. The instructions for "fully" activating my device won't work (MSL number not recognized). How do I fix this?

    Right now data is turned off for this device in my account (to be sure I can force it to wifi - is there a way to get it to give me an alert whenever it uses non-wifi?). Roaming is set to data off. Mobile networks is set to data off.

    0
    Comment actions Permalink
  • Hi Mathias. Error 67 means that your phone is not able to connect to the data network. That's mostly likely happening because your device hasn't been fully activated yet.

     To make sure your phone is fully activated, please turn off wi-fi and enable cellular data under your Ting account by going to the Device Settings tab upon logging in at ting.com. Activation requires your device to connect to the cellular data network, so it won't complete if you have data/internet turned off.

     Also, please keep in mind that we don't offer data roaming, so you need to be in an area with Sprint coverage to complete activation. We recommend having at least 2-3 bars to ensure you'll have a solid connection to the data network before doing so.

    If you wish to disable mobile data under your Ting account after completing activation, please make sure that you also do it on your device. Disabling that under your Ting account but leaving mobile data on under your phone's menu might result in your device still trying to connect unsuccessfully and returning error 67.

     The most likely reason for not having your device recognize the MSL is because the phone (including its MSL) has been modified from its original settings. You could try 000000 or 123456 instead of the MSL we sent you to see if it will go through.

     There are some third-party apps at the Google Play store which will notify you when not using wi-fi, so it might be worth taking a look at them to get those notifications.

     Let us know if you're able to complete activation and clear error 67 by following the above steps. If not, we'll go ahead and create a support request on your behalf so we can communicate through email.

    0
    Comment actions Permalink
  • I have tried some of these suggestions... the ones that seemed relevant to my phone/settings/connectivity; however, I am still encountering Error 67.  I've enabled data -even though I don't want data - just for the update... Do all of these requests need to be handled individually?

    0
    Comment actions Permalink
  • Hey Michael!

    Sorry to hear that! I saw that you sent in a support request so I responded to that for you looking for a little bit of information.

    I imagine this is something relating to Background Data that we can disable from within the phone's settings.

    0
    Comment actions Permalink
  • Thanks for the help Paraic.  It's looking fixed...  :-)

    0
    Comment actions Permalink
  • I need help i have the same problem can someone send me a step by step to fix it

    0
    Comment actions Permalink
  • Hi Michael,

    If you keep getting error code 67 when trying to update the profile (and data services are enabled on your Ting account), you may need to reset the carrier settings of your device. Here are the steps:

    Turn on mobile data and turn off WiFi.

    Go to the phone application

    Enter in # # 7 2 7 8 6 #

    If prompted, enter your device's MSL (found on your Ting account under device settings)

    device should reboot.

    Please contact our support team if you need any additional help.

    0
    Comment actions Permalink
  • Hi...just activated an lg optimus s & grtting this same error...disabled data roaming & still popping up. Please help!

    0
    Comment actions Permalink
  • Says mobile network state: disconnected.

    0
    Comment actions Permalink
  • Hi Eva,

    I took a look at your account and data was disabled on your device. I went ahead and enabled it for you, data should be working on your device now! Contact our support team if you need any additional help! 

    0
    Comment actions Permalink
  • Hi! I'm working with a Kyocera Kona that I originally turned data off for, but tried to keep picture messaging activated. This has hosed the phone, and now that I've reactivated data, completed the carrier wipe, and reset the picture URL, I still get an error code 67 when I try to access an MMS. The messages themselves seem to put my phone in limbo (they are not downloading properly) so that I cannot send texts without rebooting the phone after receiving an MMS.

    0
    Comment actions Permalink
  • Hey KaLeena!

    Let's try to get a Profile Update on the Kona to get rid of that Error 67. Just make sure you have the data on when doing this:

    1. From the home screen, press the OK/Menu key.

    2. Scroll to Settings and press the OK/Menu key.

    3. Scroll to Others and press the OK/Menu key.

    4. Scroll to Data Settings and press the OK/Menu key.

    5. With Update Data Profile highlighted, press the OK/Menu key.

    6. Press OK.

    7. Reboot the device

     

    That should help you. If not I'd recommend opening a support request with us so that we can help you troubleshoot.

    0
    Comment actions Permalink
  • I'm having the same problem and when I press update profile a message pops up and says authentication error my phone has been off for 2 months and I been using wifi since then and the message just poped up today someone please help!!!!!

    0
    Comment actions Permalink
  • Hey Jessica,

    In that case, we recommend you first check that your number is up and running under your account without any issues or limitations. You can log into your account and go to Device Settings to confirm all your services are all enabled.

    Once that's checked, please go through the activation cycle to ensure your phone is still set up correctly.

    If the issue persists, submit a support request so we can investigate that with you.

    0
    Comment actions Permalink

Please sign in to leave a comment.