MMS not working
Answered

I have an LG optimus s and a Samsung Transfor ultra.  Both are refurbished.  When I try to send a text message it says message sent.  However they have not been received on the other phone.  Can  you help me fix this issue?

0

Comments

85 comments
  • I forget to mention that the text part works but cannot send or receive pictures.

    0
    Comment actions Permalink
  • The MMSC URL likely needs to be reprogrammed. I'll email you the instructions shortly.

    0
    Comment actions Permalink
  • I'm having the same issue on my HTC Evo 4g LTE. Would it be possible for you to send me the instructions as well?

     

    Thanks

    Mike

    0
    Comment actions Permalink
  • Hi Mike, 

    I've e-mailed you these instructions! Let me know through the support ticket if everything is now working for you.

    0
    Comment actions Permalink
  • I believe I'm having the same issue on my Galaxy Nexus, could I get the instructions too?

     

    Thanks,

     

    Ryan

    0
    Comment actions Permalink
  • Will do Ryan. Expect an email shortly.

    0
    Comment actions Permalink
  • I've had this same problem with my refurbished Transform Ultra. Could I also get the instructions?

    Thanks,

    Jolyn

    0
    Comment actions Permalink
  • No problem, an email is on its way.

    0
    Comment actions Permalink
  • Hi, I am having the same problem with my wife's Galaxy Victory, it can send plain texts but not MMS. It can receive MMS, it just can't send them. Please can you contact me with the fix? Thanks! Kevin

    0
    Comment actions Permalink
  • Kevin, we'll send you an email shortly.

    0
    Comment actions Permalink
  • Hi I am having the exact same problem with the MMS, can u send me the instructions as well?

    0
    Comment actions Permalink
  • Its with all my phones, the 2 Sanyo Zio's and an LG Marquee

    0
    Comment actions Permalink
  • Hey Baby,

    Considering this thread has seen so many replies and requests for those steps, I figure it makes sense to go ahead and post them here.

    Now I am posting generic steps, and they may be slightly different for some phones. If anyone reading this finds doesn’t work for them, the proper steps for your device are likely only slightly different, and we may be able to help you with that if you let us know.

    1. Open the dialer
    2. Dial # #3282# (# #DATA#)
    3. Touch "Edit Mode"
    4. Enter your Master Subsidy Lock (MSL) and touch "OK"
    5. Touch "Advanced"
    6. Touch "MMS Server URL"
    7. Enter " http://mms.plspictures.com" then touch "OK"
    8. Press the "MENU" button
    9. Touch "Commit Modifications"

    To retrieve your MSL, log into your Ting account and click on Your Devices. If you click on the phone number you're configuring, you'll find the MSL on the left.

    As I mentioned, there may be some variation between phones, but the gist of this will always be the same. As an example, not all phones will use identical naming conventions for things like "Edit mode," or "Commit modifications," and some phones will require you to click a button named MMSC, but that's about it.

    I hope that helps!

    0
    Comment actions Permalink
  • So I have a Galaxy Victory and am having the same problem. Also what does the MSL really mean? How do I found out what mine is?

     

    Thanks!

    0
    Comment actions Permalink
  • Emily, the settings for the Galaxy Victory are: Dial # # 3 2 8 2 # -> Edit -> <MSL> -> OK -> Others -> MMSC URL -> mmsc -> change to  http://mms.plspictures.com -> OK

    Send test MMS message to activate

     

    Your MSL can be found under Your Devices in the Ting Dashboard.

    0
    Comment actions Permalink
  • Also, MSL means "Master Subsidy Lock" and it's the code that helps you get into your phone's internal, hidden settings :)

    0
    Comment actions Permalink
  • Well this certainly saved me some trouble! I can confirm that Andrew's method worked for my Galaxy Victory.

     

    Awesome work folks!

    0
    Comment actions Permalink
  • EDIT -> Although it seems I can't receive them (???)

    My girlfriend got my picture(s), but I haven't gotten hers yet. She claims she sends them all the time to others. Maybe it just takes her provider longer (?).

    If they end up coming through, I'll come back and edit this.

    0
    Comment actions Permalink
  • Almost forgot to come back here and post - but anyhow, I can receive MMS messages now (thanks Katie!). All I had to do was a profile update and a PRL update.

    Works like a charm.

     

    Cheers!

    0
    Comment actions Permalink
  • On the Galaxy S3, the MMSC URL is under "Others" instead of "Advanced". Just posting for the benefit of other GS3 users.

    Ting really should try to rectify this on their phones. The problem is easy to fix, but let's face it, non-tech-savvy users are unlikely to figure it out.

    0
    Comment actions Permalink
  • Just recently purchased two Galaxy Victories.  The instructions above were most helpful.  Not being able to receive pictures via text would have been a possible deal-breaker for my wife.  

    You have eased her pain.  :)  

     

     

    0
    Comment actions Permalink
  • Not sure if it's related, but I can't send pics anymore although I still seem to be able to receive them. I tried to send a pic last night and this morning and I keep getting the same error "Message Not Sent". I thought perhaps the settings I had entered might have somehow gotten blown away, but I checked and my MMSC URL is still correct. Anybody else having this problem?

    In looking at Joseph Bryan's post above, it seems that a "profile update and a PRL update" might do the trick, although his problem was with receiving whereas mine is with sending. How do I do these updates?

    0
    Comment actions Permalink
  • Roger, first just try doing a regular reboot to see if that helps. If it doesn't, I'd suggest a full carrier reset, which will do all of the above in one step. To do so, first make sure the phone isn't connected to Wifi (and isn't roaming), then dial: # # 72786 #

    After the phone reboots it should go through a handsfree activation (which covers the Profile Update) as well as a PRL update.

    0
    Comment actions Permalink
  • I figured out the problem. I had actually tried rebooting my device last night and it didn't fix the problem. However, I decided to try again based on your advice. This time after rebooting and launching my texting app (GO SMS Pro), I was greeted with a message that the texting app was updated, and the very first bug listed that this update fixes is the inability to send pics via text. So the problem was with GO SMS Pro! Anyhow, thanks for the prompt help response.

    0
    Comment actions Permalink
  • Good to know for future reference, and you're very welcome.

    0
    Comment actions Permalink
  • Hey guys, trying to go through the steps Andrew posted for my Galaxy Victory, but I can't seem to get past the MSL. I see the MSID and the ESN/MEID on my device page, but neither of those seem to work. Any ideas?

    Side note, the issue is the same as the original. MMS picture messages show sent on my device, but the target never receives them.

    0
    Comment actions Permalink
  • Hi Francisco, I've sent you an email so we can begin troubleshooting your Galaxy Victory.

    0
    Comment actions Permalink
  • Can someone please send me instructions for the Galaxy Victory and the Galaxy SIII?  I changed the settings on my dashboard, but the MMS messages still won't send.

    Thanks.

    0
    Comment actions Permalink
  • The settings for both are pretty much the same, Michael: Dial # # 3 2 8 2 # -> Edit -> <MSL> -> OK -> Others -> MMSC URL -> mmsc -> change to  http://mms.plspictures.com -> OK

    Send test MMS message to activate

     Your MSL can be found under Device Settings in the Ting Dashboard.

    0
    Comment actions Permalink
  • Another "me too" for Samsung S3, please.

    0
    Comment actions Permalink

Please sign in to leave a comment.