Why isn't picture messaging working for me?
Answered

Hi, I have a LG Optimus s. Picture messaging has been working for some time. Now, suddenly when I receive picture texts when I click the download message button it says: "Message expired or not available." This has happened multiple times. and I checked and the message does not expire till in July! I tried this on other picture messages and the result is the same. Furthermore, when I send picture messages, it says the message was sent but when I ask my friends they say they have no received it. Picture messaging is not working for me and if this is a continuous problem I may need to change plans. Please help.

Thankyou 

6

Comments

31 comments
  • Hi Anna,

    Please try the following:

    Dial # # 3 2 8 2 # without the spaces, then tap MMSC, then EDIT. Enter your MSL (available on your account at ting.com - click on Your Devices, then on the device itself, and the MSL is on the left side of the page!). Tap Set URL and change it to http://mms.plspictures.com then tap OK!

    Send test MMS message to activate

    0
    Comment actions Permalink
  • i tried this process and my samsung galaxy s3 phone still cannot send picture messages

    0
    Comment actions Permalink
  • Hi Moonbill,

    Try doing a profile and PRL update now - turn WiFi off and turn 3G on, then go to Settings > About Phone/System Updates > Update PRL and then Settings > About Phone/System Updates > Update Profile

    0
    Comment actions Permalink
  • i tried this and my phone asked me for a service code

     

    0
    Comment actions Permalink
  • Rebecca, that would be referring to your MSL, which you can find in your Ting Dashboard by clicking on Your Devices then on the device in question.

    0
    Comment actions Permalink
  • I tried both of these remedies, however, I am still unable to open picture messages. It say s"Your request can not be processed, internal error". I have it set so I can get pictures in my account online. Any other suggestions? Thank you!

    0
    Comment actions Permalink
  • Derick, if you've already checked the MMSC URL, then you're likely experiencing the issue that a few of our customers using LG Marquee phones have been having recently based on the error you posted. We're looking into it, though we don't have a timeframe for the solution yet.

    0
    Comment actions Permalink
  • It looks like it's not confined to LG Marquee phones. I have a LG Optimus Elite and I am having the same problem.

    What are the multimedia attributes supposed to be? Mine are all pointing to rtsp.vog.sprintpcs.com and pd.vog.sprintpcs.com. but you suggested in another step setting the URL for MMSC to mms.plspictures.com.

     

    0
    Comment actions Permalink
  • Belay my last. Got it working.

    0
    Comment actions Permalink
  • How did you get it working?

    0
    Comment actions Permalink
  • I have an optimus G and I have my mmsc settings correct. This is a big let down. It was initially working and now it won't. When I try to send a picture message my phone says, "service not activated on network." Please contact me when you have a fix.

    0
    Comment actions Permalink
  • Hi Oliver, have you made sure that the picture messaging service is enabled on your line? This is in the Device Settings tab on your Ting.com account. It sounds like this is where the message may be coming from. If this isn't enabled on your line, picture messages won't be going through. The "Can send and receive picture & video messages" setting needs to checked for picture messaging.

    0
    Comment actions Permalink
  • I've been having the same issue on my 2 LG marquees as well. It is really starting to bug me as most of the pictures I am missing are somewhat important and people don't always email them to me instead.

    Is there a known fix for this yet on the LG Marquee?

    0
    Comment actions Permalink
  • Matthew,

    You can call or email Ting to get your issue resolved.

    0
    Comment actions Permalink
  • Hi Matthew, I'll be sending you an e-mail right away so we can troubleshoot your picture messages together. Please keep an eye on your inbox.

    0
    Comment actions Permalink
  • I recently signed up with an LG Optimus S, and I can't get picture messaging to work, either. I have done all the steps listed in the first response of this thread, and made sure to activate picture messaging on my Ting account settings. This is particularly frustrating when someone sends a group text from an iPhone, because I just don't get it.

    0
    Comment actions Permalink
  • Hi Damien, Sorry to hear you are having some issues with MMS messaging. Expect an email from a member of our support team who will be happy to get your messaging working!

    0
    Comment actions Permalink
  • So I realized that I never actually sent the test picture message to activate. I did that, and now I can open my picture messages. Problem solved! I <3 ting.

    0
    Comment actions Permalink
  • i have an lg optimus s and my picture messaging isnt working right now... i have reset the url to tings one, reset it and tried to open a message... did not work. then i went to update the PRL and profile. the PRL updated sucessfully but when i go to update profile it gives me the "client error. please try again later". so here i am a couple hours later and "try again" PRL updates but profile does not. yes i am on the 3g and not on wifi. yes mms messaging is activated on my phone. help!

    0
    Comment actions Permalink
  • update: i can send pictures but i cannot receive and open it.

    0
    Comment actions Permalink
  • Hi Meena,

    I'm going open up a help request for you, be on the look out for an email!

    0
    Comment actions Permalink
  • I tried updating the MMS settings on my phone and having updated PRL and Profile I still cant send picture messages. I have an HTC Evo 4G LTE.

    0
    Comment actions Permalink
  • Hi Shalonda,

    Please make sure that you have your mobile data or wifi turned on so the picture messages can be sent. Your picture-video messaging feature is checked off on your account, and we've sent you an e-mail with some troubleshooting steps.

     

     

    0
    Comment actions Permalink
  • I followed these instructions (although when I went to do the PRL update there was no button for it…)  I thought I had it.  I sent myself some pictures and it worked but I had friends also send me some and they never showed up.  On top of that a message I already had that was set to expire n 2 days disappeared. Before I would get a download button, then when I tried to download it would say message expired or unavailable.  Now I get nothing (except from my phone)

    0
    Comment actions Permalink
  • Hi McKenna,

    Make sure that you are connected to a mobile network (3G/4G) when you are trying to send or receive an MMS message. It is also a good idea to update the profile of your device (found under settings > system updates or settings > about phone > system updates). I'm going to follow up with you via a help request, keep an eye out for an email!

    0
    Comment actions Permalink
  • HI, I just got an HTC EVO Shift 4G and the messaging has been working great, but whenever I try to send a picture message, it doesn't work. 

    0
    Comment actions Permalink
  • Hi Erica! Have you checked to see if picture messaging is enabled for your phone?  It's in Device Settings in your Ting account. You need to have both "Can access the Internet" and "Can send and receive picture & video messages" checked in order for picture messages to work.  If this doesn't solve the problem, please get in touch!

     

    0
    Comment actions Permalink
  • Just tonight my wife (on the same account) is having troubles sending mms pictures over the texting functions on her phone.

    She has a HTC EVO Shift 4G (As 3 other people in this form show) and at first it just would not work.

    We found that if she has the basic 3G enabled, and wifi DISABLED that the pictures are sent fast and accurately.

    I don't know why the phone or the service would be confused with this in either way.

    Is there anyone who has found why this would work?

    I also did the PRL reset, I checked the URL and that is correct, everything seems to be working.

    But to send pictures we have to turn off the local wifi settings.

    0
    Comment actions Permalink
  • Some phones or apps will either not send MMS over Wi-Fi or need data enabled in order to send MMS.

    I needed to enable Data on my Nexus 5 in order to send a group message from Hangouts because Google apps assume no Internet connection with data disabled, even if the phone cannot use data.

    0
    Comment actions Permalink
  • I understand the data needs to be enabled.

    It is enabled on the phone.

    The problem exists where the data is on, PRL is updated, MSL URL is correct and yet through all that if the wifi is on the picture message will not go through.

    I guess the easy fix is to shut off wifi and then send the picture but the problem is every time we try to use the app we have to turn on and off features.

    That is not very helpful when the answer is just to not use wifi.

    The real problem I am trying to figure out is why this is happening now and before for at least a year or more the phone worked fine.

    AND nothing was changed on the phone settings wise and this comes out of no where. Send pictures over and over and then one day it doesn't work.

    There has to be a reason why a features just stops working.

    The 4G network shows best peak where we live too so I do not know.

    0
    Comment actions Permalink

Please sign in to leave a comment.