using my phone in canada
Answered

I am travelling in canada (from michigan, us) and want to text message people in canada and the us but cannot. I get a message "currently unable to send your message. message will be sent when the service becomes available." I also cannot make or recieve phone calls. I am using a samsung galaxy s4.

 

Sean

1

Comments

13 comments
  • Hey Sean,

    I'm really sorry that text messages aren't working! In order to get this resolved as quickly as possible, I'm going to reach out to you through a help request, since the troubleshooting steps can include some sensitive information. Please check your email inbox momentarily! 

    -Chi

    0
    Comment actions Permalink
  • I'm currently having the same issue. Can you please help?

     

    0
    Comment actions Permalink
  • Hi Curt.  Sorry about the difficulty.  I've opened a support request to assist - please check your email!

    0
    Comment actions Permalink
  • I was informed that I had to perform updates to my phone - which required me to be connected to a US network, at which point I don't need functionality in Canada. at least my wifi still worked

    0
    Comment actions Permalink
  • For future reference, I have traveled to Canada (Niagara Falls & Toronto area) several times with no major issues using Ting for text or voice. I believe I tried data once just to see if it worked, but paying a $.50 per MB surcharge is a steep price.

    I tended to only use Wi-Fi for data usage while in Canada.

    0
    Comment actions Permalink
  • I wonder whether it is still a problem to make calls or send texts in Canada. If an update is needed, can I complete the update in the US before the trip? I have Samsung S3 phone. 

    0
    Comment actions Permalink
  • Here are a couple if tips.

    1. In your Ting dashboard. make sure the following options are checked:

         Allow international long distance Calls

         Allow North American long distance calls

         Can send text messages

         Can receive text messages

    1. Update the Profile & PRL on your phone to get the latest changes.

    2. Verify in your phone settings that you can place International long distance calls

    3. Ignore the text messages received from Sprint warning of their international rates. The Ting rates apply, not Sprint's/

    In Canada, Ting roams on Bell & Telus. There is no surcharge for texts. Voice had a $.15 per minute surcharge. If you choose to use data there is a $.50 per MB surcharge. I avoid data & MMS messages unless I am on Wi-Fi.

     

     

    0
    Comment actions Permalink
  • Hey Zaichun!  Bruce's tips are great. And yes, absolutely do the PRL update before you leave the US.  You should have no trouble using your phone in Canada; the charges are outlined here.  If you need any help completing the update, please get in touch.

    0
    Comment actions Permalink
  • Thanks, Wendy

    Some points above are from experience.

    When I first went to Canada as a Ting user, another Ting user in our group could not call because ther forgot to enable it on the dashboard. They could not update their phone without Sprint service, so they went through cell phone withdrawal for a few days.

    I remember calling Ting on Christmas Eve 2012 because I could not make calls on my Epic 4G. It turned out there were some settings on the phone that needed enabling for International calling. The Ting agent was very prompt and helpful during this stressful time.

    Just sharing so other have a more pleasant trip.

    0
    Comment actions Permalink
  • Thank you all. 

    I've updated my system and PRL. 

    I do have problem following Bruce's instruction: "1. In your Ting dashboard. make sure the following options are checked:". There are no options for me to check on my Ting.com dashboard. I tried two browsers: Chrome and Mozilla Firefox. 

    I get the sense that people rarely have problem using the phone in Canada and I shouldn't fret about it. 

    0
    Comment actions Permalink
  • My apologies.

    To get to your Ting Dashboard, click "Your Account" at the top of the page.

    Click the "Device settings" link.

    Click on the name of your phone. That will open a page where you can customize the access for that device. Do not forget to click "Save" at the bottom.

    Then, I recommend a Profile update on your phone to get those new settings.

     

    0
    Comment actions Permalink
  • Thank you very much for the detailed instructions. 

    0
    Comment actions Permalink
  • Followed Bruce's instructions above. Allowed international roaming in my phone setting. All worked as expected. 

    0
    Comment actions Permalink

Please sign in to leave a comment.