Anyone take the plunge on an M370 yet?

Who will be brave enough to order the first M370 for hacking use and see if both data profiles give correct password information?

2

Comments

45 comments
  • Hello Joey,

    I pre-ordered on the first day the M370 was available.It is now on a Fed-Ex truck and will arrive tomorrow.

    I will use it a  donor phone for my Evo 4G.

    Last night I ordered my copy CDMA Workshop (@$99), just waiting for the download link.

     

    I am SO ready to give this a shot.

    You can bet I will be here asking questions... and posting my notes on how to do this!

    0
    Comment actions Permalink
  • Wow, awesome! Please let me know if you are able to read both passwords for BOTH profiles. Each of the two profiles have two passwords, this is how 1X and 3G data works. Hopefully we don't have another Brio on our hands, where only the 1X profile passwords could be read (maybe it didn't have a 3G profile...?)

    I flashed my Sprint Nexus S 4G using DFS and QPST but have experience using an older version of CDMA Workshop. Let me know if you have any questions! I'd be happy to help where I can.

    0
    Comment actions Permalink
  • I also have HTC flashing experience, but I was trying to use a Verizon Incredible and data wouldn't work. Voice and texts did, however. Your Evo 4G is a Sprint phone, correct?

    0
    Comment actions Permalink
  • Joey,

    Will definitely let you know about my success with BOTH profiles.

    Yes, also have flashing experience.

    My Sprint Evo 4G is rooted and is running Team DIRT's Ice Cream Sandwich (really smooth/stable with great battery life)!

    This if my first time with CDMA Workshop, so yes I will ping you for help if needed,  

    Thanks for offering to help!

    0
    Comment actions Permalink
  • OK, . .  need some help.

    Can someone please point me in the right direction for finding the M370 windows drivers?

    I have googled and have not had any luck finding them.

    Thanks in advance!

    0
    Comment actions Permalink
  • Maybe try this? http://mustikamax.com/2012/03/21/samsung-m370-pc-suite-usb-driver-to-connect-for-windows-7-xp-and-vista/

     

    If that doesn't work, try downloading the DataPilot demo. The Evo3D guide here on Ting suggests buying DataPilot because it has drivers for various phones. (see step2: https://help.ting.com/entries/21281128-evo-3d-100-working-on-ting)

    0
    Comment actions Permalink
  • Here's a DataPilot demo: http://www.tucows.com/preview/421541

    0
    Comment actions Permalink
  • I actually used the Data Pilot demo to install the drivers for my Sanyo Vero, when I open up DFS now it says "Susteen cable" when my Vero is connected, which is the company that makes Data Pilot.

    0
    Comment actions Permalink
  • I was not able install the M370 PC Suite.

    I did successfully install the DataPiot demo software.

    After work tonight, I will to connect my M370 to my laptop and (fingers crossed) hope it works.

    Thanks for the DataPilot drivers!

    0
    Comment actions Permalink
  • I really think it should work - the Data Pilot website shows that their software has the same level of support for both the Vero, which I have successfully used as a donor, and the M370:

     

    http://www.datapilot.com/phonesupport/en_US/Sprint/Sanyo/2719/SCP-3820%20%28Vero%29/

    http://www.datapilot.com/phonesupport/en_US/Sprint/Samsung/3210/SPH-M370/

     

    Now let's just hope that the actual M370 phone lets you read both sets of data profile passwords...

    0
    Comment actions Permalink
  • Joey, Excellent!  thanks for checking.

    I did see the connection options for M370.  I see that they are the same are the Vero. So, we should be ok.

    I now feel more confident about opening up the box and try to connect to the M370.

    Now I am just waiting for my CDMA WS software license to arrive via email.

    0
    Comment actions Permalink
  • Still waiting? Try DFS in the meantime to see if you can at least get those profiles:

    Filename: DFS 4.0.0.4.rar

    http://www.cdmatool.com/Download

     

    Between DFS and QPST, I really don't think you need CDMA WS. Can you cancel your order if you paid through PayPal or some third party? It's probably much easier though, so it's up to you.

    0
    Comment actions Permalink
  • OK,

    Installed Data Pilot v5.  The laptop detects the M370. . .  The laptop then installs multiple Susteen device drivers (as expected).

    Open DataPilot, Before clicking "Auto Detect" I searched and see that the M370 is NOT listed in the devices.  I still clicked "Auto Detect" and it does not find the M370.

    I suspect that I will need to purchase Data Pilot v7 which DOES support the M370.

    I will do that later tonight (during opening ceremonies) and report back.

    0
    Comment actions Permalink
  • Looks like good news.

    Even though the DataPilot v5 did not see the phone, I still connected the demo version of CDMA Workshop.  I was able to see and read some of the basic info from the device. I was not able to get to the profile since you cannot see them on the demo version of CDMA WS.

    Will try DFS in a little while.

    0
    Comment actions Permalink
  • ok, need to get the SPC code (i think it is also known as the MSL) from Ting now

    0
    Comment actions Permalink
  • Put in a request online, they might get to you before the weekend. And on your HTC target phone, use this: https://play.google.com/store/apps/details?id=com.esccode.msl

    0
    Comment actions Permalink
  • Yes, Just put in a request for the M370 SPC code.  Oh well, they are closed for the weekend.  They too have families!  

    I already have my MSL (SPC) for my rooted Evo. So, I am good to go there.

     

    And a message to "Ben Lucier". . .

    Hi Ben, if you happen to be roaming this thread on the weekend and have a minute, I would appreciate the SPC code so I can move forward with the M370 as a donor for this Evo. Thanks!

    0
    Comment actions Permalink
  • Joey, the bottom line is "yes".

    Yes, Data Pilot v5 drivers work with the M370.

    This morning I connected the M370 to CDMA WS.  I attempted to save the NAM1 and NAM2 profiles. 

    CDMA gave me a message "Since the SPC code has not been provided, not all items will be read/saved".

    So, sounds like you have your answer. . .  and I will have my Evo 4G on Ting running early next week!

    0
    Comment actions Permalink
  • Is there an M.IP or data tab in CDMA WS ? That's where you'll find the HA and AAA passwords for your data to work. You will probably need MSL first though. Let me know if you run into any issues during the flash !

    0
    Comment actions Permalink
  • Ok, back home from the kid's soccer games.

    See below for a short dump of the "M.IP" dump from the NAM1 profile for the M370.

    To hide my personal info, I replaced the personal text with text between "<<" and ">>".

    BTW, Looks like no HA or AAA passwords with CDMA WS? Are there really passwords there?  If I were to export NAM1 and NAM2 profiles and import them into the Evo,   would the this not work because the HA and AAA passwords are missing?

    Not sure what to do next?

    Your thoughts?

    Thanks...

     

    [M.IP profiles]

    M.IP_NumberOfProfiles=6

    M.IP_ActiveProfile=1

    M.IP_RetryInterval=4

    M.IP_Behaviour=2

    M.IP_RegistrationRetries=1

    M.IP_DeRegistrationRetries=

    M.IP_RegExpAttemptReRegistration=30

    M.IP_RFC_AuthCalc=0

    M.IP_DataOptimization=1

    M.IP_RRQ_If_Traffic=1

    Profile0_ProfileEnabled=1

    Profile0_NAI=<<Hex MEID goes here>>@hcm.sprintpcs.com

    Profile0_T_NAI=

    Profile0_R_TunnelPref=1

    Profile0_HomeAddress=000.000.000.000

    Profile0_P.HA_Address=068.028.015.012

    Profile0_S.HA_Address=068.028.031.012

    Profile0_HA_SharedSecret_InputMode=S

    Profile0_HA_SharedSecret=

    Profile0_AAA_SharedSecret_InputMode=S

    Profile0_AAA_SharedSecret=

    Profile0_MN-HA_SPI=04D2

    Profile0_MN-AAA_SPI=04D2

    Profile0_DMU_Public=

    Profile0_DMU_Mobile=

    Profile1_ProfileEnabled=1

    Profile1_NAI=<<My Ting Cell # goes here>>@mvno102.sprintpcs.com

    Profile1_T_NAI=

    Profile1_R_TunnelPref=1

    Profile1_HomeAddress=000.000.000.000

    Profile1_P.HA_Address=255.255.255.255

    Profile1_S.HA_Address=068.028.089.076

    Profile1_HA_SharedSecret_InputMode=S

    Profile1_HA_SharedSecret=

    Profile1_AAA_SharedSecret_InputMode=S

    Profile1_AAA_SharedSecret=

    Profile1_MN-HA_SPI=04D2

    Profile1_MN-AAA_SPI=04D2

    Profile1_DMU_Public=

    Profile1_DMU_Mobile=

    0
    Comment actions Permalink
  • I think you should try DFS. It's free and read my passwords. For some reason I couldn't write them to my target phone with DFS, so I had to write them with QPST.

    you can try moving them over with CDMA WS, if data doesn't work then it's likely that those passwords didn't move.

    0
    Comment actions Permalink
  • Just connected the M370 with DFS 4.0.4.  

    Under "Moblie IP Main Settings" I read the phone's info.

    I can see all of the values for PROFILE1 and PROFILE2 except for the "AAA Shared Secret" and the "HA Shared Secret" passwords.  Bummer!

    The label for the two password fields says "Enter value in HEX", so I am not sure it would actually display a password value if it was there.  In your experience, would it display a value here?

    So, it sounds like my next option to install/use QPST and QXDM to get at those passwords?

    Any other thoughts before I go down that trail?

    Thanks for your help!

    0
    Comment actions Permalink
  • Get voice and texts working first - did you write all the other settings, ens, meid, etc? If that works, I would try to turn on the phone (NEVER have the donor and target phone on at the same time) and go to your system settings in the HTC and go to update profile. This didn't work for me, but some others have said it worked for them.

    If that doesn't work, you may have to do a memory dump of the M370 and pick through the bits for those HA / AAA passwords...

    Regarding the lack of HA/AAA passwords, did you send the MSL code before trying to read these values? If you did, I guess QPST is your last chance at reading them the easy way.

    0
    Comment actions Permalink
  • Joey,

    Thanks for your ideas!

    Here is what I will do next: (with fingers crossed that I can restore the old SPRINT values to the Evo if this does not work out. I have NOT cancelled the Sprint service on my Evo yet):

    1) Turn on M370 and get the ESN and MEID info. Then TURN off M370 and pull battery!

    2) Copy ESN + MEID from M370 to Evo

    3) Attempt to make a phone call to my home. Confirm that Caller ID shows my TING number and NOT my Sprint number.

    THEN

    4) Go to HTC Sense Settings and do an "Update Profile"

    5) Question: Should I also do an "Update PRL" while I am there? (I will hold off on that for now. If things do not work, I will try it.)

    6) Attempt to access the internet (with WiFi turned off!)

    6) If I DO get 3G Data, Connect the phone to CDMA Workshop to see if ...

    6.a) the "UserProfile-0 NAI" information from my OLD Sprint "<MySprint\_Info>@hcm.sprintpcs.com" to NEW Ting "<MyTING\_MEID>@hcm.sprintpcs.com" was changed as a result of the "Profile Update"

    6.b) the "UserProfile-1 NAI" information from OLD Sprint "xxx@sprintpcs.com" to NEW TING "xxx@mvno102.sprintpcs.com" was changed as a result of the "Profile Update"

    If data was been changed and I am getting TING "3G data"...then I am one happy guy!

    Otherwise, I will set ESN and MEID on Evo Back to SPRINT and then do a update profile. HOPE I can restore my Evo to the Sprint service... FOR NOW. :(

    Either way, I will keep trying!

    Thanks again for your help!

    0
    Comment actions Permalink
  • Joey,

    To answer your question. . . 

    Q: "Regarding the lack of HA/AAA passwords, did you send the MSL code before trying to read these values?"

    A: Yes, I have the MSL for both M370 and Evo 4G. I use the respective MSL everytime I connect to CDMA WS, DFS, and QPST.

    0
    Comment actions Permalink
  • **Latest Status... Here is what I did  (So far, CAN make Calls, BUT NO 3G Data)

    **1) Turned on M370 and got the ESN and MEID info. 

    2) Exported NAM1 and NAM2 profiles

    3) Then turned off the M370 and pulled the battery!

    4) Copied the ESN + MEID from M370 to Evo

    5) Imported the NAM1 and NAM2 profiles from the M370 into the Evo

    6) Turned off and pulled the battery on the Evo.  Then restarted it. 

    7) Successfully made a call!  Called my house and the confirmed that the Caller ID shows my TING number and NOT my Sprint number.

    THEN

    8) Attempted to update the PRL via "Settings > "PRL Update". Got error message "PRL could not be updated.  Please try again later.  If the problem persists, you may need to contact Customer Service.  Error Code: 1012".

    9) Then attempted to update the "Settings > Update Profile"

    I get the following two error messages for "Update Profile":

    A) "Error Code 67.  Registration Failure.  Your PCS Vision Username and or  Password may be incorrect. . . "

    B) "The profile update could not be completed.  Please try again later.  If the problem persists, you may need to contact customer service.  Error Code:1012"

    An interesting note:

    **Since I was having trouble getting the HA and AAA passwords from the M370 during my preparation, I did the following test.


    Before** cloning the M370 info to the Evo, I went into the Evo and typed ##3282# (##DATA#).

    Went into EDIT MODE in EPST.  Went into the DATA PROFILE section and deleted the HA Shared Secret and AAA Shared Secret passwords.

    Then clicked "Menu > Commit" to save the blanked passwords.

    Then (with WiFI turned off) I opened the Internet app and (as expected) the Evo would not connect to 3G data.  Something like "Error in Profile". 

    So to fix this, I  went to HTC Sense "Settings > Update Profile".  The profile was updated successfully.

    Once again, I opened the Internet app (with WiFI turned off) and surprisingly I DID SUCCESSFULLY connect to the internet using 3G data connection.  

    For some reason, when I attempt to update the PROFILE after I cloned the TING info to the SPRINT phone, I get error messages during the PROFILE update.  Very odd. 

    I did think about the fact that it is late here now (midnight).  So I will try to update the PROFILE and PRL settings in the morning. Maybe Sprint's servers are down for maintenance at the moment.  Probably wishful thinking.

    Any ideas are GREATLY appreciated.

    Thanks! 

    0
    Comment actions Permalink
  • OK,

    I got a dump of the NV-Items from the M370 and started reading through the dump.

    I looked for 6 or 8 character strings.

    I found 3 strings that were 8 characters long.  and 1 string that was 6 characters long.

    One by one, I tried each of them in HA and AAA field.

    For example, let's say the first 8 charcter string was KKMOOPRR.

    Using CDMA, I entered that string into the HA and AAA (since I did not know which one it was).

    Rebooted the phone and did a "Settings > Profile Update".

    None of the strings worked for me.  Big bummer!

    The odd thing is that when I attempted to get the NV-Items dump, the M370 always froze at 25% while doing the dump.

    I experienced this freeze regardless of the software (CDMA Workshop, DFS, QPST).  Always froze at 25%.

    Anyway, I feel like I am at the end of my rope.

    Unfortunately, I appear to be the only one trying to get the M370 working as a donor phone. 

    Well, such is life when working on the leading edge.

    Any other ideas?  TIA.

    BTW, I did submit a request to Ting support "requesting the HA and AAA Shared Secret passwords".

    Well another late night.  Good night for now.  :) 

    0
    Comment actions Permalink
  • did you use the QPST Memory Debug tool?

    once looking through the memory dump, you search for "mvno102" and then look for the word "secret" using a HEX editor (so it shows you plain English conversion on the right side). "secret" has been one of the passwords for all our phones. not sure if it's HA or AAA as I'm at work.

    0
    Comment actions Permalink
  • Ah! Thank you!

    I had not tried that yet.

    From what I recall, "secret" is for the HA.

    I will give QPST a try during my lunch break here at work.

    Will report back. 

    I really appreciate your advice! 

    0
    Comment actions Permalink
  • I tried dumping NV-Items memory using CDMA Workshop by Clicking the READ "NV Item" button on the Memory tab.

    I starts reading @ 0% . . . then without fail, it stops at 25% with a message "Phone has stopped responding".

    I get the same problem with other NV-Item readers.

    So at this point...

    1) I have a full dump, but the software thinks it is only 25% done.  OR

    2) I really only have 25% of the NV items dump.  In which case, I have hit another wall.

    Man, I this is starting to get very frustrating!

    Not sure what my next step is...  :(

    0
    Comment actions Permalink

Please sign in to leave a comment.