Samsung Galaxy S3 ESN Swap (from LG Optimus S)

I've (mostly) swapped an LG Optimus S (refurbished) donor phone over to my Sprint Galaxy S3.  However, I'm having some odd behavior with the 3G data.  I'm hoping someone can help me out!  Once I get the kinks worked out, I'd be happy to write up a step-by-step document as I'm guessing there are others who aren't patient enough for the BYOD to get here ;)

My problem:

I've got the Galaxy S3 up and running with the ESN and calling, texting, and data (both 1X and 3G).  However, it seems like my 3G connection doesn't work on certain towers.  When I'm at home (on an Airave still active directly through Sprint) it works fine on 3G (wifi disconnected of course).  In other areas on Sprint towers it works fine with 3G.  However, certain towers show full coverage and "Sprint" (i.e. not roaming) coverage, but my data connection fails with an authentication related error.

What I've done for the ESN swap:

1) Installed DFS (latest version of their freeware package)

2) Installed appropriate Samsung drivers (from Samsung site)

3) Installed appropriate LG drivers (from LG site)

4) Achieved connectivity to both phones through DFS

5) Located the SPC a.k.a. MSL for both phones (Ting was awesome, Sprint was a challenge as the phone wasn't on my account, but I got it)

6) Located the device PWD for each phone

7) Read settings for each phone and archived (screenshots in a Word doc)

8) Copied settings from my LG phone to the S3 (ESN&MEID, MDN, MSID, data profile username, HA IP's, and PRL)

9) *DID NOT* copy the AAA or HA keys from the LG Optimus or overwrite the AAA/HA keys on the S3

10) Performed an activation on the S3 by entering "##72786#"

This resulted in the phone getting updated programming information (from what I understand) and resulted in me having working phone and data.  However, as I mentioned above, my 3G still doesn't work on certain towers.  Does anyone know if the AAA / HA keys get provisioned when you do the "Activate" action?  I'm curious whether that's my problem, or whether it's something else.  I'd also love to know if it's imperative that I keep the old AAA / HA settings from the S3 (with original ESN) for use if I want to use the original ESN to activate it (and bring my donor Optimus S back to life) once Ting gets BYOD off the ground.

1

Comments

64 comments
  • As I mentioned, it says invalid ESN when I try to activate it at the url I listed earlier. The phone has always been mine and it has a clean ESN, so I am not sure what the problem could be. I paid over $350 to Sprint just to get out of my contract with them and I am 100% sure I have no balance with Sprint and its been like 5 months since I left. Grr. I hate that Ting doesnt have weekend support.

    0
    Comment actions Permalink
  • Sorry if I wasn't clear above -- you will need to wait another 4 hours before believing the activation response on the site. Errors are expected right now.

    However, in 4 hours, you can do that activation before resetting the phone.

    0
    Comment actions Permalink
  • Great Post! Thanks a lot It worked like a Charm.. 

    Only I issue I am having is the 3G data. I tried the ##786# to rest but no luck.. 

    when I do ##33284#, and then enter 777468, and then tap on EVDO Engineering Protocol, i get AAA: Fail :(.

    Its falling back to 1X data. I tried updating the profile and all but no luck. 

    I am flashing a phone into Sprint Network.

    0
    Comment actions Permalink
  • This is the aesthetic impression on the programs like Instagram and Pinterest which can be causing them to be to generate a buzz within the sphere of social bookmarking. You will discover a increased desire on the list of internet stores to Buy instagram followers buy instagram likes instagram followers instagram likes  and loves, to elevate their business from the thoughts of your target market inside a significantly greater way.

    0
    Comment actions Permalink

Please sign in to leave a comment.