Voice/MMS working, but not data: Samsung Galaxy SII Epic 4G Touch (SPH-D710)

I recently purchased a Samsung Galaxy SII Epic 4G Touch (SPH-D710) on Ebay to use on the Ting network.  This was advertised as a Sprint phone and I verified this with Sprint directly.

Working through Ting customer service, I was able to activate voice and MMS.  This required flashing the ROM to root the phone, determine the true MSL of the phone (the one supplied by Sprint was incorrect), and again flashing to the original ROM that came with the phone and restoring factory settings.  After entering in the correct phone number and MSID number, and then performing a carrier reset, I was able to get voice and MMS features working.

Ting customer service then then guided me through the following sequence to get the data authentication working, but no luck:

1) Tried a carrier reset ##72786# with no change.

2) Performed the master reset by performing ##786# and this did bring us to the correct options so we did the ##72786# reset again.  Once we perform the reset your sprint username or password is in correct message came back up.

3) Attempted to manual program the phone with your phone number and MSID of 3609362625, rebooted and received the same Error 131 authentication error. However, the voice and MMS were working at this point

4) Tried toggling the data services with no change.  The Update PRL and Update Profile also failed for authentication, displaying the same Error 131. 

Currently, I am still receiving 'Error 131' messages when the phone tries to activate:

*******************************

131 Error Code 131 Sign-in failed. Your username and/or password may be incorrect. Please try again. If this problem persists, you may need to contact Sprint. Mobile node failed authentication

*******************************

I am still unable to update the PRL or Profile, as I get the same error message.

Ting customer service has recommended that I post this problem on the Hacks forum, thus my post here.  Could this be as simple as calling Sprint and having them reset my user name and password, or is this something more esoteric?

Any solutions or suggested solutions would be much appreciated!

Thanks,

Tom

1

Comments

46 comments
  • I am sending you an email. Not sure if the error 131 was mentioned while you were talking to the agent as that one indicates that the password is incorrect for services. This is normally fixed by a profile update which is done through he over the air activation process after the resets you have mentioned.

    I'd like to get this checked out from a network level for you because this may be a device specific problem, or the network password needs updating.

    Sending you an email directly.

    0
    Comment actions Permalink
  • Thanks Mike; I just sent you an email response.

    0
    Comment actions Permalink
  • Mike, this is my wife's phone; she is an elementary school principal and her cell phone is important to her job.  If you could provide an update soon I would appreciated it; thanks again for your help!

    0
    Comment actions Permalink
  • Also, make sure you have a data connection on a Sprint tower. When I installed the FL16 Update on my S2, I would get that same error until I was back in a Sprint coverage area.

    0
    Comment actions Permalink
  • Thanks Jason; how can I determine if I'm connected to a Sprint tower?

    0
    Comment actions Permalink
  • I'm having a similar issue, no data access and can't update the "Vision" info...

    0
    Comment actions Permalink
  • Im having the samething error code saying the samething have done the same steeps if it wasnt for Felip Id trash the phone but he been helping he even lets me know when his not working thw olny thing with mine the error code is 49657

    0
    Comment actions Permalink
  • Im having similar issues with the error 131 code, tried everything mentioned above still no progress

    0
    Comment actions Permalink
  • Hi Todd, I see Heather and Daniel have been working with you and Logan to get your phone activated. One of the reasons we are having a bit of difficulty activating your phone is because your neighborhood does not have data coverage. You can however, activate by heading into an area with data (you can use this link to find an area with coverage ->  http://ting.com/coverage), although you will continue to data roam in your house.

    0
    Comment actions Permalink
  • Yes ive tried that it does nothing. I drove 15 minutes to main town i had 6 bars of 3g reception, still nothing. Then went over to a friends house who uses sprint, watched him use his data and i tried activating still nothing. This is not a coverage problem. when i look up my number on sprint website it says this. The owner of this account has restricted its online access. If you are the account owner and this is a personal or general business account, please visit a Sprint retail store with a photo ID to get more information. All other business accounts should contact their dedicated care representative. 

    0
    Comment actions Permalink
  • Why am i having to use a different MSL then the one TING sent to me? that also makes me feel like im using someone elses settings that have the internet turned off. The MSL ting gave me NEVER worked and i just got lucky and entered 000000 and it worked. Frustrated but glad ting support is helping me, although its been three days and still no data. and somehow i was charged one mb of data which took me into the first charge bracket. Also bought this phone through a friends referral address and neither him or I received any credits? whats going on here?

    0
    Comment actions Permalink
  • Hi Todd, a '000000' MSL usually indicates that a phone has been rooted/hacked, which may explain why we are having difficulty activating the phone. I see Daniel is still working with you on your activation, however, I will address your referral issue myself. I've just sent you an email regarding the matter. I look forward to hearing from you.

    0
    Comment actions Permalink
  • I am having a similar issue as Todd and Thomas, bought a Sprint Samsung Galaxy S2 new and I have voice and text but no data. I have tried to activate it in areas with better coverage, but no luck. The error message is 131 as well: spring password/username incorrect. Multiple representatives have tried to help but couldn't get data activated. What can I do?

    0
    Comment actions Permalink
  • Was Thomas able to get this fixed? I am having the same problem. Activated 3 HTC Evo 4g's without a hitch but the Samsung Sii Epic Touch is pulling this crap.

    0
    Comment actions Permalink
  • Robert, I ended up buying a new Samsung S2 directly from Ting as I wasn't able to resolve the issue.  However, with the old S2 and the new one, I have not once been able to access 4G services.  I'm in Portland, Oregon but I've tried in different cities including San Jose/Silicon Valley but no luck.

    0
    Comment actions Permalink
  • I also got a Samsung S2 and having the same error 131 issue... tried factory resetting the phone, ##72782# and everything i found on the forums, and still can't activate. I know it's not the area coverage because activating a LG F3 was flawless. Please Help!

    0
    Comment actions Permalink
  • Hey there Mauricio, Sorry to hear you are having trouble getting started. I will follow up with an email to get you up and running.

    0
    Comment actions Permalink
  • Hi, I'm having the same problem as Mauricio and I have tried the same things. I cannot do system updates and the MSL says the lock code is invalid. I currently have no phone service, so I would like to get this resolved as soon as possible. Help appreciated.

    0
    Comment actions Permalink
  • Anna,

    The MSL should be listed on your Ting Dashboard under the Device Settings for your phone. If that does not work, you should call or email Ting support to open a ticket.

    The support people at Ting are very helpful.

    0
    Comment actions Permalink
  • Hey Anna,

    Thanks for calling in! You've gotten in touch with Sinead and she should be able to help out from there.

    0
    Comment actions Permalink
  • Bought a refurbished Samsung S2 from Ting also, same exact problem, nothing has helped, according the map there is plenty of coverage where I'm at. I'm pretty frustrated that it looks like this is an extremely common problem with the S2 yet Ting is continuing to sell them. I definitely would not have purchased this phone had I known this. 

    0
    Comment actions Permalink
  • i am getting nervous since i just bought a used s2/epic on ebay... when i put the ESN in, it told me the phone wasn't supported yet! huh? i hope i don't have a ton of problems like it seems others are having.... this would also be my first smartphone, so i don't have much (any?) experience using them...

    0
    Comment actions Permalink
  • Hi Cindi,

    I'm going to send you an email shortly to give you a hand. Be sure to check your inbox!

    0
    Comment actions Permalink
  • Has anyone seen an issue where you have to physically turn off LTE in settings to get data?

    I have a HTC EVO 4g LTE.  I know Sprint has upgraded a bunch of towers in the area.

    If I use cyanogenmod 11 nightlies, things work as expected, I'll at least get data.  If I use a backup of stock, I have this problem.

    0
    Comment actions Permalink
  • I am having the exact same issue with my phone, which is also a galaxy s2. If there is a resolution to this I would really like to know it. 

    0
    Comment actions Permalink
  • Hi William.  I see you are working with Shaun on this issue; would you be able to update that support request with any new details please?  If you are getting the error 131, please let us know and we can help you out.

    0
    Comment actions Permalink
  • I purchased a "certified refurbished" S2 on Glyde and have had these same exact errors (error 131) and unable to update Profile or PRL, all that. I am now installing the software update so hopefully that will fix it, and then if not, I will try turning off 4g altogether like David mentioned, though his is a different phone, but since there is no WiMax here in my town I will try it anyway. My current (now inactive) ZTE Flash is in definite need of being replaced as the microphone is busted so I have to use a bluetooth headset all the time so that if I do get an incoming call I can answer it.

     

    The phone is optimizing apps now, so hopefully soon I can activate it. 

    0
    Comment actions Permalink
  • I have the exact same issue with the Glyde purchased (Ting recommended) Galaxy S2 I received today. Talking with Ting support, they are saying it's a "fatal error" and that I'll have to return my phone to Glyde. Do I upgrade to the S3? Do I try another S2? This is very annoying as I just ditched Cricket because they were unable to get a Droid 4 working on their network and I was trying to give Ting a shot instead. Sad that one of their low-cost recommended phone options has what looks like a semi-common known issue that isn't resolved.

    0
    Comment actions Permalink
  • Daniel,

    Does your phone have the stoc ROM from Samsung? You usually need to be running a stock ROM in order to successfully activate initially.

    Most custom ROMs do not support dialer codes ot PRofile & PRL updates needed for carrier activation.

    0
    Comment actions Permalink
  • Hey Daniel,

    Error 131 means the phone's data profile information is incorrect. If a profile update doesn't fix it, the phone has most likely been modified by either its previous owner or another carrier, so it doesn't have the stock Sprint rom and settings necessary for full activation on our side.

    As we don't have access to your device to look into that, we recommend you return the phone for a full refund. I saw that you have an open support request with Sean, so he will be able to follow up with additional information.

    0
    Comment actions Permalink

Please sign in to leave a comment.