[Guide]/[Fix] Activation alternative steps for custom (jellybean) roms!

If you're on a custom rom and have tried setting up your phone as per the instructions they give you you probably have come across a few issues that forced you to go back to a stock rom. I can't  guarantee  this will work for your phone or rom, nor can i guarantee that these options are even available to you, but this should work most people!

These shortcuts should let you bypass MSL modem errors ("Modem exception occurs"), as well as give you access to the Update PRL and Update Profile options that can no longer be found in settings.

Note that these are all *activity shortcuts *(long press on an empty spot on a homescreen, select shortcuts, then select activities). I don't have a list of what all launchers have the activities option, but if in doubt use Nova Launcher. Although it may not be  necessary it is best to restart your device after each step.

Also note that there are options in the activity shortcuts that can do things you don't want, such as factory reset your phone. PROCEED WITH CAUTION!! IF YOU SCREW SOMETHING UP IT ISN'T MY FAULT; THESE OPTIONS ARE HIDDEN FOR A REASON!!!

  1. Carrier wipe

activities>com.android.sprintmenu>SCRTN

 

  1. System update

you're on a custom rom, skip this ;)

 

  1. Profile Update

activities>SystemUpdateUI. launch the shortcut and select Update Profile

 

  1. PRL Update

activities>SystemUpdateUI. launch the shortcut and select Update PRL

 

  1. Picture Messaging Settings

(update mmsc)

activites>com.android.sprintmenu>MMSC. _Set address to http://mms.plspictures.com _(this should also update/overwrite all your apn settings)

 

  1. Wimax (non lte 4g)

(set REALM)

activities>WimaxHiddenMenu>REAL. set your realm address to    mnvo102.sprintpcs.com

2

Comments

6 comments
  • I just switched over to Ting with CM10.1 - I found the easiest thing to do is to follow the instructions here:

    http://epiccm.blogspot.com/2012/01/boot-el30-stock-from-sdcard.html

    to create a stock rom that runs off of your SD card. boot in to that and you can update the PRL, etc and then just go right back in to your custom rom when you are done setting up the service.

    0
    Comment actions Permalink

  • Should LastPass remember this password?
    Not NowNever...Save Site

    |
     Never For This Page
    |
    |
     Never For This Domain
    |

    There are a number of us who have used the temporary rom trick and the settings simply did not stick for the regular rom. The great thing about this is once you have the shortcuts created you can backup your nova settings and then just restore them if you ever need to use the shortcuts again! (making it a super easy and quick process at that point)

    0
    Comment actions Permalink
  • I have been trying fruitlessly to understand why the dialer in Vanilla Rootbox cannot dial out after I switched my 2 ET4Gs from the CREDOmobile Sprint MNVO to Ting Sprint MNVO.

    I used EL29 temp boot from sdcard to update PRL & Profile, and everything is working fine, even picture MMS, after using launcher shortcuts to fix APN settings.

    Before switching to Ting, I had no issues dialing out in VRB on Credo, so it must be some issue with how Ting is seeing the VRB dialer app.

    Booting again into the EL29 temp boot, I can dial out, but when I reflash the Lightning Zap kernel, and I'm back in VRB, it gives me a female voice telling me the call can't be completed when I try to do so with the VRB dialer.

    Is there another version of the "Phone version 4.2.2- eng.sniper.20130504.154438" system app I could try? Would clearing the data or converting it to a user app with TiBkp do anything? I've tried everything I could think of.

    I really just need help figuring out what the difference between the Phone Dialer in TW, and the one in VRB.

    Ting support couldn't help me.

    The only lead even remotely related to this I found in the Ting forums was the following, in regards to fixing picture MMS and APN settings, (which I already have working).

    Quote: John Lafitte, December 17, 2012-

    "A common fix is to delete your /data/data/com. android.providers.telephony/databases/telephony.db file. Then reboot and go back and set the APN again. This worked for me on cm9 but I haven't gotten it working in cm10 yet. But honestly I haven't even messed with it much."

    Is there a similar setting that I could delete or reset in order to get the Ting network to allow dialing out as if it were seeing the TW dialer, or something like that?

    0
    Comment actions Permalink
  • While I'm not a developer and can't say exactly what the issue is I'd guess it's one of three things

    1. A kernel incompatibility
    2. The rom is missing files
    3. Something with the phone/dialer apk isn't compatible

    For me the profile and prl updates I did in the el29 temp rom (on my original epic 4g) did not stick when i went back to my JB rom.

    If you want to find out the differences between the files, your best option is actually to ask android developers (specifically the ones that made your rom!).

     

    Have you tried my steps above? (using nova to create shortcuts to profile and prl updates)

    0
    Comment actions Permalink
  • when i go to update my profile or prl it says it has to dial a number it dials speaks Spanish then beeps  

    0
    Comment actions Permalink
  • Flashing a different custom rom worked for me.

    After over a week of trying to flash back to stock or rooted stock on my Samsung Galaxy S3 (continual boot loops), I switched tactics and looked for other custom roms (I was running a CM13 nightly - Marshmallow 6.0.1) that would either allow me to activate or perhaps make it easier to flash back to stock.  My device wasn't recognized over usb so I was unable to use ODIN or OTG and could only flash from the sd card.

    I ended up flashing MOAR v9.0.1 and selecting the stock kernel during installation - I used TWRP recovery.  I was able to activate my phone using the   ##72786# code once my phone booted.  I wasn't able to successfully boot into WickedX but their feature list includes:  -PRL Write Enabled in Hidden Menu(##DATA#).  It seems like touchwiz based roms are more likely to allow PRL changes.

    I'm going to flash back to CM13 now because I miss Marshmallow.

    Edit:  I wanted to add that if you plan to go my route and flash back to CM13 or other custom rom to be sure to check your apn settings and make sure you have LTE, sms, and mms before flashing.  I was unable to access apn settings in CM13 (This may be a device specific problem).  I had to flash CM12 change the settings (it took several tries as the settings kept changing - and yes, I hit save) then flash CM13.  I used APNsBU to back up apn settings before flashing CM13 and supersu to give it root access.

    0
    Comment actions Permalink

Please sign in to leave a comment.