Nokia 928 Can't Receive MMS

I have a Nokia 928, brought to Ting from Verizon. I cannot receive MMS texts but I can send them. I can send and receive SMS texts, but sending only works if I set the network to 2G. Phone calls (sending and receiving) and internet work fine. I set up the Internet and MMS APN's according to the Ting instructions except that this phone does not have the IP Type setting enabled so I can only assume it is set to IPV4 (which Google suggests is what the Verizon value would be). Any advice on how to get MMS sending working?

0

Comments

7 comments
  • I have the exact same phone issue and after chatting with support still have not got this to work.  However, I am able to send MMS/SMS messages on the LTE network now (Previously had the same 2G network fix).  I would contact support as I believe they did something on their end to fix that aspect at least. 

    0
    Comment actions Permalink
  • Thanks for the info Stephen. My research indicated that a lot of people can't receive MMS texts on Verizon phones ported to other networks. When I spoke to Ting tech support, they vaguely indicated it might be a problem with "programming" on the phone. For now, I have switched back to another phone I have that works on Ting but it isn't a Windows Phone. If someone can figure this our, I would be very happy to switch back to the Lumia.

    0
    Comment actions Permalink
  • Anyone figure this out yet? I'm having the same issue. The tech said it's because the phone wasn't unlocked by Verizon, yet Verizon claims it was never locked.

    0
    Comment actions Permalink
  • I had a similar problem with a Nokia Lumia 929 when I ported from Verizon to Ting last night. After inserting the Ting SIM, here's what worked for me:

    1. Opened Settings / Cellular+SIM / SIM
    2. Changed the "SIM name" to 'Ting' (I'm pretty sure this is just informational)
    3. Changed the "Mode selection" to 'LTE, GSM, or UMTS'
    4. Clicked on "Network selection" button, searched, and selected 'Ting'

    After this the phone restarted automatically, and from then on it worked fine.

    ADDITIONAL DETAILS
    I had already ported 2 iPhones and 2 other lines (new Motos) from Verizon with no problem, so I expected this to be easy as well. The most immediate problem was that the Windows Phone wouldn't allow ANY manual addition or modification of MMS APN--it was nowhere to be seen in any of the menus. From what I’ve gathered, the combination of Verizon and Windows Phone 8.1 hides the MMS APN settings from the user. Over the course of a few hours, I read quite a few websites and made a couple of simple changes that I undid (or at least intended to undo) when they didn't work. I don't remember with 100% certainty the exact sequence and steps, so I don't know if there were any important changes other than those listed above. For example:
    - I think the “Mode selection” of ‘LTE, GSM, or UMTS’ might have happened automatically when the Ting SIM card was installed, so that step may not be necessary.
    - My recollection is that when I first clicked on the “Network selection” button and did a search, no results were returned. I know that between when I first searched and when the search was successful, I re-started the phone. So maybe a re-start is necessary; maybe I made a mistake (i.e., didn’t do the search properly) the first time; or maybe the phone or network just glitched at a bad time on that first search.

    If anyone is able to replicate this solution, especially if any modifications to the steps above are necessary, please share since there are a number of people suffering from this issue. Perhaps Ting could verify this procedure and, if it is correct, update their porting documentation for Windows Phones to include this alternative.

    0
    Comment actions Permalink
  • As a postscript to my previous response, the APN will need to be configured to enable SMS. For my phone (Verizon Lumia Icon 929 with Windows Phone 8.1), it looks like all that is needed is to turn on "Manual Internet APN" (from the Cellular+SIM / SIM Settings screen) and enter the APN name ('wholesale'). There is no option to configure the IP type (v4/v6). The phone's available settings for user name, password, proxy server URL, and proxy port do not seem to be required for Ting.

    0
    Comment actions Permalink
  • I still have the Lumia, although it is not activated on the Ting network at the moment. I checked the settings I had tried (that didn't work) and they look essentially the same as Uetrecht's. Specifically, in Cellular+Sim / Sim :
    Mode Selection = 'LTE, GSM, or UMTS'
    Network = 'automatic' (not currently on a network so I don't know if 'Ting' was an option)
    Manual Internet APN / APN = 'wholesale'

    To reiterate, these were the settings that were on the phone when I originally had the problem. They did not resolve the problem for me. Based on the earlier comment from Stephen, I'm guessing something was changed on the network that took care of the SMS sending problem on LTE. Uetrecht, can you confirm that you are able to receive MMS texts? If so, I may switch back to the Lumia again and see if it is working now.

    On a totally unrelated note, my wife's Nexus 5 started having MMS issues sometime in the last month which required switching to "3G" (CDMA) as a workaround. Apparently, configuring the network to handle MMS correctly for all phones is proving to be taxing for the Sprint/Ting tech team. =/

    0
    Comment actions Permalink
  • Hi Jeff Shelby. Yes, the phone still is able to send and receive MMS.

    For the settings to work, it is probably essential that you press the “Network selection” button, do a search, and choose the appropriate network. After that, the button will show the network name instead of ‘automatic.’

    I’m not an expert here, but from what I’ve observed, even without the Ting SIM in place, you may be able to tell whether the right network is available on your Lumia. I have an old HTC 8X that was not ported and still has the Verizon SIM. On it, if I press the "Network selection" button and then search for networks, it shows the following:
    Verizon Wireless (4G)
    T-Mobile (forbidden)
    AT&T (forbidden)

    With the Nokia Icon I ported, if I set it back to ‘automatic’ with no network selected and then do a network search, it shows this:
    Ting (3G, 2G)
    Verizon (4G)
    AT&T (4G, 3G, 2G)

    In other words, it’s the same networks as picked up by the HTC, but now with the Ting SIM it recognizes T-Mobile and Ting as one and the same, and it becomes a valid selection.

    0
    Comment actions Permalink

Please sign in to leave a comment.