Nexus 6, CyanogenMod 12.1, CDMA

Has anyone been able to get a stable data connection with CyanogenMod 12.1 on a Nexus 6 with Ting?  I'm able to get an unstable 3g connection that cuts in and out about once a minute, and and have never gotten an LTE connection at all.  I've tried all the different APN settings I could find, including bringing over the apn config file from stock without any luck.

 

**UPDATE**

For anyone else having issues, here is what Fixed it for me.

In Settings > Mobile Networks > Access Point Names, select and edit the "Ting" APN entry.

Remove "IPv6" from the "APN Protocol" field; it should read "IPv4".

Edit "APN Type" and add ",default" to it so that it reads "mms,default".

Save the APN entry and make sure that the radio button next to it is selected. My LTE service connected as soon as I selected the Ting APN, but you may need to reboot

0

Comments

5 comments
  • You do not say whether you are using Ting CDMA or Ting GSM. If using Ting GSM try setting the phone to IPv4 or IPv6 instead of IPv4/IPv6. Many phones have had issues with the mixed settings.

    0
    Comment actions Permalink
  • It's CDMA.  I haven't tried changing the IP settings, I'll give that a shot. 

    0
    Comment actions Permalink
  • Changing to removing Ipv6 from the APN fixed everything; 3G and LTE data connections are now completely stable.  Thanks!

    0
    Comment actions Permalink
  • I've made those changes, selected Ting, but my problem is I'm not sure how to actually activate my device, since the ##7xxxx# code doesn't do anything. Do you know how to activate?

    0
    Comment actions Permalink
  • It's been a while since I activated, but I don't recall having any issues just doing the normal web activation stuff. It possible that I activated using the stock firmware before installing CM though.

    0
    Comment actions Permalink

Please sign in to leave a comment.