Picture messaging on your LG Optimus Elite

We recently sent an email out to our LG Optimus Elite owners who have enabled MMS on their accounts and thought we should post it here as well:

A little while ago, you purchased an LG Optimus Elite phone from Ting and enabled the MMS functionality in your account.

You may have noticed that sending picture messages is problematic on your device and we wanted you to know that it's not you, it's us. 

Or rather, it's a firmware problem on the Optimus Elite. 

We're working on getting a fix as quickly as possible, but since it could be some time before we have it in place, we wanted to give you a heads up to let you know. We know what it's like to struggle with something by yourself and we hate to think we may have caused you any grief.

Although we don't have an estimated fix date for the problem, we do promise to follow up as soon as this issue has been corrected.

Sincerely,

The Ting customer service team.

=== UPDATE (OCT 10)===

Hi folks,

We're pleased to announce that LG has identified the problem and fixed it (in the lab). We expect to have the permanent fix rolled out across the network (and on to your phones) by the end of this month.

Sorry for the inconvenience,

-Ben 

=== UPDATE (NOV 6)===

An update has been pushed out as of October 25th that should resolve the MMS issue, but some people may still need to reprogram the MMSC URL in their Optimus Elite handset.

There may be slight differences from one phone to the next in terms of how the steps read, and without question, every device is going to have a unique MSL (Master Service Lock), but other than that, the instructions apply to pretty well everybody.

1 - Open up the phone's keypad as though you are about to dial a number 

2 - Enter # # 3282 # 

3 - Select MMSC 

4 - Select Edit 

5 - Enter your MSL

6 - Select Set URL 

7 - Enter  http://mms.plspictures.com 

8 - Select Ok

Then simply send an MMS to activate.

If you don't know your MSL already, please contact Customer Support and we'll be happy to provide it to you.

Cheers.

Andrew

8

Comments

109 comments
  • That's the same info mine is showing.

    0
    Comment actions Permalink
  • Just posted 3 photos of the game today via wi-fi on Facebook.

    0
    Comment actions Permalink
  • I can post photos on facebook using WIFI as well when using the Facebook app.

    Using 3G, I cannot send or receive MMS picture messages..

    Your phone info is the same as mine as well.

    This is sounding more like a config issue when our phones were activated/placed in Sprints system and not a firmware issue..

    Should we be able to log into Sprint services? Or use Sprint ID?

    0
    Comment actions Permalink
  • Someone suggested entering ##DATA# using the dial pad, then editing the "MMSC" setting from the URL "http://mms.sprintpcs.com" to "http://mms.plspictures.com"

    Provided you have the MSL to edit anything..

    Has anyone tried this?

    Cory, could you look at your setting and see which your phone is set at?

    0
    Comment actions Permalink
  • Hi Joseph,

    The problem we're having is that the entered MMSC won't save in the Elite. You can change it, but it will just revert back. It's interesting that some people are reporting success when using WiFi to send MMS, we haven't heard of this.

    It would be great if we could keep this thread focused on the MMS issue related specifically to the Optimus Elite. If you've rooted/hacked your device, please note that as well (it's helpful).

    Sorry for the inconvenience folks, we had an update on this issue at the end of the week and there was still lots of testing going on in the lab. We've been pushing hard for a resolution on this as quickly as possible.

    Thanks for your patience and all the great feedback.

    0
    Comment actions Permalink
  • Hi Joseph, I was able to save the MMSC setting, now when I select view it shows: http://mms.plspictures.com

    Again, this allowed me to view an image that was attached to a previously sent MMS message.  However, sending a MMS message does not work with or without WiFi and with or without MobileData.  Instead the message is forever in the undelivered phase.

    My phone info is the same as in Cory's September 29, 2012 13:56 post.

    @Joseph, earlier you mentioned that your understanding was that MMS should work with MobileData turned on -- I don't have this behavior (doesn't work ever for me) -- does it work for you?

    @Cory: AFAIK, posting pictures on Facebook is not MMS messaging.  Could you verify that you can actually send MMS messages using the Messaging app that came installed with your phone?  Using a third party app like Facebook's app is not MMS messaging.  When using the Messaging app it should say "Send MMS" after you have attached an image to a text message.

    0
    Comment actions Permalink
  • No I can send direct MMS photos and have multiple times to my wifewith my kids pics. It's not only a Facebook posting.

    0
    Comment actions Permalink
  • @Joseph what setting are you asking me to look at?

    0
    Comment actions Permalink
  • My phone say it sends MMS but it does not, nor does it receive. I just get a download failed or expired message.

    @Cory

    Enter ##DATA# using your dialer and select MMSC, select View and theres a URL there. What is it?

    0
    Comment actions Permalink
  • 0
    Comment actions Permalink
  • Mine is mms.sprintpcs.com..

    What about under Multimedia? What are those settings?

    0
    Comment actions Permalink
  • rtsp.vog.sprintpcs.com

    0
    Comment actions Permalink
  • I recall I went thru a lot of phone calls to Ting when I first got this phone. They made me change that setting to the mms.plspictures.com setting.

    0
    Comment actions Permalink
  • I will be trying this change out if I can get my MSL so I can change it.

    0
    Comment actions Permalink
  • Joseph, I just sent it on over to you.

    Take care

    0
    Comment actions Permalink
  • After editing the MMSC URL from mms.sprintpcs.com to mms.plspictures.com I can now receive MMS messages but sending them fails and provides a message expired error where as before it acted as if sending worked but the message never reached the destination.

    So half of MMS works now.

    &Cory

    Do you recall what else was changed on your phone?

    0
    Comment actions Permalink
  • Just got my phone today. Out of the box I am able to receive MMS messages but have the same problem as Joseph when it comes to sending. My MMSC URL was already set to mms.plspictures.com.

    0
    Comment actions Permalink
  • Clarification: I can view an image someone sends me, but I am unable to download the image to my phone. Trying to use the "download" link on the webpage fails, and so does tapping the image and choosing "save image."

    0
    Comment actions Permalink
  • 6 weeks since my initial complaint and a week, with no answer, since I put in an update request. I think it is time for more than an apology for us Elite owners.

    0
    Comment actions Permalink
  • It would be very nice if we dont get a fix soon that we get some type of trade-in or discount on another phone that does work..

    0
    Comment actions Permalink
  • That's the heck of it-I don't recall exactly what they had me change. Took about 3 days of calling to get it right.

    0
    Comment actions Permalink
  • I just downloaded Go Pro SMS from Google Play and it solved the problem of having to click on a link to view incoming MMS. Now the image just appears in my Go Pro SMS message thread. It also solved the saving problem I was having. I was also able to send an MMS from my phone to another smartphone on AT&T (it appeared as a link the receiver had to click to view). Sending MMS from my phone to a feature phone does not work- perhaps because it is in link format.

     

    Cory, when you send an MMS does it appear as an image or a link to an image?

    0
    Comment actions Permalink
  • I am pretty sure it appears as an image-my wife would complain for sure otherwise! :) and she did send me a picture today that I had to click on a link to get but it definitely appears for me.

    0
    Comment actions Permalink
  • Hi folks,

    We're pleased to announce that LG has identified the problem and fixed it (in the lab). We expect to have the permanent fix rolled out across the network (and on to your phones) by the end of this month.

    Sorry for the inconvenience,

    -Ben 

    0
    Comment actions Permalink
  • Good. I have been afraid to deal with the problem of my phone randomly shutting itself off since I have been able to do MMS and didn't want to lose that capability. No whopefully I can get that fixed as well.

    0
    Comment actions Permalink
  • Cory, my Optimus Elite used to automatically reboot itself, which I thought was a sign of the phone being defective. I found it later after being debt a new phone from Ting that it was because of the secure WIFI connection that I am constantly on. I live on a college campus so this is the connection I always used. At home, I don't have the problem of the phone rebooting itself because I don't use a super secure WIFI connection, like at school. Do you might want to consider that when trying to find the problem on your phone.

    0
    Comment actions Permalink
  •   I am not sure what you consider a reboot. My phone will shut off and the only way to restart it is to pull the battery. Very frustrating butI don't want to do anything until the MMS problem is fixed because I appear to be one of a very few that has full MMS capabilities.

    0
    Comment actions Permalink
  • I was able to send a few mms messages today with no problems using 3g, has this issue been fixed without an update?

    0
    Comment actions Permalink
  • Not that I've heard of. I'd be curious if anybody else is able to.

    0
    Comment actions Permalink
  • I am able to send some MMS, but when I try to send to Verizon customers, it will not go through.

    0
    Comment actions Permalink

Please sign in to leave a comment.