Picture messaging on your LG Optimus Elite

We recently sent an email out to our LG Optimus Elite owners who have enabled MMS on their accounts and thought we should post it here as well:

A little while ago, you purchased an LG Optimus Elite phone from Ting and enabled the MMS functionality in your account.

You may have noticed that sending picture messages is problematic on your device and we wanted you to know that it's not you, it's us. 

Or rather, it's a firmware problem on the Optimus Elite. 

We're working on getting a fix as quickly as possible, but since it could be some time before we have it in place, we wanted to give you a heads up to let you know. We know what it's like to struggle with something by yourself and we hate to think we may have caused you any grief.

Although we don't have an estimated fix date for the problem, we do promise to follow up as soon as this issue has been corrected.

Sincerely,

The Ting customer service team.

=== UPDATE (OCT 10)===

Hi folks,

We're pleased to announce that LG has identified the problem and fixed it (in the lab). We expect to have the permanent fix rolled out across the network (and on to your phones) by the end of this month.

Sorry for the inconvenience,

-Ben 

=== UPDATE (NOV 6)===

An update has been pushed out as of October 25th that should resolve the MMS issue, but some people may still need to reprogram the MMSC URL in their Optimus Elite handset.

There may be slight differences from one phone to the next in terms of how the steps read, and without question, every device is going to have a unique MSL (Master Service Lock), but other than that, the instructions apply to pretty well everybody.

1 - Open up the phone's keypad as though you are about to dial a number 

2 - Enter # # 3282 # 

3 - Select MMSC 

4 - Select Edit 

5 - Enter your MSL

6 - Select Set URL 

7 - Enter  http://mms.plspictures.com 

8 - Select Ok

Then simply send an MMS to activate.

If you don't know your MSL already, please contact Customer Support and we'll be happy to provide it to you.

Cheers.

Andrew

8

Comments

109 comments
  • The MMS is now resolved on my phone between the recent hardware update and changing my url back to plspictures. I updated both phones and was able to send and receive MMS between our phones and to others on Verizon and Sprint. Actually getting a picture now - not a link. Thanks for the help Ting!

    0
    Comment actions Permalink
  • Glad to hear it Justin. Anybody who is still having trouble, you may still need to reprogram the MMSC URL if the update didn't resolve it entirely. If you need to do so but you don't know your MSL already, please give us a call or email and we'll be happy to provide it to you.

    0
    Comment actions Permalink
  • My phone has tried two time already to install the update and it says it has installed the update but when i look at the phone info it still shows it is running the old version and not the current update. How can i get my phone to install the current update all the way through the process.

    0
    Comment actions Permalink
  • I'm presuming you haven't rooted the phone or installed any custom ROMs? If not, you might need to perform a factory reset on the phone and try again (keeping in mind this will erase anything you've already put on the phone). You'll need your phone's MSL (unlock code) to do so though, so give us a call or email to get that if you don't have it already.

    0
    Comment actions Permalink
  • My phone is rooted , does that mean i cant install the update due to it being rooted?

    0
    Comment actions Permalink
  • On my LG Marquee I have done the updates (firmware and software) software shows ls855zvc. I still get msg expired when attempting open a pic msg.  What do I need to do next?The steps referenced above do not seem to work on my phone.  Thanks!

    0
    Comment actions Permalink
  • Timothy: We're not blocking rooted phones from doing updates, but it's possible that something is causing the update to not be applied due to being rooted.

    Ken: You know your MSL? If not, give us a call or email for the MSL (ask the agent you speak with for assistance with updating the MMSC URL as well if you like).

    0
    Comment actions Permalink
  • Ok, I just called in for assistance and was walked through steps to make changes.  It appears to be working just fine now. You all are awesome. Thanks so much!

    0
    Comment actions Permalink
  • After the update and the MMSC url change, mine seems to be working fine.

    0
    Comment actions Permalink
  • Great, glad to hear it!

    Anybody else who still has trouble sending MMS messages on the Elite, follow the instructions at the top of this page (from the Nov 6 update). If you don't know your MSL, please give us a call (or send us an email from the email address on your account) and we'll be happy to provide it to you.

    0
    Comment actions Permalink
  • I followed the procedure for resetting my MMSC URL above from the Nov 6 update, and seem to have the LS696ZVF software version, but still no luck sending MMS.  Just got off the phone was support and was told it'll be "a week or two" before some additional new update is pushed to my phone.  This seems weird to me after reading this thread.  Is it true that there's yet another update on the way?

    The support person talked about new phones sent out being fixed, and proposed that I exchange the handset, but I'm a new customer and received this handset only a couple days ago, so given the timelines, I wonder if that would even be successful.

    0
    Comment actions Permalink
  • OK!  I want to delete my previous comment!

    After posting, I went poking around on my account pages for the first time (new customer, dontcha know), and found that there's a "Can send & receive picture & video messages" checkbox on the device settings page.  Lo and behold?  Unticked.  It is now ticked, and MMS works.  

    It seems weird to me that this was unticked by default, and I was definitely able to receive, but not send MMS last night.

    Anyway, sorry for the errant post.

    0
    Comment actions Permalink
  • Hey everyone! I've been dealing with this issue since I got my Optimus Elite in early August 2012. I've read the forums, done the URL change, my "send/receive MMS" has always been ticked, and checked for a firmware update and NOTHING has helped! This problem has become really annoying because I can send pictures, but cannot receive them! Please help! I'm honestly considering getting a new phone just so I won't have to deal with this!!

    And when I say "can't receive" I mean, the message shows up in my inbox, but it will say "downloading" for a good 5 minutes before saying "message expired"

    SO FRUSTRATING.

    0
    Comment actions Permalink
  • Hi Emily, I've sent you an email so we may being trouble shooting. I look forward to hearing from you.

    0
    Comment actions Permalink
  • I love Ting. Got this phone a couple of weeks ago. Started noticing this issue. Looked up how to resolve. Called customer care to find out my MSL. Only took a minute for that call. Fixed the issue in under 5 minutes. Ting is by far the best!

    0
    Comment actions Permalink
  • Could i have the fix email also.  Thx

    0
    Comment actions Permalink
  • Hey John,

    Sure thing! I have sent you a help request with some reset steps and we can continue from there.

    0
    Comment actions Permalink
  • I just got my LB Optimus Elite a week ago and am noticing the same problems with MMS. I have't tried sending, but I know I cannot receive them. Are the instructions at the top of this thread still valid?

    0
    Comment actions Permalink
  • Hey Tess,

    While the steps above are still valid, I suggest taking a look and going through the steps in this help article. I see that you have submitted a help request and I will be responding to it shortly. Keep an eye out for an email!

    0
    Comment actions Permalink

Please sign in to leave a comment.