Can't access youtube via wifi on Galaxy S3

I am at home most of the time, and my Samsung Galaxy S3 works fine connected to my home network wifi. However, youtube doesn't work. If I try to load a youtube video, the little loading wheel just keeps turning. Youtube works fine if I turn off wifi, but of course then the phone eats data for lunch. Youtube works fine from a laptop accessing wifi. I would appreciate any suggestions of where to look to fix this.

0

Comments

32 comments
  • I have an S3, but have never heard of that problem before.  Does everything else work through WiFi with data turned off?  Did you try hard resetting your phone?

    0
    Comment actions Permalink
  • Thanks for responding. Works great with  WIFI with data turned off. I'm sure I am using wifi because of the low amount of data I am using, but I did try explicitly turning data off, and internet access still worked fine. I have not tried resetting the phone, not sure I want to risk that. For what it's worth, I am using a static IP with my local network. I just set it up again to see if anything would change, same behavior.

    It's just online videos that don't work, at least youtube.

    0
    Comment actions Permalink
  • Does Youtube work with other wifi conncected devices?  It is possible that your wifi ap is setup to not allow streaming.  Probably not the case in a home wifi, but i thought i would ask.

    0
    Comment actions Permalink
  • Rather than the Youtube app try going to Youtube in a browser as a check.

    0
    Comment actions Permalink
  • Rather than the Youtube app try going to Youtube in a browser as a check.

    0
    Comment actions Permalink
  • Thanks. Answers to questions. Laptop accessing wireless in a way similarly to phone (static ip) has no problem with youtube. On phone using browser youtube behaves the same - press play, little wheel turns forever.

    0
    Comment actions Permalink
  • Have you tried uninstalling & reinstalling all YouTube updates? A device restart of both the device and the router?

    While I was doing some research on this, I found a solution that seems to have worked for some Android users. What they're suggesting is that if you change the primary and secondary DNS servers of your router to Google's defaults, this will cease being a problem.

    That means changing your primary DNS server to 8.8.8.8, and secondary to 8.8.4.4.

    I have no way of confirming this myself, however, as I said, some Android do seem to be having sucess.

    For your reference, here's where I found it:

    http://forums.androidcentral.com/general-help-how/214076-need-help-asap-youtube-not-working-wifi-nexus-7-iphone-4-a.html

    0
    Comment actions Permalink
  • Thank you Rob. I read the link you provided end to end, and as you said, the tactic that worked for others who had the exact same problem was to change their router to using Google dns. Note that I am using a static IP for the phone. When the phone came I couldn't get DHCP to work with my phone and wifi, which is why I used a static IP on the phone (I generally use a static IP anyway on my local network). So based on your suggestion I made two changes to using Google's dns: 1. on the phone itself (which can only be done when using a static IP address as I am, otherwise the phone gets the dns server from dhcp) and 2. on the Wifi access point (where I don't think it matters since I am not using the access point's dhcp). Note that my laptop is connecting to the same access point using a static IP and opendns (not google dns) and youtube works fine.

     

    I have not yet tried reinstalling youtube updates. Do you mean the youtube app updates? The problem exists whether or not using the youtube app. I believe my wife's phone has the same issue, I will check. I have updated the galaxy s3 to Jelly Bean on both phones.

     

    I just tried turning off wifi and thus forcing the phone to use the Sprint network, and Youtube did work.

     

    I am fairly expert with local networks, and so I am not asking for folks to debug my local network (though all comments are appreciated). The android central article did give me food for thought. I think I will attempt to try again having the phone get an IP from the DHCP on the Access point,  a Linksys E2000 configured NOT to be a router - I am using a soekris net 4801 box running Leaf (leaf.sourceforge.net) for my router. I could also activate DHCP on the router. The Leaf router uses dnsmasq as dhcp server for the local network, which normally I don't use.

    All other internet works fine on the phone Very interesting that many others had the same problem in the androidcentral link you provided and that using Google dns was the cure for them (but not me). I did notice that if I forget my Wifi and set it up again with a static IP, that the dns is filled in my the phone as 8.8.8.8 and 4.4.4.4 (not 8.8.4.4).

    I shall keep experimenting. I can live without youtube but it is hard to give up on a good technical puzzle :-)

     

    0
    Comment actions Permalink
  • Sorry I left out one critical detail in my long response. Changing to Google's dns servers (as described earlier) did NOT solve my youtube-on -the-phone-won't-work problem.

    0
    Comment actions Permalink
  • Have you tried using other Wifi networks besides the one in your home to test Youtube?

    Sorry if I missed that part earlier.

    0
    Comment actions Permalink
  • Thanks Drew. No I haven't tried other wifi, but that has occurred to me, I will try. I did just change the dns at the furthest upstream place I can (my Leaf/Soekris router) to google, no change. I also tried my wife's phone, same results, no surprise, but at least that proves there is no peculiarity with my phone. We are going shopping tonight, I will look for a wifi hotspot. 

    0
    Comment actions Permalink
  • Tim, yes, I meant YouTube app updates. I'm sorry if I wasn't clear.

    Please keep us posted on this on what you find.

    Considering the lack of digital ink that's been spilled over this, it doesn't seem like a widespread issue at all.

    My guess is that it has something to do with your router configuration, though of course that is just a guess.

    If nothing else works out, a factory reset on the router might be worth trying out. If that does nothing, a factory reset on the phone might do the trick.

    0
    Comment actions Permalink
  • I am also having the exact same issue..I have been ready/trying different things for two days now.  It seems to have started I think maybe a week or so ago, but I don't know exact timing.

    I have a Samsung Galaxy SII, and also TWO Samsung Galaxy Note II's.  All three of these are doing the exact same thing as you describe above.  Originally I had stumbled upon an issue with not being able to download Google Play updates to apps on my phone when I was connected to my local wireless network.  BUT, if I was connected to 3G/4G coverage, it updated fine. AT same time, I realized I was also having issue getting Youtube to play on my phone.  I checked the other two phones, they are all having same issue.

     

    I took my phone to another wireless network and it downloads fine with youtube. As soon as I hit my wireless at home, same issue comes up.  I have played with settings and here is what I have to do to make it work:

    "forget" network.  Re-add the wireless network back in.  Let it get IP address.  I then go in and edit network settings and change to fixed ip and not using DHCP.  I then change DNS to either the OPENdns servers or Google servers(as listed above). It then works fine. BUT, if I reboot my phone, or if I leave the house(so it disconnects from router), then I come home and re-connect back up, it will not work again!  I then have to manually do as I describe and each time I can get youtube videos to play. Also note that when youtube quits working, I also can't update my google apps in the google play store.  As soon as I change the wireless settings as I describe above, I can then connect to youtube and also google apps will update(and I can download new ones as well).

     

    This is driving me crazy.  I can't imagine what could be causing it on my wireless network.  It only affects youtube and the google apps store on my phones, I can watch youtube fine on all my 7 other pc's in my house.   My router is a pretty new model..  A Netgear R6300 with all firmware updates.  I have opened a ticket with Netgear, but don't yet have a response back from them yet.

     

    Anyone else have ideas or a solution?

    0
    Comment actions Permalink
  • Craig, I haven't solved my problem yet, but have been pretty busy with the holidays to try hard. Did you see the link in Rob Lake's message in this thread with a link? Other people who had the problem fixed it by using Google's dns servers. Have you tried that?

     

    FWIW, I haven't been able to connect my phone to wireless using DHCP, but only with a static IP on my local network. I will fool with this some more after the holidays.

    0
    Comment actions Permalink
  • I have hard reset my wireless router, this didn't do anything. I have tried lowering security on my wireless as Netgear thought that could possibly be causing it, but no resolution. My router has worked fine though the past 6 months with same devices, so I thought that was a long shot. My next step is to call Comcast, grrr.

    0
    Comment actions Permalink
  • yes, I have added Google servers in, and that works...but after I leave my wireless network and it reconnects back up, it no longer works.  ONly way to get it to work again is to "forget" the wireless connection, re-add it back in with DHCP, then manually edit connection and enter a fixed ip address in, then put in the google dns servers(I have also used open dns servers) and both work...but only until I "loose" connection.  Each time it hooks back up it has to be redone.

     

    What kind of router do you have?  I have a Netgear R6300 and it's never caused me problems before.  I think it has to do with Comcast and/or something AndoidSprint has done on their end to change the way the streaming is done...I can't imagine anything else being the issue.

    0
    Comment actions Permalink
  • While I'm not sure what it will actually amount to, you may be able to get some help from your ISP on this.

    They're sure to know their own routers quite well, and may know the specific router settings that's interfering with this.

    0
    Comment actions Permalink
  • no luck with Comcast, said it's all working fine.  was on hold with Samsung support twice for 45 minutes and got hung up on twice, I will try later and see what I can find out

    0
    Comment actions Permalink
  • Youtube videos are cached within Comcast's network, so the streams do come from them and DNS is involved in the cache choice. Unfortunately this is something front-end support isn't even going to be aware of, so you'll probably have to find a way to escalate to the network engineering team to get anywhere from their side.

    That said, I think the DNS thing may be a red herring. I'm seeing references to Android using RTSP to stream video from the Youtube mobile site, and RTSP has significant trouble punching through NAT, which is of course what you're behind on a typical home router. I don't have a fix at the moment, but that might be a direction to go in...

    0
    Comment actions Permalink
  • A friend of mine just stopped by with his iphone.  I had him hook onto my wireless router and try the youtube app from his iphone.  It works perfectly with no issues...of course, the other variable is his phone service is not through Sprint, which mine is, although I am doubting it's Sprint that is issue....either comcast or maybe the dns routing is different when played from the iphone version of the youtube app.

    0
    Comment actions Permalink
  • Craig, from your friend's Iphone experience and my laptop experience, this looks more and more like a Samsung S3 problem. In my case, I have a laptop that connects via my wifi access point to my local network in exactly the same way as the phone. Both use a static IP. YouTube works fine on laptop, never has worked on the phone. I will say, though, that the symptoms on the phone have changed. Now quickly returns "Connection to Server lost Touch to retry". Used to just keep trying to connect for a long time. Problem same with youtube app or going straight to youtube via browser. I haven't yet had the opportunity to try on another wifi AP.

    0
    Comment actions Permalink
  • I should clarify though, I have a Samsung Galaxy S2, and two Samsung Galaxy Note 2's, and also another LG Android phone....all have the exact same issues.....I think I was searching for the youtube issue and ran into this thread not realizing it was originally regarding the S3.

    I forgot that I also have another Samsung Galaxy S2 that I do not have "activated", its screen got cracked and my wife replaced, so it's now a "gaming" device in our house.  So it will connect up via WIFI only, is not activated on the Sprint network.  I just tried to play with youtube app and it's working fine via wifi at my house.

    My next test is going to be trying to put my phone in airplane mode and see if it works on my wifi in airplane mode.  Even though the Sprint network should not matter when it's hooked to the wireless access point, it seems to be pointing to that being part of this issue.... 

    0
    Comment actions Permalink
  • okay, not thinking clearly tonight, I forgot airplane mode disables all wireless connections, so can't try that.  I am going to research more, but my next step will be to possibly "swap" one of my "active" phones on sprint with the non active S2 and see if swapping makes the currently working S2 no longer work with youtube.  I have verified the "gaming" S2 I have has the newest youtube updates and it still works, so I don't think the youtube app is the problem.

    0
    Comment actions Permalink
  • Just to clarify, my only problem is YouTube via wifi. All other phone internet activity works, including app installation and updates. To answer questions Craig asked earlier, but I missed: I am using a Linksys E2000 as an access point (not a router). My router is a Soekris net4801 box running the the LEAF Linux distribution with a Shorewall firewall.

    0
    Comment actions Permalink
  • correct with me as well, I only have the issue on all my phones while on wifi.  It will work fine if I disable wifi and hook up to the 3G/LTE coverage.  I currently have no problems doing app updates now that I changed my DNS to be google's DNS, but still have the youtube issue.

    0
    Comment actions Permalink
  • check out my "case" I have open on Sprint's boards.  I have found the issue and what is causing it, now waiting for Sprint to tell me how to fix it.  I don't think it's related to only Sprint:

     

    http://community.sprint.com/baw/message/518475?

    0
    Comment actions Permalink
  • Craig, I checked out your sprint "case". Very interesting! However your tactic did not work for me. On my Galaxy s3 I disabled data via network, but Youtube still doesn't work. Do I understand correctly that that is what worked for you?

    0
    Comment actions Permalink
  • what is odd is it worked for my Note 2, but when I tried my wife's after she got home, it would not work for hers...I am coordinating with the guy on Sprint's forum to call me so we can try some different things and see what we need to do to get her's fixed. I will keep you posted.

    0
    Comment actions Permalink
  • I finally solved my YouTube via wifi problem. I won't go through all the diagnostic steps I took, most of which are peculiar to my setup, but here are the main facts.

    Today I was at a friend's house and noticed that Youtube worked with their wifi. So I came home and dived in with a vengeance to try things. I am using a Linksys e2000 router as an access point behind a home-build router running Linux. My SGS3 uses a static IP just as my wife's laptop does, configured identically, but the laptop accesses Youtube fine. So I unplugged the network cables from my Linux router, plugged them into the Linksys e2000, reconfigured the E2000 to work as a router. Youtube STILL didn't work, and now my Linux router was out of the loop. 

    When I first got my SGS3 phone I couldn't get wifi to work with with DHCP, which is why I used static IPS. While my E2000 was still connected to the internet, I reconfigured the phones to use DHCP, and voila! Youtube worked. (I don't know why I had trouble before with DHCP, but suffice it to say my E2000 was using Linksys firmware, and yesterday I blew away the firmware with DD-WRT. It wasn't hard, and the open-source firmware is MUCH better. Maybe DD-WRT solved the DHCP.

    I returned my Linksys E2000 back to access point mode behind the Linux router, and Youtube still worked! Victory!

    The key to this is that I configured DHCP on the router with the Google DNS servers 8.8.8.8 and 8.8.4.4. There is a lot of discussion about this other places in which the cure was to use the Google servers. Somehow when I used the SGS3 phones with static IPs they weren't getting the Google dns servers, even though the same setup works with a laptop. There IS something funny with Sprint and/or Android that messes up Youtube. 

    I still don't understand everything about this, but I'm happy, and I'm fairly confident that configuring the Phone so it absolutely uses the Google dns servers is the cure. Now I'm wondering if any of this casts light on Craig's problem.

     

     

    0
    Comment actions Permalink
  • THANK YOU!!  I have spent a month on this.  I change the DNS settings on my phone to Googles 8.8.8.8 and 8.8.4.4. using a static, but then as stated in previous posts when you leave home and come back it goes back to original DNS setting that is programmed to my router.  So I went into my wireless router settings and made sure it was DHCP not static and changed to Google DNS settings.  Then I "forget network" on my phone and re connected using DHCP and VOILA!  You tube works better then ever!  Videos are clearer than they used to be.  I didn't have to change my firmware.   

    FYI . . . my husband's iphone 4S had the same problem so it's not just a Android issue. 

    I know there are so many other users that are going through the same thing and hopefully all your time and effort on this will help them as well.  THANK YOU AGAIN!!! 

     

    0
    Comment actions Permalink

Please sign in to leave a comment.