Galaxy S3 Data Not Working When Leaving Wifi

I recently updated my Samsung Galaxy S3 to the new version of Android (4.1.2) using an OTA update.  Since then, I've had two cases where I've left my home (on Wifi) and had no data connectivity.  The phone shows a connection to 3G, and the arrows light up, but nothing works.  Toggling airplane mode seems fix the problem temporarily.  

Anyone else with this same problem?

0

Comments

96 comments
  • Hi Martin,

    You may have to do a profile update after the Android update. Turn WiFi off and 3G on, and go to Settings > About Phone/System Updates > Update Profile. Please also try updating your PRL at this time: Settings > About Phone/System Updates > Update PRL

    If this does not help, please let me know, and I will continue to help you troubleshoot in an email!

    0
    Comment actions Permalink
  • Katie,

    I did that, and a factory reset of the phone, but the problem seems to be persisting.  I wonder if anyone else is having this trouble. I've been with Ting for 5 months and never had the issue before.  It may not be the update - it could be a Sprint network issue.

    0
    Comment actions Permalink
  • I'll be following up with you via email :)

    0
    Comment actions Permalink
  • Thanks for your help resolving this Katie!

     

    For anyone else having this problem, we solved it by:

     

    1.  Opening the phone dialer.

    2.  Pressing ##72786#

    3.  Allowing the phone to reboot and reprovision.

    Thanks again!

    1
    Comment actions Permalink
  • My pleasure, Martin! Glad to see you up and running :)

    0
    Comment actions Permalink
  • I am having a similar problem, please help! No data connectivity what so ever outside wifi:( I did the reccomended steps above and no luck :(

    0
    Comment actions Permalink
  • Hi Nichole,

    I've sent you an e-mail regarding this so that we can provide you some additional steps specific to your device. Let me know if you have any questions through the support request I've sent you : )

    0
    Comment actions Permalink
  • I just submitted a request but am having a similar issue with a Samsung Galaxy S2.  Data connection is either extremely slow or nonexistent when not connected to WiFi.

    0
    Comment actions Permalink
  • Hi Frank,

    I've followed up with you regarding this through the support request you submitted!

    0
    Comment actions Permalink
  • Kyra,

    I followed the steps in the e-mail you sent me.  I believe they are the steps listed above and the issue still persists.  Phone has intermittent internet access over 3G and usually it is non-existent.   

    0
    Comment actions Permalink
  • Frank, Kyra will get back to you via email.

    0
    Comment actions Permalink
  • Is everyone who is having this problem using a Galaxy S3, and did you all download the very latest update a few weeks ago?

    0
    Comment actions Permalink
  • I am using a Galaxy S2.  I only recently activated the phone with Ting, so did not do any updates.  Was this update for the S2 as well?

    0
    Comment actions Permalink
  • I'm beginning to wonder if Ting and/or Sprint just aren't having data issues in general...

    0
    Comment actions Permalink
  • I am having no issues with my HTC Evo.

    0
    Comment actions Permalink
  • The issue may be regional.  Also, since it is intermittent, you may have had periods with no data, but not tried to use data during those periods, and thus not know that you had issues.

    0
    Comment actions Permalink
  • I'm having the same problem with my GS3.   I'm running Android 4.1.2.  I've tried this and had no success:

    1. Open the phone dialer.
    2. Press ##72786#
    3. Allow the phone to reboot and reprovision.
    4. It rebooted twice.

    5. Update Profile and PRL in settings.

     

     

    0
    Comment actions Permalink
  • It looks like I am still having this issue with my phone as well.  It seems to be happening less frequently, but it is still happening from time to time.  It looks like the Verizon version of this phone is having similar issues:

     

    http://www.christianpost.com/news/samsung-galaxy-s3-android-4-1-2-jellybean-update-for-verizon-creates-issues-with-lte-97156/

    0
    Comment actions Permalink
  • @Sterling, have you tried doing a full factory reset? You need to dial # # 7 8 6 # instead, and it wipes all data off your phone (so do a backup first).

    @Martin, have you retried any of our troubleshooting recently? And thanks for the update!

    0
    Comment actions Permalink
  • Katie,

    I've redone the carrier reset several times.  The problem is very intermittent now.

    0
    Comment actions Permalink
  • Katie,

    I just did the factory reset.  The problem remains. I have no mobile data connection.

    0
    Comment actions Permalink
  • It is strange that though I am not connected to WiFi, I am able to update my profile and PRL. I see the 3g upload and download indicator and it says "preparing network" in the notification bar.

    0
    Comment actions Permalink
  • Hi Sterling, in order to update your phone's profile and PRL we actually require that your phone is not connected to WiFi. That is because we need a pure data connection to a Ting cell tower in order to update the phone. Since your phone is able to make the update, this would suggest to me that your phone is capable of making a mobile data connection. I'd like to investigate this further with you so I've sent you an email. I look forward to hearing from you.

    0
    Comment actions Permalink
  • Agreed.   It is establishing a pure data connection (wifi is off), says "preparing network" in the notification bar, but then immediately drops the connection - no email pop and no web browser.  Voice and text is working fine.

    0
    Comment actions Permalink
  • I was able to resolve this issue.  I changed the Network Mode from LTE/CDMA to CDMA and rebooted the phone.  That fixed it.

     

    0
    Comment actions Permalink
  • This is beginning to sound a lot like the complaint that Verizon SGS3 customers are experiencing after they updated to 4.1.3 as well...

    0
    Comment actions Permalink
  • I was having the same recent problem.  All of a sudden I'd leave the house and no data.  Googled the heck out of the issue and came up with nothing.  Before coming here I tried, out of desperation, various "signal booster" apps.  The Alportela Labs Network Speed Booster app at Google Play has my phone search for different towers than it normally would.  BAM!  Data.  Everything is back to normal.

    0
    Comment actions Permalink
  • I may be having a similar problem.  It seems to be losing the data connection randomly and won't reconnect till I bounce it in/out of Airplane mode usually.  I've just updated the profile/prl, so I'll see how it does 

    0
    Comment actions Permalink
  • I just recieved my Samsung Galaxy S4 yesterday and have had this problem as well. And is know solved thanks to the post made by Katie. 

    1.  Opening the phone dialer.

    2.  Pressing ##72786#

    3.  Allowing the phone to reboot and reprovision.

    Thanks again!

    0
    Comment actions Permalink
  • I had the problem occur again today.  It definitely is still happening, but much less frequently.

    0
    Comment actions Permalink

Please sign in to leave a comment.