Galaxy S3 Data Not Working When Leaving Wifi

I recently updated my Samsung Galaxy S3 to the new version of Android (4.1.2) using an OTA update.  Since then, I've had two cases where I've left my home (on Wifi) and had no data connectivity.  The phone shows a connection to 3G, and the arrows light up, but nothing works.  Toggling airplane mode seems fix the problem temporarily.  

Anyone else with this same problem?

0

Comments

96 comments
  • I am having the same problems as Martin on my daughter's S3.  Text and voice work fine, but internet does not work unless she is on a Wifi network.  I've tried all the suggested fixes above but none of them have worked. I also periodically get a 'Error 67: Registration failure..." error message.

    0
    Comment actions Permalink
  • Thomas, I see you had a support ticket open with Sam earlier in the week where she mentioned some towers in the area were having trouble causing data issues for an SIII. If this is related to that support ticket, my suggestion would be replying to her latest email to ask her to check the towers again. Actually, if it's related to a different area or phone as well, do the same (just give her the address), and she can do a check for you there as well.

    0
    Comment actions Permalink
  • I posted back at the end of May and my Samsung Galaxy S2 is still having the same issue.  Tried everything suggested here and through support ticket.  Data connection is intermittent and very slow when not on WiFi.  MMS picture messages sometimes don't send or if they do, it is hours after the initial message was sent.  

    Is there a solution to this problem or do I have to purchase a different phone? 

    0
    Comment actions Permalink
  • Hi Frank, I've sent you an email and I'll see what we can do to get your phone's data connection back up and running.

    0
    Comment actions Permalink
  • Hello, I'm having trouble with the same as others in the forum, My Data is only working with WIfi, as soon as I leave my apt, or my workplace where there's not wifi, the phone goes completely out of DATA :( I tried making a backup how you indicated via Kies, and it stayed there for long time with no solution, please help me with this!!!

    0
    Comment actions Permalink
  • @Alkis I've sent an email to your gmail address to follow-up with you on this. 

    When dealing with data issues there are a few things that would cause devices not to connect to the data network including your service area, device settings and network connections. In this thread it looks like there have been a few solutions provided that have worked for some. For those of you still experiencing issues you can contact us at help@ting.com or by phone at 1 855 846 4389 so we can look into the specifics or what could be causing the data connection problem. 

    0
    Comment actions Permalink
  • I've had an S3 on Ting since June. Everything was great until a week or so ago and my data stopped working. I did everything, reset the carrier, reentered MSL/MSN, erased the phone, started over, etc. I still could not get data. Finally, I went to my account settings on Ting's website. Although the allow data setting was on, I turned it off and saved. I then rechecked it back on and saved. I now have data. It worked for me, everyone else's results may vary.

    0
    Comment actions Permalink
  • @Bryan, Thanks for sharing. Sometimes resetting the data network gets things flowing again. 

    0
    Comment actions Permalink
  • I was facing same problem and just found a solution. Go to Settings --> More Settings --> Mobile Networks --> Access Point Names and then i have created another APN with different name and same values of my origional / default settings (i.e.NEW NAME, same APN, same proxy , same port, same user name, same password, same everything) . and choose the new APN which i have created. My Mobile Data is back and working fine. Hope it will work for others as well.

    Cheers,

    0
    Comment actions Permalink
  • hi so im having a somewhat similar problem with my s3, it wont connect to my home wifi?, but it will connect to other wifi's it wont even detect mine, i have manually entered it and it just says "out of range"  can anyone help?

    0
    Comment actions Permalink
  • @roger. That's a different issue than the one I had. I couldn't get the mobile data to work, but finally resolved it. Your situation is different with local wifi issues. I guess you've tried rebooting to the router/modem and your phone? If your phone works with other wifi routers, then it must be something's up with your router? Do other devices work with your home wifi?

    0
    Comment actions Permalink
  • Yes my iphone, laptop an other phones connect perfectly,..but not my s3, iv tried configuring my ip adress and other solutions but nothing

    0
    Comment actions Permalink
  • 0
    Comment actions Permalink
  • +1 for changing the Network Mode from LTE/CDMA to CDMA and rebooting the phone. Worked for me.

    0
    Comment actions Permalink
  • @Robert. Are you able to send mms files?

     

    0
    Comment actions Permalink
  • But Robert,  if you set it to CDMA your not getting 4G LTE.  Only 3g. I have had to switch mine to CDMA just like you did to get data when out away from my wifi. What about LTE? 

    0
    Comment actions Permalink
  • @Gloria: not that I've found yet. Did you set the Picture Message Settings from this page also ( https://help.ting.com/entries/23169888-Activation-for-your-Samsung-Device)? I just tried sending a pic to an iPhone Sprint user and to a gmail account without success.

     

    @Timothy: definitely haven't seen 4G yet. When in New Orleans, where Sprint has launched 4G, I tried simply switching Network Mode back to LTE/CDMA, the phone rebooted, and I was without data. So it would seem to be more involved -- unfortunately, I didn't think to try updating my profile. Have you tried that or a carrier wipe?

     

    0
    Comment actions Permalink
  • Yes  and yes. 

    0
    Comment actions Permalink
  • Yes  and yes. 

    0
    Comment actions Permalink
  • Sorry,  double post

    0
    Comment actions Permalink
  • my data is working fine just the wifi doesn't work samsung couldn't help me on the phone,

    tried to dial ##72786# but it doesn't go, probably don't know how to do it

    0
    Comment actions Permalink
  • A bit up the page, Faisal wrote (on Oct 23): "... Go to Settings --> More Settings --> Mobile Networks --> Access Point Names and then i have created another APN with different name and same values ..."

    I don't have anything about Access Point Names within my Mobile Networks settings. Does anyone else? Is it somewhere nearby? 

    0
    Comment actions Permalink
  • Hi Yoely,

    I am sending you an email directly to try and help.

    Aaron, I have sent you an email earlier so please keep your eyes peeled on your inbox for that :)

    Thanks!

    0
    Comment actions Permalink
  • I have been having this problem as well. I have done what was suggested in earlier posts with no progress. If you have any suggestions please let me know thanks!

    0
    Comment actions Permalink
  • Hey Angie!

    I can't find an account for you based on the email address or your name!

    Can you get in touch with us by clicking here. Please include your account details so that we can assist :) Do not however put your details in our public forums.

    Thanks!

    0
    Comment actions Permalink
  • For anyone who is following this thread, please note that the "APN Settings" menu does not exist on Ting phones or on any phone that uses a CDMA based network, such as Sprint or Verizon.

     "APN Settings" is a setting that applies only on GSM/HSDPA/LTE networks, such as those operated in the U.S. by AT&T and T-Mobile.  The comments suggesting that you locate these settings must have been posted by non-Ting customers who were experiencing similar problems with their non-Ting phones.

    0
    Comment actions Permalink
  • Just to Clarify, APN Settings also means "Access Point Names".

    0
    Comment actions Permalink
  • i bought my galaxy s3 3 weeks ago downloaded music maniac mp3 but can't transfer to usb flash drive.

    0
    Comment actions Permalink
  • @jaime, you'll get better help if you open a new thread for that separate topic. 

    0
    Comment actions Permalink
  • I tried going to settings to edit APN but in looking it has not set on proxy, port, username password server mmsc multimedia message proxy multimedia message port authentication type mobile virtual network operator mobile virtual network operator and will not let me click on any of them. geezzzzz I hate the updates

    0
    Comment actions Permalink

Please sign in to leave a comment.