Google Hangouts and MMS

BYOD device to Ting? Using Google Hangouts for SMS/MMS? Your MMS not working? System has your MMSC URL correct, but it wasn't correct when Google Hangouts SMS was turned on?

 

Try this:

1. Turn OFF SMS in Google Hangouts under its Settings

2. Check your MMSC URL is correct

3. Turn ON SMS in Google Hangouts under its Settings

Apparently, Google Hangouts uses its own APN settings, but on CDMA phones, it will pick them off from the system when SMS is turned on for the first time.

2

Comments

14 comments
  • Thank you very much for that Justin! I love when our customers help out each other :)

    0
    Comment actions Permalink
  • If you don't like Hangouts, there's a free SMS/MMS app called 8SMS. It uses code from the original Android Messenger. You can edit the APN within the app. Bonuses include MMS over Wi-Fi, pop up notifications, contacts shown by name and a lot more.

    0
    Comment actions Permalink
  • Dug this thread up and it fixed my Hangouts..

     

    thanks for the helpful tip!

    0
    Comment actions Permalink
  • Anyone know How we confirm our MMSC url is correct?  Your above instructions didn't fix it for me, however I can receive MMS messages through normal messaging app, (So I assume my mmsc url is correct) however Hangouts just gives me a "Click here to Download message, Message size 1k" and I click and it twirls like it's downloading something and nothing ever results. The twirling will stop, but there is no message, there is nothing in the Downloads. 

    By the way, you can Add an APN to Google Hangouts under it's settings as well, but again, I need to know the correct APN information to populate, don't I? 

     

    0
    Comment actions Permalink
  • Hi Marc,

    As you mentioned if you can receive MMS messages through the stock messaging app, your MMS URL is probably already set correctly. With that being said, you can find the MMS URL steps by going here.

    0
    Comment actions Permalink
  • Thanks Renny,

    As I have done more research, there really isn't a compelling reason for me to use Hangouts for MMS. Since Google can't get it to work on their end, like any other Texting app can, I'm not feeling confident it's worth using their app. 

    But thanks for the link to the instructions. 

    0
    Comment actions Permalink
  • I have been struggling to get MMS to work with Hangouts on Ting for awhile now (Has always worked with the default messaging app). Hangouts would intercept the mms and it would spam me to open the message but it would never do it successfully (I couldn't even go to the default app to look at it because it was stuck in Hangouts land).

    A new version of hangouts came out Feb. 5th, 2014, but that didn't fix the issue for me either.

    Solution:

    Hangouts gives you the option to specifically specify the APN to use to send and receive MMS. As long as your default messaging app sends/recieves mms successfully now, you can specify the apn for Hangouts to use. First, however, you'll need to get the APN that your device is currently using.

    For the System

    1. Navigate to System Settings->Mobile Networks->Access Point Names (On the NOTE 3, I had to search for "Access Point Names" as there was no way to manually navigate to it).
    2. Edit the settings of the current APN you are using (select the option with the selected radio button)
    3. Write down or take a screenshot of the settings

    In Hangouts:

    1. Launch Hangouts
    2. Select the menu button on your phone and enter the settings
    3. Select SMS then Access point names
    4. Select the plus symbol in the top right
    5. Copy the data from your current APN settings into the files
    1
    Comment actions Permalink
  • If Google Hangouts has the option for Access Point Names, then you probably need to configure it there.

    My phone (Motorola Photon Q 4G LTE) doesn't have the APN Setting in Google Hangouts, but it did start working when I configured it correctly in the OS and then disabled/re-enabled SMS in Google Hangouts

    0
    Comment actions Permalink
  • Hi new to ting. :) question when using hangouts do I still get charged from ting for messages ? If so is there a way around it?

    0
    Comment actions Permalink
  • Hi Jason! If you are sending SMS (regular text) messages to other phone numbers through Hangouts, they still count toward your Messaging totals. If the recipient is also using Hangouts, you can choose the option to send the text  as a Hangouts message (that wouldn't count toward your Messaging totals). This is only going to work for other Hangouts users, of course.  A third-party app might be advisable for messaging non-Hangouts users. 

    0
    Comment actions Permalink
  • I'm on the LG Optimus G and I've been trying for a long time to get MMS to work with hangouts, as I like it a lot better than the stock messaging app. Nothing I have tried works including creating a custom APN and mirroring the phone's MMSC settings. One thing I did notice is that when I try to set the MNC to 00 on hangouts like it is on my phone then hangouts disregards the APN. And ideas?

    0
    Comment actions Permalink
  • Hi Rory,

    We tried locating some information on Hangouts and the LG Optimus G, but although there are some records of a few issues, we still couldn't find an official or confirmed solution. There's also a discussion thread on Sprint's discussion board about Google Hangouts, and Sprint  has a short guide on how to enable that on the LG G3, but that doesn't have much info other than enabling text in Hangouts. It will be interesting to see if other customers can also share their opinions.

    0
    Comment actions Permalink
  • Well this is no longer a problem for me as I smashed the ever loving snot out of my phone by accident the evening after I last commented. I'm up and running with a Galaxy S4 now and hangouts works fine. Oh, and I bought a case too ;) 

    0
    Comment actions Permalink
  • Hey Rory, so sorry to hear it!  But...hooray for Hangouts working properly...and a case!

    0
    Comment actions Permalink

Please sign in to leave a comment.