GSM public beta discussion

(If you haven't already, head over and purchase your Ting GSM X1 SIM card.  Once it is delivered (expeditiously), you'll be ready to go!)

Thanks for taking part in the public beta for our GSM service!  There are a few things that aren't yet ready, so we wanted to be sure to point those out...

 

  • International long distance.  For now, you'll need to use an alternative service like Google Voice or Skype.  We're working on offering considerably better rates for calling overseas, so we promise it's worth the wait.  You can now enable international long distance for your GSM lines in your account dashboard.  Rates are the same as on GSM, although we're still aiming to lower international long distance rates for both CDMA and GSM later this year.
  • International roaming.  GSM opens up a lot more doors for customers in terms of travelling abroad.  We still think your best bet is to use an unlocked device with a local SIM or a service like KnowRoaming.  But we will offer international roaming in the near future.  (Keep in mind the rates will be different from our CDMA international roaming rates.)
  • Mobile apps.  Our iOS and Android apps do not yet support making settings changes for your GSM lines.  Updates will be pushed to the App Store and the Play Store later today, but it may take a few days for those revisions to get approved.  In the meantime, head over to your web dashboard for any GSM device settings changes.  Our iOS and Android apps have been updated to support making settings changes for your GSM lines.
  • Account dashboard.  We're still working on the best ways to handle GSM device settings on your account dashboard.  Also, MMS cannot currently be disabled from your dashboard.
  • Caller ID. Outgoing Caller ID Name cannot currently be updated. We'll update when the option becomes available.
  • iPhone features.  Certain iPhone features, including visual voicemail, Wi-Fi Calling, and group messaging are not yet supported.  We hope to offer these options later this year, but we don't yet have a definitive timeframe.  (If these features are critical to you, they are supported on our CDMA network.)  For more on using your iPhone with our GSM service, please see here.
  • Wi-Fi Calling.  If you have a device with firmware that supports the Wi-Fi Calling feature provided by our GSM network partner, it should now work once it is enabled on your account dashboard.  It may take up to 24 hours for the feature to fully provision to your device.  Please keep in mind, Wi-Fi Calling minutes and messages still charge at the same normal rate as a tower-based call or minute.  Wi-Fi Calling is still very much a work in progress, but a number of our customers have found it to be helpful for improving coverage indoors.

 

If you're having some issues finding the correct place to update APN settings for your specific device, our activation series covers a wide range.  If you come across one that we haven't documented but you manage to get it working, we'd love it if you could share your steps here for us to kindly borrow.  ;)  If you're wondering about the compatibility of a specific device, take a look at our article here and be sure to use our compatibility checker.

Last but not least, we're here to help.  If you run into issues, please share what's going on here.  Either a Ting team member or one of your fellow customers almost certainly has the answers.  If something is seriously broken and it's getting in the way of what you need to get done, please get in touch with us via the normal channels so we can help right away.  Our first GSM activations were almost three months ago.  Our first beta customers joined over a month ago.  Things are quite stable, but we're still tweaking and perfecting everywhere we can.

Without any further ado, we'd really love to hear how things go for you, both during and after your activation.  Thanks for being a part of our GSM beta!

5

Comments

491 comments
  • Justen, Regarding PR coverage, thanks for the info.  It's great having options!

    0
    Comment actions Permalink
  • Thanks Chris & Bruce. Good to know.

    0
    Comment actions Permalink
  • I had an addition to my tethering woes.  When I am connected to LTE, the vast majority of the time it doesn't tether, while I get data just fine on the Nexus 5.  I have seen it work a couple times, but not much.  I wanted it for mounting my Nexus 7 tablet in my car and do navigation and stuff from it.  Anyhow, I lowered the preferred network to 3G, and then tethered data finally went through more reliably, albeit a bit slower.

    0
    Comment actions Permalink
  • John Lafitte,

    I don't know if it was just a fluke but my wife has a Boost Moto G on Ting and went to San Juan on a business trip.  She tried not to use the phone too much but did have to use some data and a few texts.  I kept looking for the additional charges and they never came.  So you may be good on the CDMA usage there.

     

    0
    Comment actions Permalink
  • I have a Nexus 5 activated with the GSM sim. I've been experiencing some strange behavior when switching from Wifi to LTE.

    Problem: When I turn off WiFi, LTE does not kick in. I see a "!" where LTE should be. 

    Work around: In order to get LTE working, I have to go to Settings -> Cellular Network -> Preferred Network Type -> Select 3G ->  WAIT for it to switch -> then switch back to LTE. 

    This is the only problem I've encountered so far.

    0
    Comment actions Permalink
  • Just an FYI...if you have a 1st gen Moto X Unlocked Verizon phone...don't bother with the GSM beta as you will only be able to make phone calls and not get any form of data transfer. I tried. My calls were clear, but according to my friend who was in the car with me...there was ONE over pass on my way to work that got data for 3 seconds...ahh well, I tried. I'm back to my Moto G...Gone from the Cadillac to the Ford Escort...I may have to order a new GSM friendly Moto X...sigh...

    0
    Comment actions Permalink
  • Gary Perez - That sounds the same as I was seeing on the Sony Z3 D6633. Is your APN set to IPv4/IPv6? I found that it did not show the problem if the APN is set to IPv4 only or IPv6 only. I now have mine set to IPv6 only - it only uses IPv6 from the mobile but uses the XLAT464 to also provide IPv4 access.

    This issue only seems to be affecting certain phones/builds but so far I haven't seen any real effort from Ting to establish what is actually happening in such cases. Despite the fact that the phone behaved perfectly with other T-Mobile MVNO SIMs in place the only suggestion from the help desk was to factory reset the phone - thus I started looking for clues myself and came up with the IPv6 APN as a work around.

    I think that Justen should really get across this issue and establish what is going on.

    0
    Comment actions Permalink
  • Mis-Configuration of GSM X1 Sim

    Issue: I use Google voice as my voicemail provider. Forwarding has been setup via standard GSM codes and works perfectly. As is usual, the voicemail number which changes the phone number that is dialed when you hold the 1 key in the dialer (tape symbol) has to be set manually. My phone (HTC One M8, and Samsung Note 3) allows me to set this number, and saves it.

    Expected result:

    Google Voice voicemail phone number is retained as the default after a phone reboot.

    Actual results:

    1) With an ATT Sim inserted into my phone, the user defined voicemail number remains after a phone reboot, it even remains after switching sim cards to ting and back to AT&T.

    2) With the Ting GSM Sim insterted, every time the phone is rebooted the Google Voice number is replaced with Ting's default voicemail number.

    Obviously this can be worked around, by either using #2 speed-dial (but reducing my available speed dial numbers by 1), or by adding my google voice number as a contact (slow). It's still an annoying bug with the sim configuration that doesn't exist on any other Sim I've ever used.

    Please make someone who knows the technical aspects of Sim card configuration aware of this issue.

    Otherwise... Our first month+ of Ting has been excellent :)

    0
    Comment actions Permalink
  • RE: Porting out Ting GSM number to T-Mobile Postpaid

    I reported an issue here about a week ago, Mar 13, 2015.  I continue to have trouble porting a TIng GSM number to T-mobile postpaid due to PIN matchup problems.  Interestingly I ported another line, a ting CDMA one to tmobile postpaid without problems (ported within 24 hours).  I am about to give up on the port and have to go through the hassle of changing my phone number with all my contacts.  I post this here as there must be some issue with the ting's GSM beta and the difficulty in porting out.  I have been in touch with ting by email daily over the past week.

    0
    Comment actions Permalink
  • Kenneth: The problem is that the carrier you are trying to port to isn't respecting the industry standard for port-out PINs.  They have an archaic system in the back of a room somewhere that only allows up to four-digit PINs for certain ports.  We've used six-digits since we launched.  Every wireless provider is required to support PINs of any length between four and fifteen digits.  They've advised us they are going to fix their system to respect the industry standard, but I've emailed you a potential workaround that we could try in the meantime.

    0
    Comment actions Permalink
  • Has anyone successfully moved a Samsung S3 over from US Cellular?  It's a CDMA phone but the checker says it should work on the GSM beta.  I asked tech support if there was anything else I needed to do (unlock, root, whatever) and was told to buy the Ting GSM sim & it should work fine.  Well it didn't.  Then they said I should unlock it.  Still no-go.  Can't get to the APN screen.  What I'm seeing on the web indicates that I might be able to jump through fiery hoops and then have a max 2G data connection.

    I would appreciate any feedback as Ting tech support won't even respond to the questions on my support ticket & then if they do it seems like they're clueless on this one.

     

     

    0
    Comment actions Permalink
  • What is the model? SCH-R530? If this Wiki entry is correct that model does not have GSM or UMTS capabilities but does have LTE bands 4 & 12:

    http://en.wikipedia.org/wiki/Samsung_Galaxy_S_III

     

    0
    Comment actions Permalink
  • I've been using my One Plus One on Ting for almost a week now without any problems. Just wanted to update the Speedtest results that I shared on 3/16. I did another LTE test a different location and got 18.17 mbps down, 15.37 up with a ping of 156 ms. Those results are better than my wifi performance at home so I'm quite happy with the service. Ting and One Plus One a great combination!

    0
    Comment actions Permalink
  • Skye - I looked into bringing my wife's Verizon Samsung S3 to Ting but found that even though Ting's compatibility checker said it would have 2g and LTE support, the frequencies and bands were actually not compatible.

    I ended up buying a Moto G LTE (1st edition) for $200 and activated it as a test unit two days ago. So far, Ting's GSM LTE service is kicking butt on Verizon. Many times faster and coverage is very good in my area.

    0
    Comment actions Permalink
  • @ D Alexander  

    Thanks for the tip! I changed my APN on my Nexus 5 to IPv6 only (I had it set to IPv4 only) and that solved my problem. I can now switch from WiFi to LTE without a problem.

    0
    Comment actions Permalink
  • @Gary Perez

    Glad it worked. This issue only seems to affect some beta testers but it is unclear whether it affects certain devices, certain Android builds, certain locations or some combination.

    I'm still hoping that Justen will show some interest in getting to the bottom of the issue. The helpdesk seem to be out of their depth.

    0
    Comment actions Permalink
  • Ever since my activation everything seems to have gone fine, but I noticed that I can't send or receive pictures through text message. It takes awhile with the endless circle and then it stops stating the message couldn't be sent. Is there a fix for this?

    0
    Comment actions Permalink
  • I recently switched from CDMA to GSM without realizing that the coverage was not so good out here. Is there any chance that the coverage is going to get better?

    0
    Comment actions Permalink
  • Coverage is due to expand a lot during 2015. Note that some of this expansion is via band 12, which few handsets, at present, support but i'm assume they'll roll out the regular AWS band along with band 12 but i do not know if that is the case. http://www.tmonews.com/2015/02/t-mobiles-lte-coverage-map-will-look-like-this-by-the-end-of-2015/

    0
    Comment actions Permalink
  • 0
    Comment actions Permalink
  • Yes SCH-R530U.  I just bought a Sprint S3 from ebay where I'll sell mine.  Didn't want to go down that rabbit hole.

    0
    Comment actions Permalink
  • Tried Justen's suggestion for my issue on Ting and my Nexus 6 (page three, bottom).  I have two APN's one with mms APN Type (IPv4) and one with all other APN data types (IPv6).  That seems to be fine, but no matter how I configure the APN's I still get absolute dead spots in my home.  I have a downstairs filled with windows and the LTE coverage is "excellent" but I can not get calls on couch cushion three or send/receive any MMS from there as well (or by the fridge, or near the guestroom etc.)  Should I be able to send/receive MMS on Hangouts or Google Messenger via Wifi too?  I thought I was able too on my old service/old phone, but now I don't know.  Just throwing this out.   Thanks all...

    0
    Comment actions Permalink
  • Noah,

    Do you have Wi-Fi calling enabled? Apparently MMS does not work well when on Wi-Fi with Wi-Fi calling enabled. See https://support.t-mobile.com/message/367803

    This thread indicates an issue has been fixed. Some users had success with network settings at "3G Preferred" instead of "LTE Preferred".

    See https://code.google.com/p/android-developer-preview/issues/detail?id=52

    This thread also indicates an issue. https://help.ting.com/entries/38090948-Is-MMS-on-Nexus-5-only-over-data-not-wifi-

    I do not send MMS much with ny Nexus 5, so I cannot comment one way or the other.

    0
    Comment actions Permalink
  • 0
    Comment actions Permalink
  • Bruce,

    Thank you for the suggestions, I will certainly look into them.  I just now turned WiFi calling on, but have had it off prior since coming to Ting.

    0
    Comment actions Permalink
  • I purchased  Motorola Moto 2 2nd gen. about 2 weeks ago, installed the GSM chip and am very happy with it as it does everything I want.  Lately and randomly,  I get the message "No APN specified on this device".  It causes the phone to heat up and drain the battery rapidly.  I rechecked the network setting and they appear correct.  I have posted this issue on the Motorola forum as well but I don't have a solution as of yet.  Does anyone know of a reason for this or a solution?

    0
    Comment actions Permalink
  • Sorry Moto E, not Moto 2

    0
    Comment actions Permalink
  • I have an unlocked AT&T iPhone that I would bring to Ting if I thought it'd work. However I have had this phone activated on the T-Mo network, where I get fine voice coverage but only EDGE data. I'm assuming that I'd get the same experience with Ting. Yes?

    0
    Comment actions Permalink
  • I would assume that it would have the same coverage unless you are roaming as I don't believe roaming is enabled yet. But if you were not roaming on EDGE, you should have the same coverage as you're using the same network.

    0
    Comment actions Permalink
  • John Stepto, I had the excact same symptoms on my Moto X 2nd Pure Edition when I had my APN settings entered incorrectly. Once I corrected the settings the battery and heating problems went away. Seems the phone was working too hard trying to do something it couldn't. I wasn't able to find the correct APN settings for your phone. Hopefully a TING Army member can point you to the necessary link. My Moto X has been working perfectly on Ting GSM since getting the settings right.

    0
    Comment actions Permalink

Please sign in to leave a comment.