GSM public beta discussion

(If you haven't already, head over and purchase your Ting GSM X1 SIM card.  Once it is delivered (expeditiously), you'll be ready to go!)

Thanks for taking part in the public beta for our GSM service!  There are a few things that aren't yet ready, so we wanted to be sure to point those out...

 

  • International long distance.  For now, you'll need to use an alternative service like Google Voice or Skype.  We're working on offering considerably better rates for calling overseas, so we promise it's worth the wait.  You can now enable international long distance for your GSM lines in your account dashboard.  Rates are the same as on GSM, although we're still aiming to lower international long distance rates for both CDMA and GSM later this year.
  • International roaming.  GSM opens up a lot more doors for customers in terms of travelling abroad.  We still think your best bet is to use an unlocked device with a local SIM or a service like KnowRoaming.  But we will offer international roaming in the near future.  (Keep in mind the rates will be different from our CDMA international roaming rates.)
  • Mobile apps.  Our iOS and Android apps do not yet support making settings changes for your GSM lines.  Updates will be pushed to the App Store and the Play Store later today, but it may take a few days for those revisions to get approved.  In the meantime, head over to your web dashboard for any GSM device settings changes.  Our iOS and Android apps have been updated to support making settings changes for your GSM lines.
  • Account dashboard.  We're still working on the best ways to handle GSM device settings on your account dashboard.  Also, MMS cannot currently be disabled from your dashboard.
  • Caller ID. Outgoing Caller ID Name cannot currently be updated. We'll update when the option becomes available.
  • iPhone features.  Certain iPhone features, including visual voicemail, Wi-Fi Calling, and group messaging are not yet supported.  We hope to offer these options later this year, but we don't yet have a definitive timeframe.  (If these features are critical to you, they are supported on our CDMA network.)  For more on using your iPhone with our GSM service, please see here.
  • Wi-Fi Calling.  If you have a device with firmware that supports the Wi-Fi Calling feature provided by our GSM network partner, it should now work once it is enabled on your account dashboard.  It may take up to 24 hours for the feature to fully provision to your device.  Please keep in mind, Wi-Fi Calling minutes and messages still charge at the same normal rate as a tower-based call or minute.  Wi-Fi Calling is still very much a work in progress, but a number of our customers have found it to be helpful for improving coverage indoors.

 

If you're having some issues finding the correct place to update APN settings for your specific device, our activation series covers a wide range.  If you come across one that we haven't documented but you manage to get it working, we'd love it if you could share your steps here for us to kindly borrow.  ;)  If you're wondering about the compatibility of a specific device, take a look at our article here and be sure to use our compatibility checker.

Last but not least, we're here to help.  If you run into issues, please share what's going on here.  Either a Ting team member or one of your fellow customers almost certainly has the answers.  If something is seriously broken and it's getting in the way of what you need to get done, please get in touch with us via the normal channels so we can help right away.  Our first GSM activations were almost three months ago.  Our first beta customers joined over a month ago.  Things are quite stable, but we're still tweaking and perfecting everywhere we can.

Without any further ado, we'd really love to hear how things go for you, both during and after your activation.  Thanks for being a part of our GSM beta!

5

Comments

491 comments
  • Yes, everybody has had to enter the APNs.

    See https://help.ting.com/entries/105885676-GSM-Android-APN-Settings

    0
    Comment actions Permalink
  • I'm also having trouble with MMS while Wi-Fi is turned on. I have a Moto X (Gen 2) and a Samsung Galaxy S4 (Google Play Edition). I've checked the APN settings a dozen times and created a few new APN entries but if Wi-Fi is enabled and connected, the MMS message will not go through. Plain SMS will work just fine on and off Wi-Fi.

    I don't know if it's related but I do live in a 2G/EDGE coverage area. We have LTE nearby so I'll have to jump on some public Wi-Fi and see if MMS fails there as well.

    0
    Comment actions Permalink
  • Unlocked 2013 Moto X with ting.com GSM SIM.  So far, so good.

    0
    Comment actions Permalink
  • Christopher,

    Here is one answer for the Moto X. https://forums.motorola.com/posts/10824d2b7e

    and another. https://forums.motorola.com/posts/9a09641bed

    I looked for the Galaxy S4 and found an official T-Mobile answer. Apparently, you need to turn off IPv6. Remember they use different APNs. See https://support.t-mobile.com/message/368952

     

    Justen will need to chime in to say whether MMS over Wi-Fi works for Ting GSM. According to the second link, this may be model-specific. If so, hopefully Ting could get a list of affected models to add to their GSM FAQ.

     

    I did not test MMS over Wi-Fi. Hopefully, I will get a few minutes this weekend to test.

     

    0
    Comment actions Permalink
  • @ Robert

    Go the XDA site and pose your problem to those guys.  If anyone can figure out how to change the protocol, they will know.  Some phones including some LGs have higher level menus that can be accessed by knowing the trick.  Here's the link for the AT&T LG G3 at XDA:  http://forum.xda-developers.com/att-lg-g3

    Also, see if you can get MMS to work by turning off Wi-Fi.  If it starts working when you do, let the guys at XDA know that fact and it will help them diagnose the situation.

    You may have to root the phones to get the access you need.  There should be info at XDA on how to accomplish that as well.

    Another thought is to visit with AT&T and see if the phones are somehow still locked in such a way that you can't access the proper protocol menu.

    DC

    0
    Comment actions Permalink
  • So after a long and aggravating phone call with LG i have been told that on Unlocked LG devices it is a security feature that stops you from editing the APN Protocol option. The Device is rooted and i have posted a thread on XDA but this is really aggravating.

    0
    Comment actions Permalink
  • That sucks.  Sort of begs the question of the meaning of unlocked.  

    0
    Comment actions Permalink
  • TEXTING ISSUE: Succeffully ported a Nexus 5 over to GSM.  All is working except for a specific texting situation.  Plain text messages going through just fine.  But if I add text plus a photo, then only the photo shows up,  and instead of the text I get <Subject: NoSubject>

     

    I have made the ** http://wholesale.mmsmvno.com/mms/wapenc update**

    IDEAS?

    0
    Comment actions Permalink
  • Les,

    It your phone set up for IPv4 only? Many have had strange MMS issues with IPv6 enabled. Just a thought.

    0
    Comment actions Permalink
  • I did see that reference and switched everything else back to IPv4 before reporting the issue above.

    Also, in further testing, I added the android built in emoticons and it receives those icons, but when sending out, it turns them back to text  (this is from a Nexus 5 to Nexus 6 phones).  

    0
    Comment actions Permalink
  • I just successfully send a photo with text from my Nexus 5 using Wi-Fi t, since I had not checked MMS using Wi-Fi. The iPhone 5 received it fine.

    Did you bring your Nexus 5 from Sprint or Ting CDMA? Some people had issues getting all the settings correct.

    See also https://help.ting.com/entries/104696833-Troubleshooting-GSM-Picture-Video-MMS-Messaging

     

    0
    Comment actions Permalink
  • The two phones I testing (Nexus 6 and 5) were both originally Ting devices that I have now converted over (with same phone numbers) to GSM.

    Curious that the the N6 works fine, but some issues with the N5 (as described above with some texting features)

    0
    Comment actions Permalink
  • I moved my Nexus 5 from T-Mobile to Ting GSM. I found it worked much better when I rebooted it after activation.

    Here is some advice from people who moved a Nexus 5 from Ting CDMA to Ting GSM.

    IHere is what I wrote earlier on switching from CDMA to GSM:

    1. This is probably the easiest way. Have your SIM eject tool ready. Go to the dialer and dial *#*#72786#*#* (note you must have the CDMA SIM in and have some signal for this command to work) and immediately remove the CDMA SIM. This will erase the CDMA carrier settings. Now put the GSM SIM in while it is restarting. It should automatically switch to GSM and pick up the Ting service but you will see a exclamation point next to the signal strength icon indicating a problem. That is because you haven't set up the APN yet. Go to Settings > More > Cellular networks > and you should now see Access Point Names. Create a Ting APN per the instructions at the beginning of this thread. Restart the phone and everything should work. 
    2. This is the other way that works... you don't need to do both. Go to Settings > More > Cellular networks > and change Preferred network type to "Global." Replace the CDMA SIM with the GSM one. The Access Point Names menu should appear (you may need to exit out of that settings menu and then return before it shows up) so you can add the Ting APN. Select the Network Operators menu and tap "Choose Automatically" which will register you on the Ting GSM network.

    Hopefully some of this will help.

    0
    Comment actions Permalink
  • MY APOLOGIES!  My testing was not 'sound."  Turns out that my daughter is using Handcent and I'm using Google Messenger.  

    When using the same app (Google Messenger) I get the identical results with everything working.  So the issue is with Handcent (although that introduces new questions as this app has been reliable in the past . . . but that is for me to investigate).

    0
    Comment actions Permalink
  • Back in the day, I brought a couple of phones to Ting CDMA.  At the time, there were fewer than 10 phones that were BYOF.

    Now the Ting GSM, there seem to be an unlimited (relatively speaking) of options.  After  watching these beta forums, it's obvious that some phones are easy to configure and some seem near impossible with what we know now.  At some point in this process, it would be a worthwhile exercise for the Tiny brain trust to list which is which so future Ting BYOP customers will have an easier path to nirvana.  

    I will start out:

    OnePlus One - Piece of cake.  Includes Bands 2 & 4 for LTE.  Also does 3G and h+

    Lunia 1520 (ATT) - easy, mms must be set to IP4 from IP4IP6.  Developer mode used to turn on all radios.  Includes bands 2 & 4 for LTE.  Have not seen 3G or h+

    Lunia 1520 (ATT) - Easy, also Bands 2

    0
    Comment actions Permalink
  • I have a ZTE Zmax brand new from T-Mobile. It activated okay following the instructions given here at Ting, but I had some issues getting data to work. Basically, my phone was showing a full LTE signal, but only when I changed the network mode from LTE on (automatic) to LTE off (automatic) was I able to access data at all. So can my phone not use LTE or is there some other setting I need to tweak to get it working? It seems really odd to me that I can get a LTE signal but no data access (data is all turned on on the phone and through ING, BTW).

    I am coming from a CDMA Moto G with only 3g, and even with my current settings data seems way faster than that, but I'm not sure how to tell what bands I'm actually accessing. For the record, I believe the compatibility checker indicated that I should have access to 2g, 3g, and LTE frequencies on this phone. It is a T-Mobile phone after all, released just last Fall.

    Any help would be appreciated. I am out of my league a little with troubleshooting mobile devices.

    0
    Comment actions Permalink
  • That should say data is turned on through Ting, not ING. Oops.

    0
    Comment actions Permalink
  • Try turning off IPv6 and using IPv4 only. Many phones have IPv6 enabled by default and people have has issues when it is enabled.

    0
    Comment actions Permalink
  • I didn't think it would be too much to ask to get a straight answer from someone at Ting, but here I am asking a third time.

     

    I switched from Ting CDMA to GSM on my Nexus 6 on the 23rd of February. I am noticing frequent network flapping. The network designation in the top left of the phone switches between "Ting" and "No Service" (or "Emergency Calls Only"), and I went from 96% battery to 50% battery overnight.

     

    I have full reception, and I'm not dropping calls, but this is causing a significant battery drain, such that I have had to go on airplane mode and then turn on wifi, and rely solely on Google Voice VoiP calling while in wifi range to limit the battery drain.

     

    I spoke to Ting support on the 24th and was reassured that it was a known issue and would be resolved before the end of the beta. I spoke to them again today with an unrelated question, and brought up this network flapping issue again. The person with whom I spoke did not know anything about the issue.

     

    So, since I am getting conflicting responses on this from customer service personnel, can I please get a more official response from someone at Ting on the technical side of things? Thanks.

    0
    Comment actions Permalink
  • Erik,

    It looks like you got lost in the noise.I guess nobody else is seeing this issue.

    Email Justen Burdette (j@ting.com). He is doing a lot of work on this beta. I have been working with home testing services and hardware. He should be able to track down this issue.

     

    0
    Comment actions Permalink
  • Erik - I have a nexus 6, and at my house I don't have the best coverage. It also switches between Ting and no service, but I am not seeing the same battery drain that you are. I am going the next android update will enable WiFi calling. Like Bruce said, you should contact Justen.

    0
    Comment actions Permalink
  • Christopher,

     

    That's the thing, I have perfect reception, so I don't think the issue is reception-related.

     

    I will contact Justen.

    0
    Comment actions Permalink
  • @Bruce 

    Thank you! That was exactly the fix I needed.  LTE is working perfectly now! 

    0
    Comment actions Permalink
  • I just got my first bill after switching/porting my lines from Ting CDMA to Ting GSM.  I was overcharged for # of devices. The CDMA lines were not prorated and were billed for the entire month.  The GSM SIMs were prorated for the partial month.

    'Cody G'  (via chat) was able to credit me the small difference (around $3). 

    0
    Comment actions Permalink
  • Ting does not normally prorate device charges. I am glad support was able to assist, though.

    0
    Comment actions Permalink
  • Bruce: in theory there shouldn't be a device charge to prorate since Chris just moved his number from one device to another.  It's not too surprising that it came up though since this is actually a port between the two networks.  I've seen some comments from people talking about swapping back and forth between GSM and CDMA depending on which network is stronger where they travel.  This could get annoying for people who do that.  Certainly not a show stopper, but this is something Ting may want to address prior to official GSM launch.

    0
    Comment actions Permalink
  • Ting bills by device, not phone number.

    I just reviewed my bill when I transferred from Ting CDMA to Ting GSM. I paid the full price for Ting CDMA even though the device was not active most of the month. It appears the new GSM SIM was prorated, though. It was active for most of the month.

    I believe Ting has stated elsewhere in this forum that they do not prorate devices leaving Ting.

    0
    Comment actions Permalink
  • Erik Johnson: I am experiencing the EXACT same thing (network flapping) on my Nexus 6.  Can you post anything you hear from Justen?

     

    0
    Comment actions Permalink
  • Anthony,

    To you have IPv6 turned off? Many people have had strange issues with IPv6 on. Many phones now have it on by default.

    0
    Comment actions Permalink
  • Bruce: Do you mean in the Ting APN settings?  (ie APN protocol from "IPv4/IPv6" to just "IPv4"?)

     

    0
    Comment actions Permalink

Please sign in to leave a comment.