Finally got data working by unchecking and then re-checking "Can access the Internet"

Finally got data working on Galaxy Note 2, like-new refurbished, genuine, rooted, by unchecking and then re-checking "Can access the Internet".

I had to perform a "hardware factory reset", a.k.a. "hard reset", in order for "System Update" to work without crashing Settings, possibly because of rooting though I didn't test it before rooting. Rooting survived hard reset.

After hard reset I did Update PRL and Update Profile as suggested by support, but still no data. :( With no other ideas I randomly tried unchecking and then re-checking "Can access the Internet", which triggered a second PRL update notification. After this PRL update data finally worked.

1

Comments

1 comment
  • Activated a galaxy note 2 and couldn't get data to work, either. Followed your instructions for unchecking and rechecking "can use data" followed by a PRL update and now it works! Thanks for sharing this.

    0
    Comment actions Permalink

Please sign in to leave a comment.