Google Voice Voicemail setup

Was unhappy to learn that Ting doesn't support voicemail notification or Google Voice Lite for Voicemail.  Thought about it awhile and came up with this workaround.  Seems to work ok.  Google Voice Lite allows your phone linked to Google Voice to act as a replacement for your Ting voicemail.

Set up Google Voice lite on your Google Voice account.  Settings allow your device to intercept your voicemails.  The activation settings prompts you to enter *28(your google voice#).  This returns an error since this isn't supported by Sprint or Ting for our devices.

Make sure you have "Call Forwarding can be set on phone" checked on your device settings on the Ting Dashboard.

*72(Google voice #)  (will ring and call will end.  This temporarily forwards to your GV#)

Click Done on the Google Voice prompt (this will now show the voicemail is active for your google voice account and your Ting Cell#

*720  (unforwards the previous forwarding, leaving your GV voice mail still active).

Back to Dashboard:

Click on Forward Busy signal to this #  (your GV #)

Click on Forward "No Answer" calls to this#  (your GV#)

At this point you are done. 

I've tested my configuration.  Seems to be working properly.  I'm getting updates through the GV app, alerts to text and email and transcription appears to be working as well.

This should work until Ting talks Google into supporting them directly.

Keep in mind that you'll still be charged minutes for calls forwaded to your Google Voice#.  I'm ok with that because I want to know I have voicemails in the event I miss the calls.  Not having a decent notification system is something I'm not willing to do without.

Hope this helps someone.

TMPOOLE

28

Comments

49 comments
  • Thanks, worked for me as well, much appreciated!

    0
    Comment actions Permalink
  • Great solution for custom ROMs as well.

    Thanks!

    0
    Comment actions Permalink
  • Seems to work well. Wish I could just activate Google Voice to be the voicemail provider without doing this, but it works at least with m S3.

     

     

    0
    Comment actions Permalink
  • At least we only have to do it once.  I haven't had to touch my settings since the original setup.

    Glad its working for others as well.

    0
    Comment actions Permalink
  • Appreciate the tips. Thought I'd also point out the following:

    Since I'm using my Google Voice number strictly for voicemail now, an additional option I enabled is the DND option in the "Calls" tab so that calls are sent straight to voicemail after being forwarded. 

    1
    Comment actions Permalink
  • Appreciate the hint.  For me though, I'm forwarding my office line at night to my Google Voice number so that my calls are directed there instead of my cell.  Otherwise I'm getting billed for forwarded calls from my cell if I can't answer them.  My Google voice automatically calls my cell (which I answer if I can) and otherwise sends my calls to voicemail if my phone is busy.  That works best for me.  I just want to be sure that my voice mail answers if I am on the phone.

    I don't understand why Ting doesn't have a better setup for voice mail, but this works well for me.  I like the Google voice app and I like the transcription service also provided.  Would I use the Visual voicemail if Ting ever gets it available for us - sure.  This works well enough meanwhile.

     

    0
    Comment actions Permalink
  • Perfect solution so far. I haven't tried out every scenario with calls and voice mail, but I'll report back if anything behaves oddly.

    0
    Comment actions Permalink
  • Todd:

    Thanks for the post. Your method to conditionally forward calls is sound and well documented here and elsewhere.  

    You said ..."This should work until Ting talks Google into supporting them directly"...  I'd like to point out that it's not Google's lack of supporting Ting, it's Ting not having the method of using key-press entry to initiate CCF.  A very common issue with trying to use Google voicemail with a MVNO. and is a result of the contract between Ting and Sprint.

    [CCF = conditional call forwarding]

     

    0
    Comment actions Permalink
  • Hmm, thanks for the tip about the "do not disturb" setting.  I didn't even know that was there, and should make things a little smoother.

    0
    Comment actions Permalink
  • I've been using google voice for years and have configured it multiple times, but am confused by this step:

     

    Click Done on the Google Voice prompt (this will now show the voicemail is active for your google voice account and your Ting Cell#

     

    When I add in my phone # for my Ting phone into Google voice, it says it "must verify your phone", google then calls me and I enter a 2 digit code. It's then active as a additional phone #.  The only thing that is different is I used to have google voice AS MY SPRINT PHONE #...as soon as I changed to Ting, my google voice # changed to another phone #, but I had my ting #(which was my previous google voice/sprint phone #), showing as a "registered phone"...

     

     

    0
    Comment actions Permalink
  • I had a similar setup.  GV didn't allow me to port my Sprint Phone# to Google Voice, so I had to accept a new and different number.  It doesn't make any difference, if you follow the directions.  Don't mistake activating your phone on GV with setting up your GV for voicemail.  You seem to be discussing a different step than I am trying to present.  It's easy to link your ting# to Google Voice.  The trick is to work around the authentication required to use GV for voicemail.  Good luck.

     

     

    0
    Comment actions Permalink
  • I just get a "the feature code you entered is not valid"

    I put in: *72{10 digit GV num}

    as well as: *72{11 digit GV num}

    10 & 11 digit referring to the full area code. I already enabled forwarding in the Ting panel. Any ideas? [HTC One :: Stock ROM]

    0
    Comment actions Permalink
  • The only time I've seen feature codes not work was when I wasn't using a Sprint Tower so it didn't recognize the feature code.  If you are on a Sprint Tower, then  call Ting and have them troubleshoot the problem.  This is something your phone should allow.  Good Luck.

    0
    Comment actions Permalink
  • Edward, I never did understand why he's doing the complicated thing with all the *72 codes and "forwarding can be set on the phone".  I did none of that, and it's completely simple to use the separate GV phone number just for voice mail.  It's not the Sprint integration, which may be what some of those code things are about.  Here's the setup, and why it's so much simpler:

    In your Ting dashboard, you check the boxes for forwarding no answer and busy calls to your Google Voice phone number and enter that phone number there.  Period.  That's it.

    I have the Google Voice app on my phone, so on wi-fi or mobile data, I can get the messages.  It has the (attempted) transcribed to text version and the audio I can play.

    1
    Comment actions Permalink
  • Well, I am not sure as to why, but I am having a hunch -- I keep getting a female voice telling me, "I'm sorry, we cannot complete your call. Please try again" from my home phone when I call my cell #. This is how I have things setup so far.

    The Cell phone SETTINGS under VOICEMAIL (on the phone app) are set to GOOGLE VOICE

    My_** ACCESS NUMBER** _in Google Voice is (304) xxx-xxxx, however, that is NOT the same as the number that includes the "*28" and a phone number. The bad thing is that I did not write that number down. I assumed it would have to be SOMEWHERE in either the GV app, or on my account. Well, it seems I was wrong. 

    When I called the 304-xxx-xxxx number DIRECTLY from my home phone I got the same error message ("I'm sorry, we cannot complete your call. Please try again) which verifies to me that both TING and my phone (Samsung Galaxy Nexus #3) are correctly forwarding the call. My question is, where can I find the number that was displayed during the GV install?

    Sorry this is such a simple (lame) question, but I have looked everywhere I can think of all with no luck. Thanks in advance for the assistance!

    Bill C.

     

    [Edit: Phone number removed for privacy]

    0
    Comment actions Permalink
  • You should be able to go to your Google Voice account online (voice.google.com) and login under the account that the phone number was created. The number for me is listed on the left side of the screen.

     

    Tim

     

    0
    Comment actions Permalink
  • I thought GV Lite was for using your mobile number rather than a GV number. These instructions seem to be for using a GV number, which are not available at the moment: http://productforums.google.com/forum/#!topic/voice/lYg7vCA9WYQ

    How would I go about forwarding to GV without a separate GV number? This is so my mom can read her VM's in her e-mail. Thank goodness I already have a good GV number for myself! Who knew they would become as scarce as hen's teeth?!

    0
    Comment actions Permalink
  • Um wouldn't enabling do not disturb on google voice and just updating the setting in the dash do the same thing?  

    0
    Comment actions Permalink
  • Just weird that you have to jump through hoops to get this working. Also how the heck do i get rid of the sprint voice message texts?  

    0
    Comment actions Permalink
  • Also a temp workaround for me was to just disable texting altogether.  I've only received like one actually wanted text recently but it's not ideal by any means

    0
    Comment actions Permalink
  • "Click Done on the Google Voice prompt (this will now show the voicemail is active for your google voice account and your Ting Cell#"

    Confused by this step - not sure where 'Done' button is on Google Voice prompt.

    Clarification appreciated.

     

     

    0
    Comment actions Permalink
  • David Brigham:

    The menu prompts you see in the GV voicemail set up are only instructions.

    Clicking either instruction to Activate or Deactivate and then "DONE" results in only toggling the instructions.

    Please remember that Ting does not support the directions given in the menu at Google for activating call forwarding and you must use the options in the Ting Device dashboard.

     

     

    0
    Comment actions Permalink
  • I was able to setup visual voicemail on my Galaxy Nexus by following instructions at:

    forum.xda-developers.com/showthread.php?t=1416590

    For me to get into GV setup I had to uninstall then reinstall updates from Google Play.  After that I followed instructions as given.

    Key: Do not set up Sprint integration - skip it.  Then use your Google account  and choose Google Voice as your voicemail service.

    You can then configure Google voicemails from the GV app.

    I just tested this and it works

    Thanks to those who responded to me.  Hope this helps.

     

     

     

    0
    Comment actions Permalink
  • David:

    That set up is pretty clear cut, glad you understand how to use Google voice.

    it's the Google lite voicemail only set up that is the original discussion in this thread

    0
    Comment actions Permalink
  • Thanks - this worked perfectly...however, when i call my cell from a landline to test, my cell doesn't ring.

    0
    Comment actions Permalink
  • Set up GV as voicemail for a client's new Nexus 5, had a few issues with busy/no answers being told something along the lines as "There was a problem, please try again later, until I realized 'Voicemail' had to be enabled on the dashboard.

    So,

    *72(GV#)  (ex. *721112223333)

    Update GV number in GV app

    *720 

    On Dashboard:

    Make sure "Voicemail" is checkmarked.

    Checkmark Forward Busy signal to this #  (GV#)

    Checkmark  Forward "No Answer" calls to this #  (GV#)

    This configuration method works on the three phones I've set up for them thus far.

     

    1
    Comment actions Permalink
  • Still doesnt work for me. I just get the message "The feature code you entered is not valid" when I dial that number.

    0
    Comment actions Permalink
  • *That number being *72 my number.

    0
    Comment actions Permalink
  • Edward:

    The instructions for setting up Google voicemail are to use the Ting dashboard settings.

    The codes that you see in the Google voice documentation will not work for Ting. 

     

    0
    Comment actions Permalink
  • Yeah, I don't understand what any of that *72 stuff is supposed to do.  Like Robin said, I just have my Ting number set to forward to my GV number, and it picks up and takes the voice mail.  There's not really a "setup" or "configuring" to it.  I did set my GV account to "do not disturb", just so it will go to voice mail immediately, instead of also ringing a few more times.

    0
    Comment actions Permalink

Please sign in to leave a comment.