[FIX] TING MMS CM10

This applies to anyone running Cyanogenmod 10.1 (CM10.1) definitely, and most likely other ROMs such as AOKP, CM9, CM10 etc.

When one flashes a custom ROM, APN settings that are necessary to send/receive MMS are changed, because the default values are for Sprint.

 

Disclaimer:

DO THIS AT YOUR OWN RISK. While this worked fine for me, and you're not messing with anything too important, I am not responsible for anything you may do to your device.

 Credit to Andrew Willing in the Ting forums for new method.

 

  1. From the launcher/desktop, Add > Shortcut > Activities > com.android.sprintmenu > MMSC .MMSC

  2. Use that shortcut to access your MMS URL.  Change it to the correct URL for Ting, http://mms.plspictures.com

  3. profit!

 

A note: stock AOSP messenger does not as of right now have code built in to send MMS over wifi, unlike Touchwiz or other. It might be worth looking into the Gnex or Nexus 4 to see if there's anything there.

 

 

Old/complicated:

Requirements:

  • Root (assuming you're on a custom ROM, this is included)
  • A root explorer such as ES File Explorer with root explorer enabled in settings
  • A text editor capable of editing xml such as Jota+

 

Instructions:

  1. Open Voice Dialer, say "Open APN's"
  2. Check every one for an MMSC of "http://mms.sprintpcs.com"
  3. Change all instances of this to "http://mms.plspictures.com" and save
  4. Select one of the profiles with the correct MMSC in it.
  5. Open your root explorer, navigate to /system/etc and find apns-conf.xml
  6. Copy it to somewhere on your sdcard
  7. Open it and replace all instances of "http://mms.sprintpcs.com" with "http://mms.plspictures.com" and save.
  8. Copy and paste it back into /system/etc, ignoring warnings about overwriting
  9. Reboot
  10. ????
  11. Profit

Please let me know if anyone has any problems or if this worked for you.

A note: It might be worthwhile to keep the edited copy of apns-conf.xml you made somewhere on your sd card, as whenever you update your ROM these settings go away. Simply copy and paste the edited file into /system/etc and recheck the other apns you get to from the voice dialer.

3

Comments

56 comments
  • I did this on CM 10.1 and it did not work.  Still can't send or receive MMS.

    0
    Comment actions Permalink
  • At all or just on Wi-Fi? And what phone and build are you using?

    0
    Comment actions Permalink
  • At all.  Over wifi it acts like it sends, but the recipient never gets it.  Over 3g, it just sits at the sending animation (handcent).

    I cannot receive over wifi or 3g either.

    Phone is a Epic 4g Touch.  I am using this build: http://forum.xda-developers.com/showthread.php?t=2099881 from 2/3.

     

    I went into the data menu and when putting in my MLS i get a "Modem Exception Occurred" error.  

    0
    Comment actions Permalink
  • If you're using handcent you'll have to configure apn settings in the app, I don't use it

    0
    Comment actions Permalink
  • Doesn't work with the stock messaging app either.

    0
    Comment actions Permalink
  • Have a look at  https://play.google.com/store/search?q=apn+backup+and+restore&c=apps

     Make sure the spelling is correct. 

     

    0
    Comment actions Permalink
  • There might be something to be done inside the messaging apk as well, I'll look into it.

    0
    Comment actions Permalink
  • I'm on an Epic4g and can't receive messages. It used to say it was downloading and never finish. I updated everywhere possible (APN, dialer code, and apn config xml) the sprint mms URL to Ting's and still can't receive messages. Now it just tells me that I can't download the message and gives me an error notification. I'm on CM10 and trying to use stock messaging. Please let us know if you find anything else that needs to be updated.

    0
    Comment actions Permalink
  • Oh, sorry for the double-post. APN backup and restore will not work on CM10 because it is JB based and it is not supported. I thought I saw somewhere that there was a workaround for a rooted phone but they did not say what that was.

    0
    Comment actions Permalink
  • The work around for APN Backup and Restore is to use Titanium Backup to make it a System App, then go into settings for APN Backup and Restore and check the option for ICS.

    I did this and it still didn't work.

    0
    Comment actions Permalink
  • I was able to get MMS working on the Epic 4G running CM10.  I only needed to go through steps 1 - 4 and MMS was working without a reboot.

    0
    Comment actions Permalink
  • Does the build of cm10 make a difference? I am running the stable build.

    0
    Comment actions Permalink
  • The "and save" bit at the end of step 3 tripped me up. I didn't realize that I had to use the menu key to save my changes. After a reboot, all of my APNs were gone. I have no idea why, but it removed all of the Sprint entries from my apns-conf.xml.

    I re-flashed CM10.1 and tried again, saved the changes to my APNs this time, and it worked like a charm. Thanks so much for the how to. I'm so glad I can keep using CM with Ting.

    0
    Comment actions Permalink
  • For those who have had success with this, would you mind posting a screenshot of your APN settings? After flashing my ROM, I believe my APN settings got all screwy. Thanks.

    0
    Comment actions Permalink
  • Did it on 10.1 on Samsung Epic and can send back and forth with both Ting phones and can send to non Ting but can't receive non Ting MMS.

    0
    Comment actions Permalink
  • @rodney I'm having the same issue. Very frustrating.

    0
    Comment actions Permalink
  • I can send and receive with someone on Sprint. Waiting for some test results with a few other people on different carriers.

    0
    Comment actions Permalink
  • Actually it appears to be working. The one person who it did not work with the problem was on his end. Now seems to work with several I have tested. 

    0
    Comment actions Permalink
  • What about temp-booting (e.g., the EL29 temp boot) and updating the MMS settings in that fashion?  Does that not work?

    0
    Comment actions Permalink
  • @Rodney, great! Also, sometimes the stock messaging client is a little wonky, and turning off auto-receive in its settings will help.

    0
    Comment actions Permalink
  • @Rodney: are you using the Samsung Epic 4G or Epic 4G Touch (i.e. Galaxy S II)? You have both inbound and outbound MMS working with CM 10.1 "WILD FOR THE NIGHT"?

    0
    Comment actions Permalink
  • I have the opposite problem.  I can receive MMS, but cannot send.  It shows as sent but the other person never receives.  Wild For the Night 10.1

    0
    Comment actions Permalink
  • I am running CM10.1 on my Epic 4G. My Epic 4G Touch I am still running stock. If sending doesn't work it is probably the MMSC address is incorrect somewhere.

    0
    Comment actions Permalink
  • And yes working both ways.

    0
    Comment actions Permalink
  • Attached are my APN screens.  Can receive, but not send.

    0
    Comment actions Permalink
  • Oops.  I see the sprintpcs.  I swear I changed that before

    0
    Comment actions Permalink
  • Make sure you save it. I am pretty sure there is a save option but can't remember at moment.

    0
    Comment actions Permalink
  • Yea, there is.  I saved it and tried sending a pic to myself and so far nothing.

    0
    Comment actions Permalink
  • Restart phone?

    0
    Comment actions Permalink
  • @Joshua, any luck on getting the MMS through?

    0
    Comment actions Permalink

Please sign in to leave a comment.