Mobile ID - Service Unavailable Popup on Ting purchased Samsung Galaxy S6 phone

There is an issue with Ting purchased Samsung Galaxy S6 and the embedded Mobile ID app that comes on the phone. I purchased the Samsung Galaxy S6 directly from Ting and fresh out of the box it has been experiencing a Mobile ID popup message stating 'Service unavailable' with the the explanation that 'An unexpected download error has occurred. Please try again. Code: 30'. This popup message appears every time I reboot the Ting provided S6 mobile phone, and it keeps reappearing periodically throughout the day. Even though this message only pops up a few times a day is not totally annoying, but it should not be happening at all. I have a help ticket open with Ting, but they have not responded to it in a few days which is why I'm posting this in the open forums now in case other S6 owners are having this same issue. Right now I'm not sure if Ting is working on this issue, or if they are even concerned about it as they have had all week to respond and/or resolve this issue. Ting help's last response was something about this Mobile ID app being 'bloatware'. Well, I cannot remove or even disable this Mobile ID app on the S6 so this needs to be resolved by Ting.

According to Sprint who is the home owner of Ting's service and the branded phones they sale, Sprint explains the Mobile ID as:

Mobile ID – Mobile ID delivers a complete mobile experience – centered on consumers’, students’ or businesses’ interests or favorite brands – including applications, widgets, ringtones and wallpapers, all in a couple of simple clicks. With more than 6 million downloads in the United States, Sprint smartphone users have already begun to harness the power of ID packs to create their own experiences while catering to different tastes and hobbies. Mobile ID enables personalization for the end user that offers access to a broad array of categories, allowing MVNOs to deliver a successful customized application to defined markets and customer segments.

Reference: http://newsroom.sprint.com/news-releases/sprint-introduces-custom-branded-device-program-enabling-mvnos-to-custom-brand-white-label-android-phones.htm

Reading this, it looks like Ting could provide their own Ting Android app in a Mobile ID Pack offering to signify their own 'Brand'. But, alas their is nothing currently available so the Mobile ID app just annoys the user right now.

1

Comments

59 comments
  • Call or chat with Ting support to get the official work on whether they support Mobile ID. Perhaps there is a setting somewhere that needs adjusting.

    0
    Comment actions Permalink
  • My family has two S6 devices with the exact same issue. Just as Wayne states, the error appears after every reboot and then periodically throughout the day. It's very annoying. Is there a resolution from Ting or anyone else for this issue?

    0
    Comment actions Permalink
  • Actually, in my rather lengthy email string with Ting support, they are shipping me a new replacement S6 at this time. They advised me in the long email string conversation that this should not be a widespread issue with the Ting S6. However, you have two more Ting S6 phones doing the same thing. Anyway, I'll find out if this Mobile ID popup message re-appears on the new S6 after I receive and activate it which should be sometime this week according to the shipper. If this Mobile ID popup message re-appears on the new replacement S6 phone, then I wonder what Ting will do next. Anyway, you should contact Ting support as soon as possible to ensure they know a few more Ting S6 phones are having this Mobile ID popup issue, and you should ensure they will to replace them if in fact that resolves this Mobile ID popup issue. I really like Ting, so giving them the benefit of my doubt, maybe Ting received a batch of S6's from Sprint that were meant for another Sprint MVNO that actually uses this Mobile ID 'Bloatware' app as they referred to it as being.

    0
    Comment actions Permalink
  • Update: I received the second new S6 from Ting today, and after activating it the Mobile ID popup message is still popping up. Every reboot, and a few times after that. Oh well, now I have to find a Fedex authorized shipper near me to return it so I don't get charged for it.

    0
    Comment actions Permalink
  • Hey everyone, just wanted to let you all know that we're looking into this. Will be working with the Sprint wholesale channel to resolve and will keep everyone updated as we make progress. Thanks for flagging this, hoping we can find a quick solution for everyone.

    0
    Comment actions Permalink
  • Is Ting using the Custom Branded Device Program? A program where Ting devices are automatically modified through Mobile ID and Mobile Zone, giving Ting the ability to extend their own brand directly to end users through over-the-air activation?

    "MVNOs have greater access to completely de-branded devices from Sprint

    Coupled with white-labeled Mobile ID and Mobile Zone products from Sprint, MVNOs can extend their brand elements to end users more efficiently"

    0
    Comment actions Permalink
  • Any more info or updates on this? I really want to buy a GS6 from you guys, but not until this has been resolved.

    0
    Comment actions Permalink
  • Thank you Brad for the uplifting comments. I'm patiently waiting for updates.

    So far, it isn't totally annoying though. I only see it about three times in succession every time I reboot the S6, and if I don't reboot, I just see it once every morning when I first look at my S6. So, I'd still purchase the S6 since it has a lot to offer, providing Samsung doesn't renege on their promise of Samsung Pay with the magnetic swipe feature. So far, they have already made the Themes feature a totally worthless offering if you ask me.

    On a positive side, I did notice that maybe due to this Mobile ID app is having this issue, there are absolutely no Sprint apps, except for voicemail, loaded on this S6. I pretty sure that my previous Samsung S3 and S4 Ting phones had all those Sprint apps on them.

    0
    Comment actions Permalink
  • I am pleased to hear Ting is working with Sprint to research and resolve this issue. Here is link to a screenshot of the error: https://plus.google.com/107997355820649754680/posts/jQMG2fqaGQ7.

    Despite the annoying error, I must say that my wife and I love the S6. The OLED screen is outstanding and the camera is excellent. The photos captured are by far the best I have ever seen from a phone. I was also pleasantly surprised to see no Sprint bloatware. Wayne may be on to something. If the phone is not seen as a Sprint device, the Mobile ID app may be looking to authenticate the MVNO.

    0
    Comment actions Permalink
  • @Wayne, check the theme store now, they added one called Material. It makes the phone look more like stock Lollipop if that is something you are after. Tons of people have been waiting for this. All the other ones look like they were made for kids.

    Also, I currently have a very early Ting S4 and it has zero Sprint apps. You can't even tell it is a Sprint phone. There is no Sprint branding anywhere.

    0
    Comment actions Permalink
  • Hey everyone, I'm continuing to push this issue along with the Sprint wholesale team. David was kind enough to share the screenshot with me, we've used it to help further communicate the issue.

    This does indeed look to be a defect of how the device is 'white labelled' and provisioned for wholesale and MVNOs. We do not have any custom branded devices, we just keep them white label. It looks like this error is occurring because Mobile ID is looking for this branding profile.

    Thanks for everyones feedback and patience, I was able to quickly report the exact issue to Sprint thanks to all the information in this thread. Stay tuned for updates, will make sure to keep checking in.

    0
    Comment actions Permalink
  • Brad, I presume from your comments that the help desk ticket #789477 that I opened with Ting back on June 5th never makes it to the right people at Ting like you. Because I had all of this in the ticket, including sending Ting a screen shot way back on June 7th.

    0
    Comment actions Permalink
  • Brad, here is an update. An update to android 5.1.1 (OF7) pushed out today and I received the notification and loaded the update this morning. After loading the 5.1.1 update, it appears I'm not getting this popup message, but rather a notification bar message advising of a 'Download Error' 'stating 'No action required. ID will automatically retry'. It seems with the update to 5.1.1, the Mobile ID app was updated and simply changed the Mobile ID popup message to a notification tray message that has to be swiped away. It still appeared three times in the notification tray after a reboot, and I imagine it will be there every morning too. At least it's somewhat better to deal with, but keep moving forward with your carrier ID branding.

    BTW, if Ting does start providing their own carrier ID branding via this Mobile ID app, I hope that Ting will be able to restore the Mobile Data quick toggle in the notification bar. Samsung released a Quick Toggles Restore app in their Samsung app store, but the app doesn't work on this Ting (Sprint) S6.

    0
    Comment actions Permalink
  • This morning my S6 greeted me with a notification that Mobile ID was successfully installed and no download error message. The Mobile ID app now has an update applied. I restarted the phone and was pleased to see no error message again. Hopefully, this means the issue is resolved.

    On a side note, the new Material theme mentioned by Drew SR is fantastic. Coupled with my solid black wallpaper/lock screen, it almost feels like stock Android. This phone is awesome.

    0
    Comment actions Permalink
  • I too received the Mobile ID app update, and so far no popups or notifications since.

    As for those themes, I have been waiting for the Marerial Dark and it is finally available. I just hate the fact that only 'sponsored' developers can do themes and not a typical user like me. I just want to create my own theme without publishing it.

    I will say that the first few days since the android 5.1.1 update, my battery life has changed drastically when not on WiFi. Before on 5.0.2, it only went down about 25% every day while at work, but now it's doubled to 50% drainage. Wow.

    0
    Comment actions Permalink
  • Hey everyone, glad to see the roll out has made things less annoying... Still a shame it's showing up in the notification tray. @Wayne this is reappearing every time you restart your device? Does it show up daily regardless of a restart? Is anyone else having this issue after updating?

    Thanks for everyone's feedback and bearing with us while we worked back with Sprint on this.

    0
    Comment actions Permalink
  • Everything still going smoothly for you guys who have a Ting GS6? That battery draining issue after the update does not sound too great though.

    0
    Comment actions Permalink
  • The issue with Mobile ID appears to be resolved. I have had no notification errors since the app was updated on July 1st.

    I am also still on android 5.0.2. I know Sprint started rolling out the 5.1.1 update at the beginning of July but I have yet to receive it. Manual system update checks always fail. I've tried PRL and profile updates but the System update still fails with an "Unable to download update" error. The Last Checked date still shows 06/29/2015. Strange. I might try a factory reset if I don't have the 5.1.1 update by the end of the month. If there is a new battery drain issue in 5.1.1, I'm in no hurry to move on from 5.0.2.

    0
    Comment actions Permalink
  • @David, did you try updating your phone using Samsung's Kies software? The update maybe in there also.

    0
    Comment actions Permalink
  • @Drew - I believe Kies has been replaced with Smart Switch. I've previously confirmed the 5.1.1 update is available when I connect my S6 on a PC. I may end going that route but I want the system update issue corrected, too. I've read a factory reset should fix it. Either way, I'm not really in a hurry since my phone is running fine without it.

    0
    Comment actions Permalink
  • David, yes the mobile ID was resolved since Brad got Sprint to fix it.

    As for the 5.1.1 update, my update now date changes every time I mash that button if it's showing a previous date. I also see some onscreen popups showing me that it ran. Before you factory reset, maybe you should try going to the application manager and find the 'System Update' app in the 'All tab' and 'clear cache' and 'clear data' and then reboot before you try mashing that update button again.

    As for 5.1.1 battery life, well, I found out it was actually my Podcast app playing in the background. So, I had to change the way the Podcast app was playing the podcasts. Today I had 77% left after being unplugging for 8.5 hours. I had very little screen on time since I was pretty busy, but I did have Tasker automatically send a few text messages and automatically start my Podcast playing over bluetooth three times for 20 minutes, 60 minutes, and 20 minutes. So, 20% in an area with a weak cellular signal isn't too bad.

    Drew, as for using Samsung Kies, Kies works on all my Samsung tables and worked on my previous S3 and S4 phones, but it doesn't work with the S6. When I connected the S6, Kies just told me that the S6 is only supported by Samsung SmartSwitch. So, you need SmartSwitch for the S6 now.

    0
    Comment actions Permalink
  • Thanks for the update guys. I am still using my GS4, so I didn't know about SmartSwitch. I have to decide whether I want to upgrade to the GS6 now since everything seems to be working well.

    0
    Comment actions Permalink
  • I am having this problem with my Sprint LG G4 purchased new. Is there a simple solution to this? Restarts have not fixed the problem and I looked for an application named "ID" or "Sprint ID" without seeing one.

    0
    Comment actions Permalink
  • @ Brad Coates is there a fix for this Mobile ID pop up issue?

    0
    Comment actions Permalink
  • I am experiencing this issue as well on my HTC One M8 purchased from Ting over a year ago. My phone updated to Android 6.20.651.3 this morning and that's when this Sprint ID/Mobile ID issue started. Specifically, I keep getting this message in my notifications tray: "Download Error. No action required. ID will automatically retry. An unexpected download error has occurred. (Code: 30)."

    @Brad Coates, any update on this issue for Android devices?

    0
    Comment actions Permalink
  • Hey Ian...i'm having the exact same problem with my HTC One M8...just started today after that huge updated.

    0
    Comment actions Permalink
  • Hey everyone,

    I can look into what the HTC One M8 will require to fix. Last time, when we saw this issue with the Samsung S6 we were at the mercy of Samsung/Sprint to roll out the update. I'm assuming this will fall in the same boat.

    Will do some investigating and update everyone as soon as I can. This issue looks to be occurring on just the HTC One M8 with our Sprint service correct?

    0
    Comment actions Permalink
  • I'm having the same issue, also with and HTC One M8 after the update.

    0
    Comment actions Permalink
  • Thanks Brad, that's correct...sprint service.

    0
    Comment actions Permalink
  • Mine is an LG G4, it has been happening for approximately a month for me. Sprint also.

    0
    Comment actions Permalink

Please sign in to leave a comment.