Getting no background data even on apps where I haven't restricted it, and GV is using mobile data always for SMS, so those don't come through. Answered

Don Seiler

Setup:
Ting
1. Ported my Sprint # to GV, only use that for calls and SMS.
2. Use Google Hangouts for SMS from my GV # as well as Google talk.
3. Enable background data, then restrict it on an app-by-app basis.

Problem:
I don't get any messages, SMS or Hangouts, unless I have Hangouts open and I'm staring strongly at it. This tells me that (a) background data is not working for hangouts even though I haven't restricted it, and (b) Google Voice is apparently using mobile data for SMS no matter what? I would expect normal SMS to come through regardless of mobile data setting.
I've quadruple checked all my settings and I can't see where the problem is. /u/silicon_reverie , I'd love to know what you think.

Comments

3 comments

  • Comment author
    Jason McVicar

    Hi Don,

    This is a pretty strange one. Were you able to get things working? Maybe a profile update would help? Do you have any problems with the mobile data connection when actively using apps?

    1
  • Comment author
    Don Seiler

    Yes the problem was when I disabled background data for Google Play Services. I though it only was used for stuff like contact and calendar syncing (based on the description of the service). However it is responsible for ALL data through almost all apps. So I have to leave that one enabled. After that everything works as expected.

    0
  • Comment author
    Jason McVicar

    Wow, I didn't know that either! Thanks for coming back to let us know how it went. This will probably help a good number of people!

    0

Please sign in to leave a comment.