Stopgap for stagefright exploit

Due to the crazy new stagefright exploit, I was looking at disabling MMS for my account, however the only option is for all texting. is there a way you wonderful people could allow just disabling MMS per device or account?

0

Comments

6 comments
  • You can disable just MMS while still having texts enabled. On the Ting website under your device internet settings there is an option to turn MMS off.

    1
    Comment actions Permalink
  • Ben, thanks. You are partially correct. You can do that for CDMA devices, but not GSM SIM devices. I was only looking at my GSM phone (which is unfortunately one that received a suspect MMS today before I turned it off in hangouts).

    I know have MMS off for my CDMA phones, but we should, if possible, have the option in GSM as well.

    0
    Comment actions Permalink
  • Thanks for the update, I use CDMA and wasn't aware the option was not available yet for GSM.

    0
    Comment actions Permalink
  • Hey Ben, we looked into this a little bit, and it seems the best answer on our GSM service would be to change the MMS APN settings stored in your device to a random URL.

    That should interrupt the flow of MMS, and be the basic equivalent of disabling MMS on the network.

    Cheers!

    0
    Comment actions Permalink
  • There's also some advice out there about disabling the auto retrieval of MMS messages that might be helpful:

    http://www.pocketmeta.com/how-to-protect-your-android-device-from-the-mms-hack-stagefright-exploit-30361/

    0
    Comment actions Permalink
  • Thanks Rob, I have already disable auto MMS retrieval in hangouts on all my devices. Unfortunately, my one GSM device received a random group MMS, dutifully pre-retrieved in hangouts before I put any counter measures in place. Changing the MMS apn is a great idea. I will go do that... after I factory reset my suspect device. I hate doing it but it has access to critical and confidential business data so I have to be able to trust it.

    0
    Comment actions Permalink

Please sign in to leave a comment.