Nexus 5 MMS Problems
Answered

My wife and I are both having problems receiving MMS messages from friends ("New MMS message to download: size is 1kb, expires..."). We are also having problems both sending and receiving pictures, including to each other. How can we fix this? This has just become a problem in the past week.

0

Comments

30 comments
  • If this is on Ting CDMA, they are aware of issues and are getting some Ting Army members to help isolate the issue. Some people are wondering whether a recent update broke things.

    Chat with or call Ting support to open a ticket so they can inform you whenever they have a solution for this.

    0
    Comment actions Permalink
  • I have have a Nexus 5 as well. The official, temporary workaround is to set your phone to only use 3G. Go to settings, cellular network, preferred network type, and then set to 3G.

    However I was able to get MMS on LTE working again by switching from Google Hangouts to Textra. I haven't had others confirm this, but it might be worth a try if you really want to use LTE.

    2
    Comment actions Permalink
  • Both my wife (Nexus 5 CDMA) and I (Moto X 1st Gen CDMA) had the same problem. We were using Hangouts, thought that was an issue so moved back to Messenger. The problem still existed. When we had problems before, an update to the preferred roaming list and a phone restart would fix it, but this time took more effort to fix it.

    Our fix was to change the MMSC URL. Follow these instructions: https://help.ting.com/hc/en-us/articles/205421048-Updating-the-Picture-Messaging-or-MMS-URL-on-Your-CDMA-Device

    You'll need the MSL for your phones. You can find that on your Ting device info page.

    I entered http://mms.sprintpcs.com as the MMSC URL. In both of our phones was a "proxy URL" and "port number." I removed the content from those entries, saved the configuration, and rebooted the phones. Both phones now can send/receive MMS to multiple people with no issue. I'm not sure if the older stuff downloaded.

    9
    Comment actions Permalink
  • Sorry, that should be http://mms.sprintpcs.com, not sprintcs.com. Edit: Hey, it can be edited now!

    0
    Comment actions Permalink
  • Interesting. My wife and I have the same issue with our new-to-us Nexus 5s. I spent an hour and a half on the phone with a Ting rep a couple of weeks ago. The "switch to 3g, download the MMS and switch back to LTE / wifi" approach works every time for us. I hope there's soon a better solution. Might this issue have been introduced with the "fix" for the Android / stage fright bug? Did any of you have this issue before mid-August?

    0
    Comment actions Permalink
  • Thanks for all the help and suggestions. For now the 3G solution is working, but that is less than ideal.

    We never had any problems like this before mid-August. Before that we would have the occasional message that would get delivered late or the very rare group message from iPhone users that would have the "download" cue instead of the message, but once this started we would first get group messages 12 hours apart and then the whole problem with MMS messages as a whole.

    Hopefully an update is forthcoming that will fix all this.

    0
    Comment actions Permalink
  • Really though, changing the MMSC URL fixes the problem. It is also what Ting's help page says to do.

    I also had the problem from mid August and this fixed it.

    -1
    Comment actions Permalink
  • I am going to call them tomorrow. My Nexus 5's MMS has not been working for a couple weeks now. And none of these things have worked for me. In fact, they have made things significantly worse, because (maybe from fiddling with the 3G/LTE options) I now have zero data coverage. 3G nor LTE show at the top of the screen. This is such horse garbage.

    0
    Comment actions Permalink
  • I cannot change the MMSC URL, it prompts me for a security code to access the MMS stuff. I am immensely frustrated.

    0
    Comment actions Permalink
  • Lucas - the security code is the MSL i referenced in my first post. Each phone has a unique one and you can find it on the device info page for your phone under your Ting account. When you try to edit the MMSC URL and it asks for the security code, enter the MSL.

    0
    Comment actions Permalink
  • I too tried changing the MMSC URL. My phone was already set to the sprintpcs setting so I tried the other one (plspictures.) Didn't help at all. The only thing that DID help was changing my preferred data to 3G. Am chatting with Ting as I type this and so far the only solution they've come up with is changing the data to 3G and making sure that WiFi is off. They also asked if I'd checked to see if any updates were available for my phone but I told them that if this were the root of the problem others having the same problem probably would've suggested it by now. They took my name and added it to the list of people to be contacted once (if?) a solution is found.

    0
    Comment actions Permalink
  • I, too, tried both of the MMSC URLs, and that didn't fix the issue. I have my fingers crossed that the LMY48I build from August that "fixed" the stage fright think broke the MMS. Either way, I hope there's a patch to fix it.

    0
    Comment actions Permalink
  • This happened on my Nexus 5, and what Eric Nelson posted worked for mine. Please read his instructions carefully, I first thought mine had the correct url, and it did. I had other information in the two fields below, once I erased/deleted those to blank fields, and saved it, the phone reset, and now I have pictures again. I'm using the stock Google Hang Outs for my sms/mms.

    0
    Comment actions Permalink
  • Thanks Jim. I noticed what Eric wrote about those other two fields but I couldn't find them on my phone in order to check and/or clear them. Proxy URL? Port Number?

    As of this moment the less-than-ideal solution of switching to 3G in order to send or receive MMS is what I'm relying on...begrudgingly! If you wouldn't mind telling me where those other two fields might be I'd sure appreciate it. As you've probably already surmised I'm not exactly a genius when it comes to this stuff!

    BTW, related question: Is this an issue that unique to Nexus 5's or is it something that's plaguing all Ting users, Android and iPhon alike?

    Thanks to all who bother to answer and have a great weekend!

    0
    Comment actions Permalink
  • Hey David, I don't know why MMS isn't working for some people anymore. It was definitely a problem for a Nexus 5 and my Moto X, and why I posted my fix. I've read that using Hangouts configured for handling SMS/MMS has caused some issues with some people but I'm not convinced that's the biggest issue, otherwise more people, not just Ting users, would be seeing problems.

    iPhones use Apple's iMessage service, which doesn't necessarily use normal SMS/MMS. I'm not sure if they're affected with this problem.

    I only have a Nexus 5 and Moto X to play with, so if your phone doesn't have the proxy URL or port number, I can't help, sorry. I would try both MMS urls in the link I provided earlier to see if that helps.

    0
    Comment actions Permalink
  • HI, here's a little more explanation on why I found this post, and how it helped me for my particular problem - NO picture's coming or going on Google+ Hangouts MMS text messages.

    My Issues I was having:
    Last month I received a text from my son that had a photo attachment. I use the default Google+ Hangouts app on my phone for text message. The message had no picture, just a blank box saying attachment.....of something (sorry this is from memory) and it would expire in a week. When I clicked on the box, it gave me 2 options, delete or download. When I tried download, it never worked, I think it might of popped up a box saying download fail. Then every day I would get the same message and I would delete it until it finally expired. Then of course my son sends me another, and now I'm out searching the forums to find out how to fix this issue I was having. Before last month I was always able to send and receive pictures in my texts. People would text a picture and it would appear in my hangouts text message threads.

    My thinking:
    What I'm guessing what happened is that Sprint on Google's request was asked to prevent stagefright malware from attacking phones by simply sending an attached photo to any random number. This malware would give the senders complete access to your phone, so I'm guessing this was good that Sprint would implement this protection, because, a random picture sent to any android phone number would give the malware authors access to your phone. While searching on the forum, I came across this thread on how to fix it, and what Eric Nelson posted looked like something to try.

    First off, I'm using the Nexus 5 phone, and I just received the latest 5.1.1 Lollipop Update which is supposed to have the stagefright patch (i'm hoping it's true) and I would recommend that you make sure your phone is updated before you try this fix. You can see the latest revision in your settings, about phone section.

    What did I do:
    I followed Eric's steps, but I didn't have the proxy or port fields he mentioned, instead I had Gateway and Set Port fields. I already had the http://mms.sprintpcs.com, so I decided to clear these fields out anyways. After you delete the numbers in the fields, and hit the back button the phone will reset. Afterwards I did a couple test text messages, I sent a picture to my son and received a picture from my son using Android Hangouts. And they worked! It is definitely a risk to blank out the fields, but take a snapshot of your screen (Power Button + Volume Down held until the picture is snapped) or write them down just in case you need to put them back.

    I would of posted my step by step screen shots, but it doesn't look like I can attach them in this response.

    Good luck David, I hope this works on yours.

    7
    Comment actions Permalink
  • I installed the new LMY48M update yesterday. So far, so good. Does anyone have evidence that this issue was or was not resolved in this month's patch?

    0
    Comment actions Permalink
  • The LMY48M update didn't help my Nexus 5 at all. Forcing to 3G worked for me, then blanking out the Gateway and Port entries as mentioned by Jim K. got MMS working for me on LTE.

    0
    Comment actions Permalink
  • I already had the LMY48M update and the phone still had the problem of receiving photo messages "mms" (I think sending also was a problem-but it could of been blocked on the receiving phones end). I'm not sure if this matter but it may be why some don't have this issues and some of us do. I mainly have used Google Hangouts for my text messages, some time around spring I was not getting my texts through to my son. I would ask him if he saw my text and he would say not on the phone but later on his computer. That's when we realized when I would select a contact out of hangouts, it would prioritize sending to the google+ account and not to the sms phone. I had to search on Google and found out that I could force all the text messages to go through sms. Sorry, I don't remember exactly what I did, but I'm sure you can find it googling - it was something in the hangouts settings. Well I did this, and it solved my problem of messages not going to hangouts but instead of my friends phones.

    I wasn't having any issues with the photo attached messages after this setting's change. Instead, it was just about 1-2 months ago when it started, that mms photos stopped coming, and I couldn't download them either. I fixed it by using the method explained in this thread, and it worked for me. What I'm thinking is that the phone providers blocked this to prevent the attacks of stagefright on the phones and they still have it implemented because many people still don't have the updates on their phones. This is do to the broken way updates are distributed through the phone's manuacturers and how they partner with Google Android, that's why I have a Nexus phone I get them faster. I also believe the latest update, LMY48M, also contains a patch for stagefright. So I feel comfortable turning my photo texts back on, and having protection from the malware. Of course I could be completely wrong, but I'm sure I will survive if I'm wrong anyhow.

    0
    Comment actions Permalink
  • I had been using the 3G fix for a while - my Nexus 5 stopped receiving MMS in August like many of you. The 3G fix was pretty annoying but it worked. But I tried Eric's suggestion just now and it completely solved the issue for me. I am able to use LTE now and receive MMS. I did have to change the MMSC settings in the texting app that I started using after this initially happened (Yaata). If you are using a third-party texting app, check to see if there are advanced settings within the app for MMSC because you will need to update those as well for it to work. Good luck!

    0
    Comment actions Permalink
  • FYI: I had to update my wife's nexus 5 again after an update. My guess is that these parameters come from a network setting, and it is incorrect. The fix is easy, just remember to apply after an update.

    0
    Comment actions Permalink
  • Eric's workaround of removing the entries for "Gateway" and "Port" (This is what they were referred to in Android 6.0) worked for me and I can now send MMS again. However, I worry that each monthly security update from Google will reset these fields.

    2
    Comment actions Permalink
  • oh wow, clearing the Gateway and Port fields did it. I have MMS on LTE for the first time in 6-8 months. This is amazing! 

    0
    Comment actions Permalink
  • Keep in mind that you will need to revert to the working configuration after every PRL or system update.

    1
    Comment actions Permalink
  • This has been an absolute nightmare for me with two separate Nexus 5s. Nothing works and has devolved into no MMS, no 4G, and problems with regular texting now. If Ting has no recourse with the product it offers then I don't see the business model lasting. 

    1
    Comment actions Permalink
  • Ok Ting, it looks like we have a fix for this issue.  Like the posts before me, I nuked the gateway and port values and I can MMS on LTE via Hangouts. Case closed!  You should notify everyone who has a Nexus 5 because the 3G workaround is lame.

    5
    Comment actions Permalink
  • One more additional piece of information.  My Moto X (2013) had been frequently resetting the MMSC URL back to one that wasn't working.  I could go in and change it but it would revert back the next day.

    I chatted with Ting support and after a little back and forth, they recommended that I perform a carrier reset on my phone, which restarts the hands free activation.  The thought was that some configuration item somewhere was improperly configured and the reactivation would reset all settings back to Ting.  The carrier reset did not wipe my phone.

    For me (a Moto X on CDMA) this worked.  I recommend chatting with Ting support if this is still an issue.

    0
    Comment actions Permalink
  • Worked for my wife's Nexus 5 as well. Please, Ting, can we fix this at the network level??

    Doing a carrier reset didn't work. Had to manually alter the MMSC settings.

    0
    Comment actions Permalink
  • I have been having problems again since Friday. When I try to reset the mmcc settings I am asked for a service code. I was never asked for that before, and without it, I can't reset the settings and fix this problem.

    0
    Comment actions Permalink
  • Hey Barry! You can grab that code from your Ting Account. Click on Device Settings, then on your phone. It will be listed under "MSL".

    0
    Comment actions Permalink

Please sign in to leave a comment.