4G-LTE doesn't work on Sprint Galaxy S3 after upgrading to CM12, downgrading to CM11, then a nuke and pave reinstall of CM11?
Answered

Here's the short version of the situation is as such, everything (Minus the normally buggy camera. I just run 'su pkill -9 /system/bin/mediaserver' whenever the camera gives connection issues, aggravation evaded.), including 4G-LTE, was running nice and fine on CM11, but I saw that CM12 was officially available for my phone (d2spr), I wanted to upgrade from CM11 to CM12, but some features were iffy in CM12 (I don't remember if data even worked, but the camera didn't work, and some other stuff, and I couldn't live with that.), so I then attempted to downgrade. When I finished downgrading to CM11, the phone would boot, to then say something to the effect of "Phone has crashed.", followed by the phone locking up, then rebooting to the same screen. I tried a clean install (Without wiping the personal data.), and now everything is mostly normal, with the exception of the following, there is an optimizing apps process every boot, Google Partner setup crashes multiple times on every boot, and only 1x and 3G work, no 4G LTE, and coverage seems worse than usual. I'd also rather not nuke and repave my phone to get rid of the issues. Any suggestions would be heavily appreciated, as getting no data in 4g zones is painful to live with.

0

Comments

4 comments
  • If you can get the APN selections to show up, you can select the Ting APN, but first edit it to add 'default' in the APN Type field. It should say something like "mms,supl", just put 'default' and a comma in front.
    It might take some fiddling and a few reboots to let you edit the menu.

    I had a similar problem of no LET and after using a code (##4635*#*#) to dial into a menu I was able to get LTE back working after a few weeks of 3G.
    But I had already ordered a new phone so I was not too worried about bricking it.

    2
    Comment actions Permalink
  • Initially, I was not able to see or edit the APN list, so.... I did the following:

    Used ODIN to do a factory refresh back to Kit-Kat.
    Booted into Factory version and I refreshed the profile and updated the PRL. I already had the latest version of the modem since I had done that back in May for some reason.
    Next, I downloaded a root zip onto the phone then used ODIN to add the Philz boot loader.
    I then booted into the boot loader where I told it to do a Wipe Data / Factory Reset for a full OS install.
    Then, I installed CM12.1 with the appropriate Gapps.

    After booting, I was able to see the APNs and edit them

    Settings > Mobile Networks > Access Point Names

    I selected Ting rather than the default "Sprint LTE internet"

    Edit the Ting APN and change "APN Type" from “supl,mms” to “default,supl,mms”

    Save this and then wait a bit, it sometimes takes a little while before things update. Oh, and make sure that data is enabled.

    Hope this helps.

    1
    Comment actions Permalink
  • @Andrew_Pitonyak Since I'm a Linux user (I don't own, now have any access to any Windows computers.), there is no way I could use Odin. Is there any specific way you'd recommend to get the 4.4.2 Touchwiz rom, and would there be any specific way to backup my phone and restore (Personal and app data included.) too? I currently use TWRP. Also, my modem currently is reported as L710VPUDNJ2. Did upgrading to CM12 somehow give me the wrong modem, or is this just an old modem?

    @william_jeschke I tried dialing the number (##4635*#*#) just to get a 'not in your country' type of message. I'm pretty sure that was supposed to get me into the APN settings, but I can already navigate to there myself anyway, so that wasn't a problem. I did what you told me to do (Edit the Ting APN, and change APN type from "mms,supl" to "default,mms,supl".), but that didn't work. I think I might've f-ed my install.

    EDIT: Fixed a stupid error in my comment.

    0
    Comment actions Permalink
  • OMG, William Jeschke, have a millionty billion brownie points! I just deleted all the other APNs, and with that (And the edit to the Ting APN.), I have LTE! :D

    0
    Comment actions Permalink

Please sign in to leave a comment.