APN settings for CDMA device

I have CyanogenMod 12 on my Sprint Galaxy S4. I can't receive group text messages. I get data, text messages and MMS message, but not group messages. Everything is enabled on my device.

Does anyone have the APN settings I should be using?

0

Comments

19 comments
  • I am not sure but I don't think that CDMA has apn settings. Only GSM has apn settings.

  • Well, that's confusing because I can access the APN settings under Mobile Networks. Any idea on how I can enable group-texting?

  • CDMA does have APN settings. Group messages are sent as MMS, so you have to be able to receive them and even then some apps may not handle them.

    If you use Google Voice it does not do MMS.

  • Yes. I'm not using google voice, and using the built-in messaging app in Cyanogenmod. I get regular mms messages, just not pictures.

  • Hey Jeremy!

    I see that you were able to get in touch with chat support, if you have any further questions please feel free to reach out via email, chat or phone.

  • Hey Sarah or Jeremy, can you share what the answer was? I'm having the same problem except with a Nexus 5.

  • Yeah, I removed the MMS proxy port from the Ting settings and that did the trick.

  • Jeremy, could you post a copy of your APN settings here? I'm working with CM12 on a Sprint S4 as well and having the same issue. Thanks!

  • Here's 3 pics of the settings: https://goo.gl/photos/JFBT85PcESfYD7FDA

  • Thanks Jeremy!!

  • Thanks for sharing the photos Jeremy. It didn't solve my problem of no data (no mms or internet), but it did have the effect of removing the exclamation point on my reception status bars. So you might be onto something with this configuration. I'm using a Nexus 5. I'm not sure if you're in the same boat but I've read that this is a known bug for Nexus 5 phones on Sprint's network. Even though CDMA doesn't use APNs there is a bug with CM12 that requires you to correctly configure a APN (it doesn't make sense, that's why it's a bug).

  • This has worked for me for data (internet) and for text, including pictures.

    APN=n.t8.ispsn

    Proxy=not set

    port=not set

    Username=not set

    Password=not set

    Server=not set

    MMSC=http://mms.plspictures.com    

    (The MMSC setting is right off the ting knowledgebase article https://help.ting.com/hc/en-us/articles/205421048)

    MMS Proxy= not set

    MMS Port=80

    MCC=310

    MNC=120

    Authentication=not set

    APN Type=mms,default

    (The setting Ting recommends for their GSM phones also works. It is: deafult,admin,fota,mms,supl,hipri,internet,dun. Make sure there are no spaces after the comas or anywhere else. Some phones will automatically add a space after comas as you type, it can be easy to miss and can cause problems.

    APN Protocol=IPv4/IPv6

    APN roaming protocol=IPv4/IPv6

    Bearer=unspecified

    MVNO Type=none

  • I'm having an issue downloading MMS on my Ting-purchased CDMA phone.  Ting support has been trying to help me out, but it's been slow going (in part because I have access to the phone only at night after work).  So I've been researching on my own while waiting for additional instructions, and I found this.

    For me, unsetting the MMSC proxy solved the problem, however after a few minutes the setting reverted back to it's original value and MMS consequently stopped working.

    Has anyone else seen such behavior?  I'm using Google Hangouts on a 2nd Gen Moto E.  Is it possible the app is changing the setting, or could it be something more deeply embedded in the phone?  Any advice (or similar stories) would be appreciated.  Thanks.

     

  • Hey Anthony - Are you selecting "save" after making the change? You have to tap the menu option (three dots on the upper right) to find it.

  • Behavior seems to vary from phone to phone.  Some versions of this instruction said the phone would reboot automatically after making the change.  Others mentioned pressing "Save", but there was no such option for me (there's no APN section in my phone's settings, I have to use ##DATA# to get to the settings).

    Ting support suggested that I reboot immediately after making the change.  Another community thread I found suggested that Hangouts might be altering this configuration (or at least ignoring it in favor of one of it's own).  The instruction there was to disable SMS in Hangouts before making the change, then reenable it afterwards prompting Hangouts to refresh it's configuration from the phone's.

    I ended up doing both at once:

    1. Disable SMS in Hangouts
    2. Re-apply the MMSC Proxy change
    3. Reboot the phone manually
    4. Enable SMS in Hangouts

    So far, so good...

     

  • After working fine for the past couple of weeks, MMS suddenly stopped working again today on my CDMA Moto E.  I went back into the settings and the MMS Proxy was set again, and clearing it restored functionality just like last time.

    Does anyone understand why this might be happening?  Or for that matter why it was set in the first place if unset is the valid value?  Could this be something Sprint is doing to annoy MVNO customers in an attempt to drive us back to Sprint?

     

  • Surprisingly, these settings worked for me.

  • Luckily I found this page, and it helped me restore LTE on my Sprint Galaxy S4.

    Wanted to add, that another thing to check is if the selected access point has somehow been reset.

    The access point is selected from a list that appears in the 'APNs' panel, that is accessed by tapping on 'Access Point Names' in the 'Mobile network settings' panel.

    On my phone, I keep setting it to 'Ting', and after I do, LTE usually starts working again.  But after some time, it stops working.  When I go back to the 'APNs' panel again, I see that somehow it got reset back to 'Sprint ...' something or other.  Maybe this happens after a reboot.  I have to change it back to 'Ting' to get LTE working again.

  • Oh my goodness. That is the worst UI ever. Chris G, you saved my butt. I was going absolutely crazy, and after 3 days of banging my head against getting data on stock working on a new phone, then I finally managed that, finally flashed LineageOS, and data stopped working again. I was like 99% sure I remembered from last time that there was an apn fix, but last time I was on CM11 and someone posted a flashable fix, which didn't appear to exist for LineageOS, and I wasn't sure if they were compatible. Looked like an easy manual fix, but I tried it and it didn't do anything, and I was about to smash my phone in frustration, when I saw your post. 

     

    Anyone in the future reading this, if you tried to update your apn settings and nothing changed, yeah. You have to click a HIDDEN SAVE BUTTON or it silently doesn't save. Who came up with that UI?!

Please sign in to leave a comment.