Problems accessing the Adafruit IO system, with the GSM SIM X1 card.

I purchased the ting GSM SIM X1 card, and I am using it in the Adafruit FONA 808 GMS/GPRS module. I have been trying to connect to the Adafruit IO system so I can send and receive data. According to the software I am using, I need to provide the ting APN field before I can connect. According to your website, the ting APN field is "wholesale". I tried that name, but I still can't connect. Is it possible there is another APN that I need to use instead? Thanks in advance for any help you can provide.

Robert Fowler

0

Comments

5 comments
  • Hey Robert.

    When you try to use the network, I am assuming you are trying to connect to LTE.. Have you tried switching the channel to 3G instead? Usually with hotspots on our GSM network, you will need to have a 3G connection instead of an LTE connection. Let us know if this worked out, if not we might need to do some live extensive troubleshooting over either a chat or a phone call.

    0
    Comment actions Permalink
  • I got it to work. The example program Adafruit provided has bugs. I used another program, and now everything works find.

    0
    Comment actions Permalink
  • Would you mind sharing how you got it to connect? I've been struggling with the same issue! Their code does not work :(

    Thank you!

    0
    Comment actions Permalink
  • These commands were necessary for me to apply the Ting settings to the SIM808 (FONA) device:

    NOTE: All commands are followed by "carriage return" ('\r')and "newline" ('\n') characters

     

    AT+SAPBR=3,1,"CONTYPE","GPRS"

    AT+SAPBR=3,1,"APN","wholesale"

     

    The remaining list of commands:

    AT+CGATT=1

    AT+SAPBR=1,1 (confirm you have an IP address with `AT+SAPBR=2,1`)

    AT+HTTPINIT

    AT+HTTPPARA="CID",1

    AT+HTTPSSL=1 (optional if you need `https`)

    AT+HTTPPARA="URL","<url>"

    AT+HTTPPARA="CONTENT","application/json"

    AT+HTTPDATA=<strlen>,<data_timeout> (wait for the DOWNLOAD response)

    <json_data>

    AT+HTTPACTION=1

    AT+HTTPREAD (allow time for the server to respond before executing)

    AT+HTTPTERM

    AT+CGATT=0

     

     

    0
    Comment actions Permalink
  • Hi Robert

    Although your post was close to a year ago I'm hoping you'll get this. I'm trying to set up 6 FONAs (educational project) with TIng SIMs that are on the 2G network to ping sensor data to my server. This APN issue has me stumped. In another person's post the Ting tech responded that it may be necessary to get a business account to set up a private(?) APN. That isn't feasible. Can you elaborate on how you fixed the problem? Perhaps share your code? I'm actually using an Arduino with the FONA 808 GSM/GPS shield.

    Thanks,

    Maria

    0
    Comment actions Permalink

Please sign in to leave a comment.