Unable to send or receive MMS

A friend and I who are both on Ting(Sprint) had an ongoing problem sending and receiving MMS from each other and from others on different carriers.


I resolved it for both of us but have a concern on the workaround taken to resolve it. Jeannette Waud (Ting Help Center) suggested I document it here.


There's the problem.


When someone sent a MMS to us we would get a notification of it's arrival but trying to download the MMS would fail. There was no error message but the MMS would be stuck "downloading".


If we tried to send a MMS the MMS would say "sending" for several seconds and then say it would try again. The sending of the MMS never succeeded. Logging into our Ting accounts the Data allocation showed it had incremented by the MMS size.


I was using Google's Messenger app on my Nexus 5 for MMS and my friend was using Google's Hangouts app on his LG G4.


I followed Ting's MMS troubleshooting guide and nothing was wrong but I did take the suggested action of changing the MMSC URL from http://mms.sprintpcs.com to http://mms.plspictures.com. It made no difference.


I contacted Ting and Greg Lane (Ting Help Center) asked me to clear the MSSC port which had a value of 80. I did this but it too made no difference. Greg suggested I either tried a third party MMS app such as Textra or perform a phone factory reset.


Using the Textra app fixed the sending and receiving MSS on my Nexus 5 phone and my friend's LG G4 phone.


But I preferred to use Google's Messenger app and the suggestion on various forums on the web concerning issues with MMS suggested clearing the MMSC Gateway as well as the MMSC port.


I did that and now the Google Messenger app works for sending and receiving MMS. So it would appear there was an issue with the Gateway sever 68.28.31.7.


So my concern is overriding the carrier settings in the phone's MMSC is what's needed to use Google's Hangouts and Messenger apps for MMS. What is the effect in not using the Gateway server?

0

Comments

1 comment
  • Ever since switching to Ting and my new Motorola E4 Plus phone, trying to send an MMS message (group and/or media messages) failed miserably.
    After a LOT of attempts with settings and updates, finally got to a point of just changing my SMS client to Textra SMS.
    Tonight I finally successfully sent my FIRST MMS message.

    I don't mind using a different app for messaging, but I believe that something as rudimentary as texting (SMS or MMS) should just work, with the default clients. 

    0
    Comment actions Permalink

Please sign in to leave a comment.