What is "Allow Calls on Other Devices" ?

iPhone SE, iOS 11.4.1, Ting CDMA connection via Sprint.

In Settings > Cellular > Sprint, there's a toggle for "Calls on Other Devices." When selected (not even toggled to "on"), the screen changes and this is displayed:

What does this mean? I can't find an explanation in Apple's online iOS 11 manual. 

 

0

Comments

10 comments
  • Hey David, 

    On Apple's website, this is called WiFi Calling on iCloud-connected devices, and we support it. 

    What that means is that if you have a compatible Apple device (usually an iPad or Mac computer), you can make and receive your regular cell network calls via those devices provided they're signed into the same iCloud account. The only real limitation is that your iPhone and other iDevice have to be on the same WiFi network. 

    I use this a lot. Sometimes, I'll need to leave my iPhone plugged in upstairs because the battery is low. I can take my fully-charged iPad with me to the basement (no iPhone chargers there, and limited cell signal) and if I get a call or text message on my iPhone, my iPad rings just like my iPhone would. I can take the call, make another call, and send and receive iMessages AND text messages from my iPad. I can do the same on my Macbook Air.

    Not all carriers support this feature, but we do. If you have a Mac computer or an iPad, I highly suggest you try it out.

    0
    Comment actions Permalink
  • Hello Mitch,

    Thanks very much for your comment and the Apple doc reference explaining this setup. I was flummoxed as I forgot about FaceTime, and couldn't imagine how I might make a telephone call on my iMac. All is revealed!

    David

    0
    Comment actions Permalink
  • It is beyond cool to not have to have my phone on me at all times, and still get a call because I'm in front of my Macbook. And to be able to send actual text messages from my Mac without a third-party addon or requirement to use a separate website a la Android Messages is something I now take for granted.

    0
    Comment actions Permalink
  • Yes, that's the advantage, and should make things a bit easier here at home. Like you, I often find myself at a distance from my cell phone. Sometimes I almost long for the days of wired landlines, when I had a physical phone in every room.

    0
    Comment actions Permalink
  • It really does make the difference. It's like an every-room intercom using your iPhone.

    Here's a scary thought: we're almost at the point where people buying houses will have never used a landline phone in their lives.

    0
    Comment actions Permalink
  • Well...I can't get it to work yet. When I flip the iPhone toggle to "Allow Calls on Other Devices," the phone presents a dialog advising "Cannot Turn on Calls on Other Devices. FaceTime and iCloud must be signed in to the same Apple ID to enable Calls on Other Devices." The screen then reverts back to having the toggle "off."

    The iPhone and the Mac are both signed in on the same (my only) Apple ID, on both FaceTime and iCloud. I signed out of both FT and iCloud on both the iPhone and on the iMac, then I signed in again to both services on both machines. Then I restarted both devices. The toggle still refuses to stay on.

    Have you any suggestions?

    0
    Comment actions Permalink
  • Per Apple's troubleshooting on this

    If you can't add a device, check these items:

    • On your iPhone, make sure that Wi-Fi Calling and Allow Calls on Other Devices are on, and that your device appears under Allow Calls On.
    • Make sure that you're using the same Apple ID for FaceTime and iCloud on your iPhone and your other device.

    And, later in that same article:

    If you can't turn on or use Wi-Fi Calling, make sure that your carrier offers Wi-Fi Calling and that your devices have the latest software. Then, follow these steps if you can't turn on Wi-Fi Calling or make a Wi-Fi call. Wait two minutes before you go from one step to the next.

    1. Go to Settings > Phone > Wi-Fi Calling and make sure that Wi-Fi Calling is on.
    2. Restart your iPhone.
    3. Connect to a different Wi-Fi network. Not all Wi-Fi networks work with Wi-Fi Calling.
    4. Turn Wi-Fi Calling off and then on again.
    5. Go to Settings > General > Reset and tap Reset Network Settings

     

    0
    Comment actions Permalink
  • Specifically, make sure your other device (your Mac) is signed in and has Facetime enabled, too.

    0
    Comment actions Permalink
  • A mystery. I ran through all the steps a second time...and the iPhone now allows the toggle to stay in the "On" position, and my other machines are shown (also toggled "on") on the subsequent screen. I guess I'm just too quick to get frustrated.

    Thanks for the support.

    0
    Comment actions Permalink
  • Here's hoping you use it enough to have been worth the hassle.

    If you run into any other errors, just reply to this thread and let me know. I get an email every time someone posts in one of my threads, so I shouldn't be too far behind in following up with you to troubleshoot further.

    0
    Comment actions Permalink

Please sign in to leave a comment.