Updated Browser

I just got the message that you do not support older browsers. What a mistake.  I need to update my CC info and I got a message to do so in my Inbox which (at work) runs on IE. Hopefully, you realize that a lot of people will probably contact you while working throughout the day AND that we have no control over the version of browser that we use while here. Cross-browser functionality is imperative today (yes, including older browsers).  If your developers want to play with the latest tools all of the time then, well, its like the cart leading the horse.  You will maintain a better customer base if you do less to confuse your customers.  What an oversight.

0

Comments

2 comments
  • This is more a security feature than anything else, really. Older browsers are subject to security flaws that we cannot support if we want to be PCI-compliant.

    That risk far outweighs the benefit of supporting older browsers, even with the small inconvenience to the customers who need to use our website at work.

    If it really is that arduous, you can also just call us to update your credit card information. Our number is 855-846-4389. 

    0
    Comment actions Permalink
  • If you are stuck using an old unsecured browser at work, you can still use a modern browser even if you can't install anything on the computer.

    You can get a stand alone version of Firefox or other browsers from sites like Portableapps https://portableapps.com/apps/internet/firefox_portable which will work without being installed on the computer. You can use a USB or even a cloud drive like Dropbox to run the browser from.

    0
    Comment actions Permalink

Please sign in to leave a comment.