constantly scanning for wifi

I know this is a device issue, but I'm starting here.

Galaxy Note 3, constantly scans for wifi, even when it's connected to my home router.

I've searched, tried all the settings suggested, but it keeps chugging away. How do
I stop it?

0

Comments

9 comments
  • Hey Ken, 

    Per this xda thread on the issue, it doesn't scan in the background if you have the background scanning option disabled. Otherwise, scanning for additional or alternate WiFi networks is working as designed -- for example if you need to set up a smart device that provides its own WiFi network while connected to your home router. 

    0
    Comment actions Permalink
  • But mine apparently does scan frequently when I'm not on that screen (settings).

    The Sprint connections optimizer web page (with its broken link) comes up every time I
    wake the phone and often in the middle of things I'm doing- browsing, talking, texting, etc. 

    It did this for the longest time, and then stopped (recently), until I had to reset the phone to
    stop constant ads at my wake screen.

    0
    Comment actions Permalink
  • update and remove/disable stuff like sprints optimizer. android devs ruined linux wpa_supplicant interface. as insecure as possible. android 5/6 are just broken if u can install 7 than do it.

    0
    Comment actions Permalink
  • don't see any way to install android 7. did figure out I could stop optimizer notifications, thanks.

    0
    Comment actions Permalink
  • apparently sprint connections optimizer restarts itself and carries on
    intruding in what I'm doing... any way to delete the app?

    0
    Comment actions Permalink
  • settings > apps > the app > disable/remove
    if its branded malware download app inspector or a terminal app like terminal emulator. use the pm command to force disable or remove the package.

    i recall some function in and6 that reinstalls removed apps from backup when device is on wifi and charging. gave up on it but theres some fix to that im sure.

    0
    Comment actions Permalink
  • sprint connections manager cannot be removed, and it restarts itself without my input

    it was off when I turned my phone off last night, and it's again running when I turn the
    phone back on.

    looks like the only way to prevent it from working is to root my phone then uninstall it.
    not crazy about rooting my phone.

    0
    Comment actions Permalink
  • honestly best major change is: https://lineageosroms.com/moto-g-2015-osprey/
    to disable sprint crap download terminal emulator app and run; pm disable-user --user 0: x
    x being any/all sprint packages from; pm list packages | sort

    0
    Comment actions Permalink
  • turning off connections manager notifications eliminated the
    whole-screen intrusions, at least for now. wifi still constantly
    hunts and gives me a little notification, but i'm done.

    0
    Comment actions Permalink

Please sign in to leave a comment.