Ting App - "Request Timed Out"

I tried to log into the Ting app and it says Request Timed Out.

I've uninstalled and reinstalled and it still doesn't work.  I've changed my password and that hasn't helped it.  I am able to log in on the website on my computer, but it's nice to have the app when I'm away from home to check on things. 

I see this has happened in the past.  Any idea how I can fix this? 

I'm on a Samsung Galaxy A51.  I also tried it on my Samsung Galaxy S9 and it doesn't work on there either.



1 comment
  • Hey Tina, 

     We're not reporting any issues with the app at the moment. If you haven't tried clearing the app data that is what I would suggest doing first. It might just be that the app is remembering your previous session if you are on a WiFi router that you've connected over before. 

     You may also want to check if the app and operating system is up to date as well. If that is all in order and it's still not working we would have to get our team to look at it which we'll need to create a ticket through support for that. Send us an email to Help@ting.com and we can have it escalated to the team to investigate and see what's going on. 


Please sign in to leave a comment.