Samsung S7 SM-G930R4 calling doesn't work but data does

Hi,

Transferred my number and old Samsung S7 from U.S. Cellular on 11/22. 4G data and texting worked soon after installing Ting SIM and configuring APN, but calling/receiving calls has not. I have been able to call/receive calls during the evening/morning but not during the day. My phone always says that it has no bars, but when I can call/receive a call they magically appear and I have full service. Otherwise they are gone. I do still have 4G or "E" data and the ability to text, even MMS.

Any ideas on what to try?

 

0

Comments

8 comments
  • And of course shortly after typing that my phone shows cell signal and appears to work properly. I've turned my phone off and removed my SIM about 50 times but maybe that last time was what did it. We'll see if it lasts through the day. 

    0
    Comment actions Permalink
  • Hi Reed,

    Isn't that how it always goes! Glad to hear that you were able to get connected. If you run into any other trouble you can reach a live agent from our chat support from 8 AM - 11 PM EST: ting.com/support

    0
    Comment actions Permalink
  • It seems to be working much better now. I have noticed that I randomly get the "No Service" sign and cannot make any calls, but it seems to recover after a bit and my signal returns. Not sure why it's doing that but maybe it'll sort itself out as well.

    0
    Comment actions Permalink
  • Do you have a backup compatible device that you can try your SIM in by any chance? If yes try inserting your SIM into that phone, then restart it. This will let you know if the issue is specific to your device or perhaps a SIM issue. 

    Also, double-check to make sure VoLTE is enabled. You can check that by following these steps:

    1. From your home screen, press the Phone icon
    2. Tap More on the top right corner
    3. Scroll down and tap on Settings
    4. Tap on VoLTE
    5. Make sure that "Use VoLTE when available" is checked
    0
    Comment actions Permalink
  • I do not have anything besides an old iPhone available presently. I might be able to come up with another Android device somewhere. 

    Regarding VoLTE, I do not have that option where you specified. I couldn't seem to find it anywhere when Tech Support was trying to help me. When I put my old SIM in I did see an option that sounded like a similar setting but I can't remember the name now. 

    0
    Comment actions Permalink
  • I am still having trouble with no signal showing up and being unable to call on my phone. Sometimes I see signal, most of the time I do not. I can sometimes call people, sometimes I cannot. So far tech support acts like my phone is set up properly. What else can I check or are there limitations on my phone/software due to age/past carrier?

    0
    Comment actions Permalink
  • It could be VoLTe as it may be labelled as HD or Advanced Calling in your Settings, support could also help check if your calls are in fact using VoLTE.

    Beyond that attempting another device could help us see if the issue is local coverage (same issue on another device with similar compatibility) or device/setting related (we try another device and it works flawlessly) 

    0
    Comment actions Permalink
  • When I had US Cellular I did have an "HD" icon show up while talking on the phone but that is no longer there on the Ting SIM. There's an "Enhanced Calling" setting under "Mobile Networks" when I have the USC SIM in, but it's not there when I put the Ting SIM back in. 

    This is frustrating because it does work some of the time, just not all the time. I will try to come up with another phone to test it in, but right now I'm not very impressed. I like the Ting concept but this is not working out so far.

    0
    Comment actions Permalink

Please sign in to leave a comment.